summaryrefslogtreecommitdiffstats
path: root/meta/packages/xset/xset/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xset/xset/autofoo.patch')
-rw-r--r--meta/packages/xset/xset/autofoo.patch109
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/packages/xset/xset/autofoo.patch b/meta/packages/xset/xset/autofoo.patch
new file mode 100644
index 0000000000..039d1319e3
--- /dev/null
+++ b/meta/packages/xset/xset/autofoo.patch
@@ -0,0 +1,109 @@
1diff -urN xset.orig/Makefile.am xset/Makefile.am
2--- xset.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
3+++ xset/Makefile.am 2004-08-14 16:32:10.000000000 +0200
4@@ -0,0 +1,53 @@
5+#
6+# $Id: Makefile.am,v 1.2 2004/06/25 19:38:50 markh Exp $
7+#
8+# Copyright © 2003 Keith Packard
9+#
10+# Permission to use, copy, modify, distribute, and sell this software and its
11+# documentation for any purpose is hereby granted without fee, provided that
12+# the above copyright notice appear in all copies and that both that
13+# copyright notice and this permission notice appear in supporting
14+# documentation, and that the name of Keith Packard not be used in
15+# advertising or publicity pertaining to distribution of the software without
16+# specific, written prior permission. Keith Packard makes no
17+# representations about the suitability of this software for any purpose. It
18+# is provided "as is" without express or implied warranty.
19+#
20+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
21+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
22+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
23+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
24+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
25+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
26+# PERFORMANCE OF THIS SOFTWARE.
27+#
28+
29+AUTOMAKE_OPTIONS = 1.7 foreign
30+
31+AM_CFLAGS = @XSET_CFLAGS@
32+
33+bin_PROGRAMS = xset
34+
35+xset_SOURCES = xset.c
36+
37+xset_LDADD = @XSET_LIBS@
38+
39+man5_MANS=xset.man
40+
41+EXTRA_DIST= $(man5_MANS)
42+
43+MAINTAINERCLEANFILES = configure \
44+config.guess \
45+config.sub \
46+install-sh \
47+ltmain.sh \
48+missing \
49+mkinstalldirs \
50+aclocal.m4 \
51+Makefile.in \
52+depcomp \
53+autoscan.log \
54+configure.scan \
55+config.h \
56+config.h.in \
57+$(man5_MANS)
58diff -urN xset.orig/autogen.sh xset/autogen.sh
59--- xset.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
60+++ xset/autogen.sh 2004-08-14 16:27:56.000000000 +0200
61@@ -0,0 +1,3 @@
62+#! /bin/sh
63+autoreconf -v --install || exit 1
64+./configure --enable-maintainer-mode "$@"
65diff -urN xset.orig/configure.ac xset/configure.ac
66--- xset.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
67+++ xset/configure.ac 2004-08-17 14:21:25.000000000 +0200
68@@ -0,0 +1,41 @@
69+dnl
70+dnl $Id: configure.ac,v 1.1 2003/10/09 06:16:59 keithp Exp $
71+dnl
72+dnl Copyright © 2003 Keith Packard
73+dnl
74+dnl Permission to use, copy, modify, distribute, and sell this software and its
75+dnl documentation for any purpose is hereby granted without fee, provided that
76+dnl the above copyright notice appear in all copies and that both that
77+dnl copyright notice and this permission notice appear in supporting
78+dnl documentation, and that the name of Keith Packard not be used in
79+dnl advertising or publicity pertaining to distribution of the software without
80+dnl specific, written prior permission. Keith Packard makes no
81+dnl representations about the suitability of this software for any purpose. It
82+dnl is provided "as is" without express or implied warranty.
83+dnl
84+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
85+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
86+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
87+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
88+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
89+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
90+dnl PERFORMANCE OF THIS SOFTWARE.
91+dnl
92+
93+AC_PREREQ(2.57)
94+AC_INIT([xset],4.4.0,[],xset)
95+AC_CONFIG_SRCDIR([Makefile.am])
96+AM_INIT_AUTOMAKE([dist-bzip2])
97+AM_MAINTAINER_MODE
98+AM_CONFIG_HEADER(config.h)
99+
100+AC_PROG_CC
101+AC_PROG_INSTALL
102+AC_PROG_LN_S
103+AC_LIBTOOL_WIN32_DLL
104+AM_PROG_LIBTOOL
105+AC_PROG_MAKE_SET
106+
107+PKG_CHECK_MODULES(XSET, xext xextensions xmuu x11)
108+
109+AC_OUTPUT([Makefile])