summaryrefslogtreecommitdiffstats
path: root/meta/packages/xserver/xserver-kdrive_20060312.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xserver/xserver-kdrive_20060312.bb')
-rw-r--r--meta/packages/xserver/xserver-kdrive_20060312.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/packages/xserver/xserver-kdrive_20060312.bb b/meta/packages/xserver/xserver-kdrive_20060312.bb
new file mode 100644
index 0000000000..e5101a3579
--- /dev/null
+++ b/meta/packages/xserver/xserver-kdrive_20060312.bb
@@ -0,0 +1,52 @@
1PV = "0.0+cvs${FIXEDSRCDATE}"
2FIXEDSRCDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
3DEFAULT_PREFERENCE = "1"
4
5LICENSE = "MIT"
6DEPENDS = "tslib xproto libxdmcp xextproto xtrans libxau libx11 libxext libxrandr fixesproto damageproto libxfont resourceproto compositeproto xcalibrateext recordproto videoproto scrnsaverproto"
7PROVIDES = "virtual/xserver"
8RPROVIDES = "virtual/xserver"
9PACKAGES = "xserver-kdrive-mach64 xserver-kdrive-fbdev xserver-kdrive-vesa xserver-kdrive-mga xserver-kdrive-via xserver-kdrive-ati xserver-kdrive-fake xserver-kdrive-i810 xserver-kdrive-xephyr xserver-kdrive-epson ${PN}-doc ${PN}-dev ${PN}-locale"
10SECTION = "x11/base"
11DESCRIPTION = "X server from freedesktop.org"
12DESCRIPTION_xserver-kdrive-i810 = "X server from freedesktop.org, supporting i810 devices"
13DESCRIPTION_xserver-kdrive-ati = "X server from freedesktop.org, supporting ATI devices"
14DESCRIPTION_xserver-kdrive-mga = "X server from freedesktop.org, supporting MGA devices"
15DESCRIPTION_xserver-kdrive-vesa = "X server from freedesktop.org, supporting generic VESA devices"
16DESCRIPTION_xserver-kdrive-mach64 = "X server from freedesktop.org, supporting Mach64 devices"
17DESCRIPTION_xserver-kdrive-via = "X server from freedesktop.org, supporting VIA CLE266 devices"
18DESCRIPTION_xserver-kdrive-fbdev = "X server from freedesktop.org, supporting generic framebuffer devices"
19DESCRIPTION_xserver-kdrive-epson = "X server from freedesktop.org, supporting Epson S1D13806 devices"
20DESCRIPTION_xserver-kdrive-fake = "Fake X server"
21DESCRIPTION_xserver-kdrive-xephyr = "X server in an X window"
22
23PR = "r11"
24
25FILES_xserver-kdrive-fbdev = "${bindir}/Xfbdev"
26FILES_xserver-kdrive-ati = "${bindir}/Xati"
27FILES_xserver-kdrive-vesa = "${bindir}/Xvesa"
28FILES_xserver-kdrive-via = "${bindir}/Xvia"
29FILES_xserver-kdrive-mga = "${bindir}/Xmga"
30FILES_xserver-kdrive-mach64 = "${bindir}/Xmach64"
31FILES_xserver-kdrive-fake = "${bindir}/Xfake"
32FILES_xserver-kdrive-i810 = "${bindir}/Xi810"
33FILES_xserver-kdrive-epson = "${bindir}/Xepson"
34FILES_xserver-kdrive-xephyr = "${bindir}/Xephyr"
35
36SRC_URI = "${FREEDESKTOP_CVS}/xserver;module=xserver \
37 file://kmode.patch;patch=1 \
38 file://disable-apm.patch;patch=1 \
39 file://no-serial-probing.patch;patch=1 \
40 file://kdrive-evdev.patch;patch=1 \
41 file://kdrive-use-evdev.patch;patch=1 \
42 file://fbdev-not-fix.patch;patch=1"
43
44SRC_URI_append_mnci = " file://onlyfb.patch;patch=1"
45SRC_URI_append_poodle = " file://xserver-kdrive-poodle.patch;patch=1"
46PACKAGE_ARCH_poodle = "poodle"
47
48S = "${WORKDIR}/xserver"
49
50inherit autotools pkgconfig
51
52EXTRA_OECONF = "--enable-composite --disable-xinerama"