summaryrefslogtreecommitdiffstats
path: root/meta/packages/xserver/xserver-kdrive_20050207.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xserver/xserver-kdrive_20050207.bb')
-rw-r--r--meta/packages/xserver/xserver-kdrive_20050207.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/packages/xserver/xserver-kdrive_20050207.bb b/meta/packages/xserver/xserver-kdrive_20050207.bb
new file mode 100644
index 0000000000..32fdb82146
--- /dev/null
+++ b/meta/packages/xserver/xserver-kdrive_20050207.bb
@@ -0,0 +1,74 @@
1PV = "0.0+cvs${FIXEDSRCDATE}"
2FIXEDSRCDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
3DEFAULT_PREFERENCE = "1"
4
5LICENSE = "MIT"
6DEPENDS = "tslib xproto libxdmcp xextensions-1.0.1 xtrans libxau libx11 libxext libxrandr fixesext damageext libxfont resourceext compositeext xcalibrateext recordext"
7
8# Uncomment the following DEPENDS line and the commented line in SRC_URI
9# to make this snapshot build against X11R7.0 xlibs.
10#DEPENDS = "tslib xproto libxdmcp xextproto xtrans libxau libx11 libxext libxrandr fixesproto damageproto libxfont resourceproto compositeproto xcalibrateext recordproto"
11
12PROVIDES = "virtual/xserver"
13RPROVIDES = "virtual/xserver"
14PACKAGES = "xserver-kdrive-mach64 xserver-kdrive-fbdev xserver-kdrive-vesa xserver-kdrive-mga xserver-kdrive-via xserver-kdrive-ati xserver-kdrive-fake xserver-kdrive-i810 xserver-kdrive-xephyr xserver-kdrive-epson ${PN}-doc ${PN}-dev ${PN}-locale"
15SECTION = "x11/base"
16DESCRIPTION = "X server from freedesktop.org"
17DESCRIPTION_xserver-kdrive-i810 = "X server from freedesktop.org, supporting i810 devices"
18DESCRIPTION_xserver-kdrive-ati = "X server from freedesktop.org, supporting ATI devices"
19DESCRIPTION_xserver-kdrive-mga = "X server from freedesktop.org, supporting MGA devices"
20DESCRIPTION_xserver-kdrive-vesa = "X server from freedesktop.org, supporting generic VESA devices"
21DESCRIPTION_xserver-kdrive-mach64 = "X server from freedesktop.org, supporting Mach64 devices"
22DESCRIPTION_xserver-kdrive-via = "X server from freedesktop.org, supporting VIA CLE266 devices"
23DESCRIPTION_xserver-kdrive-fbdev = "X server from freedesktop.org, supporting generic framebuffer devices"
24DESCRIPTION_xserver-kdrive-epson = "X server from freedesktop.org, supporting Epson S1D13806 devices"
25DESCRIPTION_xserver-kdrive-fake = "Fake X server"
26DESCRIPTION_xserver-kdrive-xephyr = "X server in an X window"
27
28PR = "r10"
29
30FILES_xserver-kdrive-fbdev = "${bindir}/Xfbdev"
31FILES_xserver-kdrive-ati = "${bindir}/Xati"
32FILES_xserver-kdrive-vesa = "${bindir}/Xvesa"
33FILES_xserver-kdrive-via = "${bindir}/Xvia"
34FILES_xserver-kdrive-mga = "${bindir}/Xmga"
35FILES_xserver-kdrive-mach64 = "${bindir}/Xmach64"
36FILES_xserver-kdrive-fake = "${bindir}/Xfake"
37FILES_xserver-kdrive-i810 = "${bindir}/Xi810"
38FILES_xserver-kdrive-epson = "${bindir}/Xepson"
39FILES_xserver-kdrive-xephyr = "${bindir}/Xephyr"
40
41SRC_URI = "${FREEDESKTOP_CVS}/xserver;module=xserver;date=${FIXEDSRCDATE} \
42# file://build-20050207-against-X11R7.diff;patch=1 \
43 file://kmode.patch;patch=1 \
44 file://disable-apm.patch;patch=1 \
45 file://fbdev-not-fix.patch;patch=1 "
46
47SRC_URI_h3600 = "${FREEDESKTOP_CVS}/xserver;module=xserver;date=${FIXEDSRCDATE} \
48 file://kmode.patch;patch=1 \
49 file://faster-rotated.patch;patch=1 \
50 file://fbdev-not-fix.patch;patch=1 "
51
52
53SRC_URI_append_mnci = " file://onlyfb.patch;patch=1 \
54 file://faster-rotated.patch;patch=1 \
55 file://devfs.patch;patch=1"
56SRC_URI_append_collie = " file://faster-rotated.patch;patch=1"
57SRC_URI_append_poodle = " file://xserver-kdrive-poodle.patch;patch=1 \
58 file://faster-rotated.patch;patch=1"
59SRC_URI_append_spitz = " file://faster-rotated.patch;patch=1"
60SRC_URI_append_akita = " file://faster-rotated.patch;patch=1"
61
62PACKAGE_ARCH_mnci = "mnci"
63PACKAGE_ARCH_collie = "collie"
64PACKAGE_ARCH_poodle = "poodle"
65PACKAGE_ARCH_h3600 = "h3600"
66PACKAGE_ARCH_spitz = "spitz"
67PACKAGE_ARCH_akita = "akita"
68
69S = "${WORKDIR}/xserver"
70
71inherit autotools pkgconfig
72
73LDFLAGS += " -lXfont -lXdmcp -lXau "
74EXTRA_OECONF = "--enable-static=no --disable-static --enable-composite --disable-xinerama"