summaryrefslogtreecommitdiffstats
path: root/meta/packages/xserver/xserver-kdrive/build-20050207-against-X11R7.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xserver/xserver-kdrive/build-20050207-against-X11R7.diff')
-rw-r--r--meta/packages/xserver/xserver-kdrive/build-20050207-against-X11R7.diff464
1 files changed, 464 insertions, 0 deletions
diff --git a/meta/packages/xserver/xserver-kdrive/build-20050207-against-X11R7.diff b/meta/packages/xserver/xserver-kdrive/build-20050207-against-X11R7.diff
new file mode 100644
index 0000000000..596e498b80
--- /dev/null
+++ b/meta/packages/xserver/xserver-kdrive/build-20050207-against-X11R7.diff
@@ -0,0 +1,464 @@
1--- xserver.orig/configure.ac 2006-03-11 16:27:42.000000000 +0100
2+++ xserver/configure.ac 2006-03-11 16:46:51.000000000 +0100
3@@ -79,7 +79,7 @@
4 # tslib touchscreen driver
5 AC_CHECK_HEADERS([tslib.h])
6
7-REQUIRED_MODULES="randr render fixesext damageext xextensions xfont xproto xtrans xau"
8+REQUIRED_MODULES="randrproto renderproto fixesproto damageproto xextproto xfont xproto xtrans xau"
9
10 DEFAULT_FONT_PATH="/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
11 DEFAULT_VENDOR_STRING="freedesktop.org"
12--- xserver.orig/dix/dispatch.c 2006-03-11 16:27:42.000000000 +0100
13+++ xserver/dix/dispatch.c 2006-03-11 16:30:59.000000000 +0100
14@@ -79,7 +79,6 @@
15 #endif
16
17 #include "windowstr.h"
18-#include "fontstruct.h"
19 #include "dixfontstr.h"
20 #include "gcstruct.h"
21 #include "selection.h"
22--- xserver.orig/dix/glyphcurs.c 2006-03-11 16:27:42.000000000 +0100
23+++ xserver/dix/glyphcurs.c 2006-03-11 16:31:57.000000000 +0100
24@@ -51,7 +51,6 @@
25 #include <config.h>
26 #endif
27 #include "misc.h"
28-#include "fontstruct.h"
29 #include "dixfontstr.h"
30 #include "scrnintstr.h"
31 #include "gcstruct.h"
32--- xserver.orig/dix/main.c 2006-03-11 16:27:42.000000000 +0100
33+++ xserver/dix/main.c 2006-03-11 16:32:05.000000000 +0100
34@@ -89,7 +89,6 @@
35 #include "colormap.h"
36 #include "colormapst.h"
37 #include "cursorstr.h"
38-#include "font.h"
39 #include "opaque.h"
40 #include "servermd.h"
41 #include "site.h"
42--- xserver.orig/dix/swaprep.c 2006-03-11 16:27:42.000000000 +0100
43+++ xserver/dix/swaprep.c 2006-03-11 16:32:24.000000000 +0100
44@@ -57,7 +57,7 @@
45 #include <X11/Xproto.h>
46 #include "misc.h"
47 #include "dixstruct.h"
48-#include "fontstruct.h"
49+#include "dixfont.h"
50 #include "scrnintstr.h"
51 #include "swaprep.h"
52 #include "globals.h"
53--- xserver.orig/dix/xpstubs.c 2006-03-11 16:27:42.000000000 +0100
54+++ xserver/dix/xpstubs.c 2006-03-11 16:32:34.000000000 +0100
55@@ -31,7 +31,7 @@
56 #include <config.h>
57 #endif
58 #include "misc.h"
59-#include "font.h"
60+#include "dixfont.h"
61
62 Bool
63 XpClientIsBitmapClient(ClientPtr client)
64--- xserver.orig/fb/fbglyph.c 2006-03-11 16:27:42.000000000 +0100
65+++ xserver/fb/fbglyph.c 2006-03-11 16:52:01.000000000 +0100
66@@ -26,7 +26,6 @@
67 #include <config.h>
68 #endif
69 #include "fb.h"
70-#include "fontstruct.h"
71 #include "dixfontstr.h"
72
73 Bool
74--- xserver.orig/hw/kdrive/epson/epson13806draw.c 2006-03-11 16:27:42.000000000 +0100
75+++ xserver/hw/kdrive/epson/epson13806draw.c 2006-03-11 16:34:56.000000000 +0100
76@@ -38,7 +38,6 @@
77 #include "pixmapstr.h"
78 #include "regionstr.h"
79 #include "mistruct.h"
80-#include "fontstruct.h"
81 #include "dixfontstr.h"
82 #include "fb.h"
83 #include "migc.h"
84--- xserver.orig/hw/kdrive/i810/i810draw.c 2006-03-11 16:27:42.000000000 +0100
85+++ xserver/hw/kdrive/i810/i810draw.c 2006-03-11 16:34:41.000000000 +0100
86@@ -51,7 +51,6 @@
87 #include "pixmapstr.h"
88 #include "regionstr.h"
89 #include "mistruct.h"
90-#include "fontstruct.h"
91 #include "dixfontstr.h"
92 #include "fb.h"
93 #include "migc.h"
94--- xserver.orig/hw/kdrive/src/kaa.c 2006-03-11 16:27:42.000000000 +0100
95+++ xserver/hw/kdrive/src/kaa.c 2006-03-11 16:35:39.000000000 +0100
96@@ -29,7 +29,6 @@
97 #endif
98 #include "kdrive.h"
99 #include "kaa.h"
100-#include "fontstruct.h"
101 #include "dixfontstr.h"
102
103 #define DEBUG_MIGRATE 0
104--- xserver.orig/include/dixfont.h 2006-03-11 16:27:42.000000000 +0100
105+++ xserver/include/dixfont.h 2006-03-11 16:43:25.000000000 +0100
106@@ -27,10 +27,10 @@
107 #define DIXFONT_H 1
108
109 #include "dix.h"
110-#include "font.h"
111-#include "fontconf.h"
112+#include <X11/fonts/font.h>
113+#include <X11/fonts/fontconf.h>
114 #include "closure.h"
115-#include "fontstruct.h"
116+#include <X11/fonts/fontstruct.h>
117
118 #define NullDIXFontProp ((DIXFontPropPtr)0)
119
120--- xserver.orig/include/dixfontstr.h 2006-03-11 16:27:42.000000000 +0100
121+++ xserver/include/dixfontstr.h 2006-03-11 16:43:31.000000000 +0100
122@@ -27,7 +27,6 @@
123
124 #include "servermd.h"
125 #include "dixfont.h"
126-#include "fontstruct.h"
127 #include "closure.h"
128 #define NEED_REPLIES
129 #include "X11/Xproto.h" /* for xQueryFontReply */
130--- xserver.orig/mi/mibstore.c 2006-03-11 16:27:42.000000000 +0100
131+++ xserver/mi/mibstore.c 2006-03-11 16:36:26.000000000 +0100
132@@ -57,7 +57,6 @@
133 #include "gcstruct.h"
134 #include "windowstr.h"
135 #include "pixmapstr.h"
136-#include "fontstruct.h"
137 #include "dixfontstr.h"
138 #include "dixstruct.h" /* For requestingClient */
139 #include "mi.h"
140--- xserver.orig/mi/miglblt.c 2006-03-11 16:27:42.000000000 +0100
141+++ xserver/mi/miglblt.c 2006-03-11 16:53:52.000000000 +0100
142@@ -55,7 +55,6 @@
143 #include <X11/Xmd.h>
144 #include <X11/Xproto.h>
145 #include "misc.h"
146-#include "fontstruct.h"
147 #include "dixfontstr.h"
148 #include "gcstruct.h"
149 #include "windowstr.h"
150--- xserver.orig/mi/mi.h 2006-03-11 16:27:42.000000000 +0100
151+++ xserver/mi/mi.h 2006-03-11 16:36:16.000000000 +0100
152@@ -54,7 +54,7 @@
153 #include "validate.h"
154 #include "window.h"
155 #include "gc.h"
156-#include "font.h"
157+#include "dixfont.h"
158 #include "input.h"
159 #include "cursor.h"
160
161--- xserver.orig/mi/miinitext.c 2006-03-11 16:27:42.000000000 +0100
162+++ xserver/mi/miinitext.c 2006-03-11 16:36:41.000000000 +0100
163@@ -54,6 +54,8 @@
164 #include "extension.h"
165 #include "micmap.h"
166 #include "xext.h"
167+#include "pixmap.h"
168+#include "gc.h"
169
170 #ifdef NOPEXEXT /* sleaze for Solaris cpp building XsunMono */
171 #undef PEXEXT
172--- xserver.orig/mi/mipolytext.c 2006-03-11 16:27:42.000000000 +0100
173+++ xserver/mi/mipolytext.c 2006-03-11 16:36:48.000000000 +0100
174@@ -63,7 +63,6 @@
175 #include <X11/Xproto.h>
176 #include "misc.h"
177 #include "gcstruct.h"
178-#include "fontstruct.h"
179 #include "dixfontstr.h"
180 #include "mi.h"
181
182--- xserver.orig/mi/misprite.c 2006-03-11 16:27:42.000000000 +0100
183+++ xserver/mi/misprite.c 2006-03-11 16:37:00.000000000 +0100
184@@ -42,7 +42,6 @@
185 # include "input.h"
186 # include "mi.h"
187 # include "cursorstr.h"
188-# include "font.h"
189 # include "scrnintstr.h"
190 # include "colormapst.h"
191 # include "windowstr.h"
192@@ -50,7 +49,6 @@
193 # include "mipointer.h"
194 # include "mispritest.h"
195 # include "dixfontstr.h"
196-# include "fontstruct.h"
197 #ifdef RENDER
198 # include "mipict.h"
199 #endif
200--- xserver.orig/miext/damage/damage.c 2006-03-11 16:27:42.000000000 +0100
201+++ xserver/miext/damage/damage.c 2006-03-11 16:37:17.000000000 +0100
202@@ -28,9 +28,7 @@
203 #include <X11/X.h>
204 #include "scrnintstr.h"
205 #include "windowstr.h"
206-#include "font.h"
207 #include "dixfontstr.h"
208-#include "fontstruct.h"
209 #include "mi.h"
210 #include "regionstr.h"
211 #include "globals.h"
212--- xserver.orig/miext/shadow/shadow.c 2006-03-11 16:27:42.000000000 +0100
213+++ xserver/miext/shadow/shadow.c 2006-03-11 16:38:13.000000000 +0100
214@@ -29,9 +29,7 @@
215 #include <X11/X.h>
216 #include "scrnintstr.h"
217 #include "windowstr.h"
218-#include "font.h"
219 #include "dixfontstr.h"
220-#include "fontstruct.h"
221 #include "mi.h"
222 #include "regionstr.h"
223 #include "globals.h"
224--- xserver.orig/miext/shadow/shalloc.c 2006-03-11 16:27:42.000000000 +0100
225+++ xserver/miext/shadow/shalloc.c 2006-03-11 16:38:25.000000000 +0100
226@@ -29,9 +29,7 @@
227 #include <X11/X.h>
228 #include "scrnintstr.h"
229 #include "windowstr.h"
230-#include "font.h"
231 #include "dixfontstr.h"
232-#include "fontstruct.h"
233 #include "mi.h"
234 #include "regionstr.h"
235 #include "globals.h"
236--- xserver.orig/miext/shadow/shpacked.c 2006-03-11 16:27:42.000000000 +0100
237+++ xserver/miext/shadow/shpacked.c 2006-03-11 16:38:33.000000000 +0100
238@@ -28,9 +28,7 @@
239 #include <X11/X.h>
240 #include "scrnintstr.h"
241 #include "windowstr.h"
242-#include "font.h"
243 #include "dixfontstr.h"
244-#include "fontstruct.h"
245 #include "mi.h"
246 #include "regionstr.h"
247 #include "globals.h"
248--- xserver.orig/miext/shadow/shplanar8.c 2006-03-11 16:27:42.000000000 +0100
249+++ xserver/miext/shadow/shplanar8.c 2006-03-11 16:38:44.000000000 +0100
250@@ -28,9 +28,7 @@
251 #include <X11/X.h>
252 #include "scrnintstr.h"
253 #include "windowstr.h"
254-#include "font.h"
255 #include "dixfontstr.h"
256-#include "fontstruct.h"
257 #include "mi.h"
258 #include "regionstr.h"
259 #include "globals.h"
260--- xserver.orig/miext/shadow/shplanar.c 2006-03-11 16:27:42.000000000 +0100
261+++ xserver/miext/shadow/shplanar.c 2006-03-11 16:38:39.000000000 +0100
262@@ -28,9 +28,7 @@
263 #include <X11/X.h>
264 #include "scrnintstr.h"
265 #include "windowstr.h"
266-#include "font.h"
267 #include "dixfontstr.h"
268-#include "fontstruct.h"
269 #include "mi.h"
270 #include "regionstr.h"
271 #include "globals.h"
272--- xserver.orig/miext/shadow/shrotate.c 2006-03-11 16:27:42.000000000 +0100
273+++ xserver/miext/shadow/shrotate.c 2006-03-11 16:38:56.000000000 +0100
274@@ -28,9 +28,7 @@
275 #include <X11/X.h>
276 #include "scrnintstr.h"
277 #include "windowstr.h"
278-#include "font.h"
279 #include "dixfontstr.h"
280-#include "fontstruct.h"
281 #include "mi.h"
282 #include "regionstr.h"
283 #include "globals.h"
284--- xserver.orig/miext/shadow/shrotpack.h 2006-03-11 16:27:42.000000000 +0100
285+++ xserver/miext/shadow/shrotpack.h 2006-03-11 16:39:02.000000000 +0100
286@@ -30,9 +30,7 @@
287 #include <X11/X.h>
288 #include "scrnintstr.h"
289 #include "windowstr.h"
290-#include "font.h"
291 #include "dixfontstr.h"
292-#include "fontstruct.h"
293 #include "mi.h"
294 #include "regionstr.h"
295 #include "globals.h"
296--- xserver.orig/miext/shadow/shrotpackYX.h 2006-03-11 16:27:42.000000000 +0100
297+++ xserver/miext/shadow/shrotpackYX.h 2006-03-11 16:39:08.000000000 +0100
298@@ -25,9 +25,7 @@
299 #include <X11/X.h>
300 #include "scrnintstr.h"
301 #include "windowstr.h"
302-#include "font.h"
303 #include "dixfontstr.h"
304-#include "fontstruct.h"
305 #include "mi.h"
306 #include "regionstr.h"
307 #include "globals.h"
308--- xserver.orig/os/xstrans.c 2006-03-11 16:27:42.000000000 +0100
309+++ xserver/os/xstrans.c 2006-03-11 16:39:31.000000000 +0100
310@@ -27,4 +27,4 @@
311
312 #include "config.h"
313
314-#include <transport.c>
315+#include <X11/Xtrans/transport.c>
316--- xserver.orig/os/xstrans.h 2006-03-11 16:27:42.000000000 +0100
317+++ xserver/os/xstrans.h 2006-03-11 16:39:37.000000000 +0100
318@@ -25,4 +25,4 @@
319 #define XSERV_t
320 #define TRANS_SERVER
321
322-#include <Xtrans.h>
323+#include <X11/Xtrans/Xtrans.h>
324--- xserver.orig/Xext/shmint.h 2006-03-11 16:27:42.000000000 +0100
325+++ xserver/Xext/shmint.h 2006-03-11 16:29:24.000000000 +0100
326@@ -32,27 +32,6 @@
327 #include "pixmap.h"
328 #include "gc.h"
329
330-typedef struct _ShmFuncs {
331- PixmapPtr (* CreatePixmap)(ScreenPtr pScreen,
332- int width,
333- int height,
334- int depth,
335- char *addr);
336- void (* PutImage)(DrawablePtr dst,
337- GCPtr pGC,
338- int depth,
339- unsigned int format,
340- int w,
341- int h,
342- int sx,
343- int sy,
344- int sw,
345- int sh,
346- int dx,
347- int dy,
348- char *data);
349-} ShmFuncs, *ShmFuncsPtr;
350-
351 void
352 ShmRegisterFuncs(ScreenPtr pScreen, ShmFuncsPtr funcs);
353
354--- xserver.orig/Xext/syncint.h 2006-03-11 16:27:42.000000000 +0100
355+++ xserver/Xext/syncint.h 2006-03-11 16:30:16.000000000 +0100
356@@ -48,7 +48,7 @@
357 PERFORMANCE OF THIS SOFTWARE.
358
359 ******************************************************************/
360-/* $Id: syncint.h,v 3.1 2003-11-02 19:56:10 keithp Exp $ */
361+/* $Id: syncint.h,v 3.2 2005-04-20 18:42:31 clee Exp $ */
362
363 #ifndef _SYNCINT_H_
364 #define _SYNCINT_H_
365@@ -57,26 +57,10 @@
366
367 #define CARD64 XSyncValue /* XXX temporary! need real 64 bit values for Alpha */
368
369-typedef struct _SyncCounter {
370- ClientPtr client; /* Owning client. 0 for system counters */
371- XSyncCounter id; /* resource ID */
372- CARD64 value; /* counter value */
373- struct _SyncTriggerList *pTriglist; /* list of triggers */
374- Bool beingDestroyed; /* in process of going away */
375- struct _SysCounterInfo *pSysCounterInfo; /* NULL if not a system counter */
376-} SyncCounter;
377-
378 /*
379 * The System Counter interface
380 */
381
382-typedef enum {
383- XSyncCounterNeverChanges,
384- XSyncCounterNeverIncreases,
385- XSyncCounterNeverDecreases,
386- XSyncCounterUnrestricted
387-} SyncCounterType;
388-
389 typedef void
390 (*SyncQueryValueProcPtr) (pointer pCounter,
391 CARD64 *freshvalue);
392@@ -86,16 +70,6 @@
393 CARD64 *lessthan,
394 CARD64 *greaterthan);
395
396-typedef struct _SysCounterInfo {
397- char *name;
398- CARD64 resolution;
399- CARD64 bracket_greater;
400- CARD64 bracket_less;
401- SyncCounterType counterType; /* how can this counter change */
402- SyncQueryValueProcPtr QueryValue;
403- SyncBracketValuesProcPtr BracketValues;
404-} SysCounterInfo;
405-
406 struct _SyncTrigger;
407
408 typedef Bool
409@@ -108,55 +82,6 @@
410 typedef void
411 (*SyncCounterDestroyedProcPtr) (struct _SyncTrigger *pTrigger);
412
413-typedef struct _SyncTrigger {
414- SyncCounter *pCounter;
415- CARD64 wait_value; /* wait value */
416- unsigned int value_type; /* Absolute or Relative */
417- unsigned int test_type; /* transition or Comparision type */
418- CARD64 test_value; /* trigger event threshold value */
419- SyncCheckTriggerProcPtr CheckTrigger;
420- SyncTriggerFiredProcPtr TriggerFired;
421- SyncCounterDestroyedProcPtr CounterDestroyed;
422-} SyncTrigger;
423-
424-typedef struct _SyncTriggerList {
425- SyncTrigger *pTrigger;
426- struct _SyncTriggerList *next;
427-} SyncTriggerList;
428-
429-typedef struct _SyncAlarmClientList {
430- ClientPtr client;
431- XID delete_id;
432- struct _SyncAlarmClientList *next;
433-} SyncAlarmClientList;
434-
435-typedef struct _SyncAlarm {
436- SyncTrigger trigger;
437- ClientPtr client;
438- XSyncAlarm alarm_id;
439- CARD64 delta;
440- int events;
441- int state;
442- SyncAlarmClientList *pEventClients;
443-} SyncAlarm;
444-
445-typedef struct {
446- ClientPtr client;
447- CARD32 delete_id;
448- int num_waitconditions;
449-} SyncAwaitHeader;
450-
451-typedef struct {
452- SyncTrigger trigger;
453- CARD64 event_threshold;
454- SyncAwaitHeader *pHeader;
455-} SyncAwait;
456-
457-typedef union {
458- SyncAwaitHeader header;
459- SyncAwait await;
460-} SyncAwaitUnion;
461-
462 pointer
463 SyncCreateSystemCounter(char *name,
464 CARD64 inital_value,