summaryrefslogtreecommitdiffstats
path: root/meta/packages/xrdb/xrdb/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xrdb/xrdb/autofoo.patch')
-rw-r--r--meta/packages/xrdb/xrdb/autofoo.patch132
1 files changed, 132 insertions, 0 deletions
diff --git a/meta/packages/xrdb/xrdb/autofoo.patch b/meta/packages/xrdb/xrdb/autofoo.patch
new file mode 100644
index 0000000000..b30a46bc36
--- /dev/null
+++ b/meta/packages/xrdb/xrdb/autofoo.patch
@@ -0,0 +1,132 @@
1diff -urN xrdb.orig/Imakefile xrdb/Imakefile
2--- xrdb.orig/Imakefile 2004-04-23 21:55:03.000000000 +0200
3+++ xrdb/Imakefile 1970-01-01 01:00:00.000000000 +0100
4@@ -1,19 +0,0 @@
5-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:56 cpqbld Exp $
6-
7-
8-
9-
10-XCOMM $XFree86: xc/programs/xrdb/Imakefile,v 3.6tsi Exp $
11-
12-#ifdef PatheticCpp
13- CPPDEFS = -DPATHETICCPP
14-#endif
15-#if HasMkstemp
16- CPPDEFS = -DHAS_MKSTEMP
17-#endif
18-XCOMM Due to ill make parsing the cpp is passed directly in source file
19- DEFINES = -DCPP="\"$(CPP)\"" $(CPPDEFS)
20- DEPLIBS = $(DEPXMUULIB) $(DEPXONLYLIB)
21-LOCAL_LIBRARIES = $(XMUULIB) $(XONLYLIB)
22-
23-SimpleProgramTarget(xrdb)
24diff -urN xrdb.orig/Makefile.am xrdb/Makefile.am
25--- xrdb.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
26+++ xrdb/Makefile.am 2004-08-14 16:05:01.000000000 +0200
27@@ -0,0 +1,53 @@
28+#
29+# $Id: Makefile.am,v 1.2 2004/06/25 19:38:50 markh Exp $
30+#
31+# Copyright © 2003 Keith Packard
32+#
33+# Permission to use, copy, modify, distribute, and sell this software and its
34+# documentation for any purpose is hereby granted without fee, provided that
35+# the above copyright notice appear in all copies and that both that
36+# copyright notice and this permission notice appear in supporting
37+# documentation, and that the name of Keith Packard not be used in
38+# advertising or publicity pertaining to distribution of the software without
39+# specific, written prior permission. Keith Packard makes no
40+# representations about the suitability of this software for any purpose. It
41+# is provided "as is" without express or implied warranty.
42+#
43+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
44+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
45+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
46+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
47+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
48+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
49+# PERFORMANCE OF THIS SOFTWARE.
50+#
51+
52+AUTOMAKE_OPTIONS = 1.7 foreign
53+
54+AM_CFLAGS = @XRDB_CFLAGS@
55+
56+bin_PROGRAMS = xrdb
57+
58+xrdb_SOURCES = xrdb.c
59+
60+xrdb_LDADD = @XRDB_LIBS@
61+
62+man5_MANS=xrdb.man
63+
64+EXTRA_DIST= $(man5_MANS)
65+
66+MAINTAINERCLEANFILES = configure \
67+config.guess \
68+config.sub \
69+install-sh \
70+ltmain.sh \
71+missing \
72+mkinstalldirs \
73+aclocal.m4 \
74+Makefile.in \
75+depcomp \
76+autoscan.log \
77+configure.scan \
78+config.h \
79+config.h.in \
80+$(man5_MANS)
81diff -urN xrdb.orig/autogen.sh xrdb/autogen.sh
82--- xrdb.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
83+++ xrdb/autogen.sh 2004-08-14 15:57:35.000000000 +0200
84@@ -0,0 +1,3 @@
85+#! /bin/sh
86+autoreconf -v --install || exit 1
87+./configure --enable-maintainer-mode "$@"
88diff -urN xrdb.orig/configure.ac xrdb/configure.ac
89--- xrdb.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
90+++ xrdb/configure.ac 2004-08-14 16:03:31.000000000 +0200
91@@ -0,0 +1,41 @@
92+dnl
93+dnl $Id: configure.ac,v 1.1 2003/10/09 06:16:59 keithp Exp $
94+dnl
95+dnl Copyright © 2003 Keith Packard
96+dnl
97+dnl Permission to use, copy, modify, distribute, and sell this software and its
98+dnl documentation for any purpose is hereby granted without fee, provided that
99+dnl the above copyright notice appear in all copies and that both that
100+dnl copyright notice and this permission notice appear in supporting
101+dnl documentation, and that the name of Keith Packard not be used in
102+dnl advertising or publicity pertaining to distribution of the software without
103+dnl specific, written prior permission. Keith Packard makes no
104+dnl representations about the suitability of this software for any purpose. It
105+dnl is provided "as is" without express or implied warranty.
106+dnl
107+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
108+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
109+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
110+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
111+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
112+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
113+dnl PERFORMANCE OF THIS SOFTWARE.
114+dnl
115+
116+AC_PREREQ(2.57)
117+AC_INIT([xrdb],4.4.0,[],xrdb)
118+AC_CONFIG_SRCDIR([Makefile.am])
119+AM_INIT_AUTOMAKE([dist-bzip2])
120+AM_MAINTAINER_MODE
121+AM_CONFIG_HEADER(config.h)
122+
123+AC_PROG_CC
124+AC_PROG_INSTALL
125+AC_PROG_LN_S
126+AC_LIBTOOL_WIN32_DLL
127+AM_PROG_LIBTOOL
128+AC_PROG_MAKE_SET
129+
130+PKG_CHECK_MODULES(XRDB, xext xmuu x11)
131+
132+AC_OUTPUT([Makefile])