summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-xserver/xserver-xf86-dri-lite
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xorg-xserver/xserver-xf86-dri-lite')
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch33
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch28
2 files changed, 45 insertions, 16 deletions
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch
index 2341e40bca..8b82de2223 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/crosscompile.patch
@@ -1,19 +1,20 @@
1Index: xorg-server-1.7.99.2/configure.ac 1diff --git a/configure.ac b/configure.ac
2=================================================================== 2index b3b752c..600500b 100644
3--- xorg-server-1.7.99.2.orig/configure.ac 2010-01-29 16:38:49.000000000 +0000 3--- a/configure.ac
4+++ xorg-server-1.7.99.2/configure.ac 2010-01-29 16:42:39.000000000 +0000 4+++ b/configure.ac
5@@ -503,14 +503,10 @@ 5@@ -523,13 +523,9 @@ dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d,
6 6 dnl otherwise uses standard subdirectories of FONTROOTDIR. When cross
7 dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d, 7 dnl compiling, assume default font path uses standard FONTROOTDIR directories.
8 dnl otherwise uses standard subdirectories of FONTROOTDIR 8 DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/"
9-AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d], 9-if test "$cross_compiling" != yes; then
10- [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'], 10- AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d],
11- [ 11- [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'],
12 DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/" 12- [case $host_os in
13 case $host_os in 13+ case $host_os in
14 darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;; 14 darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;;
15 esac 15- esac])
16- ]) 16-fi
17+ esac
17 AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]), 18 AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]),
18 [ FONTPATH="$withval" ], 19 [ FONTPATH="$withval" ],
19 [ FONTPATH="${DEFAULT_FONT_PATH}" ]) 20 [ FONTPATH="${DEFAULT_FONT_PATH}" ])
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch
new file mode 100644
index 0000000000..cd408c7bc2
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/macro_tweak.patch
@@ -0,0 +1,28 @@
1This is the revised version of files/macro_tweak.patch for
2xorg-server 1.8.99.904.
3
4the files/macro_tweak.patch can not removed now since it is used by
5xserver-kdrive-1.7.99.2 and xserver-xf86-lite_1.7.99.2. Once they
6are all upgraded to 1.8.99.904, the the files/macro_tweak.patch
7can be safely replace by this patch.
8
9Signed-off-by: Yu Ke <ke.yu@intel.com>
10
11diff --git a/xorg-server.m4 b/xorg-server.m4
12index bdecf62..040fdb8 100644
13--- a/xorg-server.m4
14+++ b/xorg-server.m4
15@@ -28,10 +28,12 @@ dnl
16 # Checks for the $1 define in xorg-server.h (from the sdk). If it
17 # is defined, then add $1 to $REQUIRED_MODULES.
18
19+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
20+
21 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
22 AC_REQUIRE([PKG_PROG_PKG_CONFIG])
23 SAVE_CFLAGS="$CFLAGS"
24- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
25+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
26 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
27 #include "xorg-server.h"
28 #if !defined $1