summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-xserver/xserver-kdrive-1.4.99.901/enable-tslib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xorg-xserver/xserver-kdrive-1.4.99.901/enable-tslib.patch')
-rw-r--r--meta/packages/xorg-xserver/xserver-kdrive-1.4.99.901/enable-tslib.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/xorg-xserver/xserver-kdrive-1.4.99.901/enable-tslib.patch b/meta/packages/xorg-xserver/xserver-kdrive-1.4.99.901/enable-tslib.patch
new file mode 100644
index 0000000000..0519b3093a
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-kdrive-1.4.99.901/enable-tslib.patch
@@ -0,0 +1,24 @@
1--- /tmp/configure.ac 2008-04-16 10:52:15.016442542 +0200
2+++ xorg-server-1.4.99.901/configure.ac 2008-04-16 10:54:23.786428934 +0200
3@@ -1925,7 +1925,7 @@
4 AC_CHECK_LIB([rt], [nanosleep], XEPHYR_LIBS="$XEPHYR_LIBS -lrt"))
5
6 if test "x$TSLIB" = xyes; then
7- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
8+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
9 if test "x$HAVE_TSLIB" = xno; then
10 AC_MSG_ERROR([tslib must be installed to build the tslib driver. See http://tslib.berlios.de/])
11 fi
12@@ -1949,10 +1949,10 @@
13 ;;
14 esac
15 KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
16- KDRIVE_LOCAL_LIBS="$TSLIB_LIBS $DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
17+ KDRIVE_LOCAL_LIBS="$DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
18 KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $FB_LIB $MI_LIB $KDRIVE_PURE_LIBS"
19 KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $KDRIVE_OS_LIB $OS_LIB"
20- KDRIVE_LIBS="$KDRIVE_LOCAL_LIBS $XSERVER_SYS_LIBS"
21+ KDRIVE_LIBS="$TSLIB_LIBS $KDRIVE_LOCAL_LIBS $XSERVER_SYS_LIBS"
22
23 # check if we can build Xephyr
24 PKG_CHECK_MODULES(XEPHYR, $XEPHYR_REQUIRED_LIBS, [xephyr="yes"], [xephyr="no"])