summaryrefslogtreecommitdiffstats
path: root/meta/packages/xauth/xauth/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/xauth/xauth/autofoo.patch')
-rw-r--r--meta/packages/xauth/xauth/autofoo.patch148
1 files changed, 148 insertions, 0 deletions
diff --git a/meta/packages/xauth/xauth/autofoo.patch b/meta/packages/xauth/xauth/autofoo.patch
new file mode 100644
index 0000000000..d279a6f4fc
--- /dev/null
+++ b/meta/packages/xauth/xauth/autofoo.patch
@@ -0,0 +1,148 @@
1diff -urN xauth.orig/Imakefile xauth/Imakefile
2--- xauth.orig/Imakefile 2004-04-23 21:54:38.000000000 +0200
3+++ xauth/Imakefile 1970-01-01 01:00:00.000000000 +0100
4@@ -1,19 +0,0 @@
5-XCOMM $Xorg: Imakefile,v 1.3 2000/08/17 19:54:11 cpqbld Exp $
6-
7-
8-
9-
10-XCOMM $XFree86: xc/programs/xauth/Imakefile,v 3.5tsi Exp $
11-
12- DEPLIBS = $(DEPXAUTHLIB) $(DEPXMUULIB) $(DEPXLIB)
13-LOCAL_LIBRARIES = $(XAUTHLIB) $(XMUULIB) $(XLIB)
14- SRCS = xauth.c gethost.c process.c parsedpy.c
15- OBJS = xauth.o gethost.o process.o parsedpy.o
16- CONN_DEFINES = $(CONNECTION_FLAGS)
17- DEPEND_DEFINES = $(CONN_DEFINES) $(SIGNAL_DEFINES)
18-
19-ComplexProgramTarget(xauth)
20-
21-SpecialCObjectRule(gethost,$(ICONFIGFILES),$(CONN_DEFINES) $(SIGNAL_DEFINES))
22-SpecialCObjectRule(process,$(ICONFIGFILES),$(CONN_DEFINES) $(SIGNAL_DEFINES))
23-SpecialCObjectRule(parsedpy,$(ICONFIGFILES),$(CONN_DEFINES))
24diff -urN xauth.orig/Makefile.am xauth/Makefile.am
25--- xauth.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
26+++ xauth/Makefile.am 2004-08-14 13:20:37.000000000 +0200
27@@ -0,0 +1,53 @@
28+#
29+# $Id: Makefile.am,v 1.2 2004/06/25 19:38:50 markh Exp $
30+#
31+# Copyright © 2003 Keith Packard
32+#
33+# Permission to use, copy, modify, distribute, and sell this software and its
34+# documentation for any purpose is hereby granted without fee, provided that
35+# the above copyright notice appear in all copies and that both that
36+# copyright notice and this permission notice appear in supporting
37+# documentation, and that the name of Keith Packard not be used in
38+# advertising or publicity pertaining to distribution of the software without
39+# specific, written prior permission. Keith Packard makes no
40+# representations about the suitability of this software for any purpose. It
41+# is provided "as is" without express or implied warranty.
42+#
43+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
44+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
45+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
46+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
47+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
48+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
49+# PERFORMANCE OF THIS SOFTWARE.
50+#
51+
52+AUTOMAKE_OPTIONS = 1.7 foreign
53+
54+AM_CFLAGS = @XAUTH_CFLAGS@
55+
56+bin_PROGRAMS = xauth
57+
58+xauth_SOURCES = gethost.c parsedpy.c process.c xauth.c xauth.h
59+
60+xauth_LDADD = @XAUTH_LIBS@
61+
62+man5_MANS=xauth.man
63+
64+EXTRA_DIST= $(man5_MANS)
65+
66+MAINTAINERCLEANFILES = configure \
67+config.guess \
68+config.sub \
69+install-sh \
70+ltmain.sh \
71+missing \
72+mkinstalldirs \
73+aclocal.m4 \
74+Makefile.in \
75+depcomp \
76+autoscan.log \
77+configure.scan \
78+config.h \
79+config.h.in \
80+$(man5_MANS)
81diff -urN xauth.orig/autogen.sh xauth/autogen.sh
82--- xauth.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
83+++ xauth/autogen.sh 2004-08-14 13:15:46.000000000 +0200
84@@ -0,0 +1,3 @@
85+#! /bin/sh
86+autoreconf -v --install || exit 1
87+./configure --enable-maintainer-mode "$@"
88diff -urN xauth.orig/configure.ac xauth/configure.ac
89--- xauth.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
90+++ xauth/configure.ac 2004-08-14 23:43:54.000000000 +0200
91@@ -0,0 +1,57 @@
92+dnl
93+dnl $Id: configure.ac,v 1.1 2003/10/09 06:16:59 keithp Exp $
94+dnl
95+dnl Copyright © 2003 Keith Packard
96+dnl
97+dnl Permission to use, copy, modify, distribute, and sell this software and its
98+dnl documentation for any purpose is hereby granted without fee, provided that
99+dnl the above copyright notice appear in all copies and that both that
100+dnl copyright notice and this permission notice appear in supporting
101+dnl documentation, and that the name of Keith Packard not be used in
102+dnl advertising or publicity pertaining to distribution of the software without
103+dnl specific, written prior permission. Keith Packard makes no
104+dnl representations about the suitability of this software for any purpose. It
105+dnl is provided "as is" without express or implied warranty.
106+dnl
107+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
108+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
109+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
110+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
111+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
112+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
113+dnl PERFORMANCE OF THIS SOFTWARE.
114+dnl
115+
116+AC_PREREQ(2.57)
117+AC_INIT([xauth],4.4.0,[],xauth)
118+AC_CONFIG_SRCDIR([Makefile.am])
119+AM_INIT_AUTOMAKE([dist-bzip2])
120+AM_MAINTAINER_MODE
121+AM_CONFIG_HEADER(config.h)
122+
123+AC_PROG_CC
124+AC_PROG_INSTALL
125+AC_PROG_LN_S
126+AC_LIBTOOL_WIN32_DLL
127+AM_PROG_LIBTOOL
128+AC_PROG_MAKE_SET
129+
130+PKG_CHECK_MODULES(XAUTH, xau xext xmuu x11)
131+
132+AC_TYPE_SIGNAL
133+
134+# Transport selection
135+AC_ARG_ENABLE(unix-transport,[ --disable-unix-transport ], [UNIXCONN=$enableval], [UNIXCONN=yes])
136+AC_ARG_ENABLE(tcp-transport, [ --disable-tcp-transport ], [TCPCONN=$enableval], [TCPCONN=yes])
137+AC_ARG_ENABLE(ipv6, [ --disable-ipv6 ], [IPV6CONN=$enableval], [IPV6CONN=yes])
138+if test "$UNIXCONN" = "yes"; then
139+ AC_DEFINE(UNIXCONN,1,[Support UNIX socket connections])
140+fi
141+if test "$TCPCONN" = "yes"; then
142+ AC_DEFINE(TCPCONN,1,[Support TCP socket connections])
143+fi
144+if test "$IPV6CONN" = "yes"; then
145+ AC_DEFINE(IPv6,1,[Support IPv6 for TCP connections])
146+fi
147+
148+AC_OUTPUT([Makefile])