summaryrefslogtreecommitdiffstats
path: root/meta/packages/wbxml
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/wbxml')
-rw-r--r--meta/packages/wbxml/files/no-doc-install.patch15
-rw-r--r--meta/packages/wbxml/wbxml2_0.9.2.bb24
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/wbxml/files/no-doc-install.patch b/meta/packages/wbxml/files/no-doc-install.patch
new file mode 100644
index 0000000000..16084e60e6
--- /dev/null
+++ b/meta/packages/wbxml/files/no-doc-install.patch
@@ -0,0 +1,15 @@
1--- wbxml2-0.9.2/Makefile.am.old 2007-01-03 19:50:24.000000000 +0000
2+++ wbxml2-0.9.2/Makefile.am 2007-01-03 19:50:39.000000000 +0000
3@@ -24,9 +24,9 @@
4 TODO\
5 doxygen.h
6
7-install-data-local:
8- $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
9- cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
10+#install-data-local:
11+# $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
12+# cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
13
14 dist-bz2: distdir
15 sed -e "s/tar.gz/tar.bz2/g" $(distdir)/wbxml2.spec > $(distdir)/wbxml2.spec.aux
diff --git a/meta/packages/wbxml/wbxml2_0.9.2.bb b/meta/packages/wbxml/wbxml2_0.9.2.bb
new file mode 100644
index 0000000000..cb1d733370
--- /dev/null
+++ b/meta/packages/wbxml/wbxml2_0.9.2.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "parser for wbxml"
2LICENSE = "GPLv2"
3
4DEPENDS = "libxml2 sed-native"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
7 file://no-doc-install.patch;patch=1"
8
9inherit autotools pkgconfig
10
11do_configure_append() {
12 sed -i s:-I/usr/include::g Makefile
13 sed -i s:-I/usr/include::g */Makefile
14}
15
16do_stage() {
17 autotools_stage_all
18}
19
20PACKAGES += "${PN}-tools"
21
22FILES_${PN}-tools = "${bindir}"
23FILES_${PN} = "${libdir}/*.so.*"
24