diff options
Diffstat (limited to 'meta/packages/util-linux/files/fix-make-c.patch')
-rw-r--r-- | meta/packages/util-linux/files/fix-make-c.patch | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/packages/util-linux/files/fix-make-c.patch b/meta/packages/util-linux/files/fix-make-c.patch new file mode 100644 index 0000000000..bf1082e85c --- /dev/null +++ b/meta/packages/util-linux/files/fix-make-c.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From: Karel Zak <kzak@redhat.com> | ||
2 | Date: Mon, 11 May 2009 09:49:00 +0000 (+0200) | ||
3 | Subject: build-sys: fix "make -C" bug | ||
4 | X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=2ef7d41e6bbb7c842c06e911ffc562335a467b5d | ||
5 | |||
6 | build-sys: fix "make -C" bug | ||
7 | |||
8 | Running: | ||
9 | |||
10 | ./configure --with-fsprobe=builtin | ||
11 | make -C mount mount | ||
12 | |||
13 | causes the following error: | ||
14 | |||
15 | gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -include ../config.h | ||
16 | -I../include -DLOCALEDIR=\"/home/matthew/util-linux-ng/share/locale\" | ||
17 | -fsigned-char -I../libs/blkid/src -g -O2 -MT mount-setproctitle.o | ||
18 | -MD -MP -MF .deps/mount-setproctitle.Tpo -c -o mount-setproctitle.o | ||
19 | `test -f '../lib/setproctitle.c' || echo './'`../lib/setproctitle.c mv | ||
20 | -f .deps/mount-setproctitle.Tpo .deps/mount-setproctitle.Po | ||
21 | make -C | ||
22 | make: option requires an argument -- 'C' | ||
23 | Usage: make [options] [target] ... | ||
24 | ... | ||
25 | |||
26 | Reported-by: Matthew Burgess <matthew@linuxfromscratch.org> | ||
27 | Signed-off-by: Karel Zak <kzak@redhat.com> | ||
28 | --- | ||
29 | |||
30 | diff --git a/config/include-Makefile.am b/config/include-Makefile.am | ||
31 | index b42a0c3..d5da619 100644 | ||
32 | --- a/config/include-Makefile.am | ||
33 | +++ b/config/include-Makefile.am | ||
34 | @@ -17,6 +17,7 @@ dist_noinst_DATA = $(dist_man_MANS) | ||
35 | # Paths to in-tree libraries (use ul_ prefix to avoid possible collisions) | ||
36 | # | ||
37 | ul_libblkid_srcdir = $(top_srcdir)/libs/blkid/src | ||
38 | +ul_libblkid_builddir = $(top_builddir)/libs/blkid/src | ||
39 | ul_libblkid_la = $(top_builddir)/libs/blkid/src/libblkid.la | ||
40 | |||
41 | $(ul_libblkid_la): | ||