summaryrefslogtreecommitdiffstats
path: root/meta/packages/update-rc.d
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/update-rc.d')
-rw-r--r--meta/packages/update-rc.d/update-rc.d-0.6/copyright.patch27
-rw-r--r--meta/packages/update-rc.d/update-rc.d_0.6.bb22
-rw-r--r--meta/packages/update-rc.d/update-rc.d_0.7.bb21
3 files changed, 70 insertions, 0 deletions
diff --git a/meta/packages/update-rc.d/update-rc.d-0.6/copyright.patch b/meta/packages/update-rc.d/update-rc.d-0.6/copyright.patch
new file mode 100644
index 0000000000..bfe9cb8181
--- /dev/null
+++ b/meta/packages/update-rc.d/update-rc.d-0.6/copyright.patch
@@ -0,0 +1,27 @@
1Index: update-rc.d
2===================================================================
3RCS file: /cvs/apps/update-rc.d/update-rc.d,v
4retrieving revision 1.6
5retrieving revision 1.7
6diff -u -r1.6 -r1.7
7--- update-rc.d/update-rc.d 31 Dec 2004 12:21:40 -0000 1.6
8+++ update-rc.d/update-rc.d 31 Dec 2004 16:39:09 -0000 1.7
9@@ -2,8 +2,17 @@
10 #
11 # update-rc.d Update the links in /etc/rc[0-9S].d/
12 #
13-# Phil Blundell <pb@handhelds.org> 2003-06-26
14+# (c) 2003, 2004 Phil Blundell <pb@handhelds.org>
15 #
16+# This program is free software; you can redistribute it and/or modify
17+# it under the terms of the GNU General Public License as published by
18+# the Free Software Foundation; either version 2, or (at your option)
19+# any later version.
20+#
21+# This program is distributed in the hope that it will be useful,
22+# but WITHOUT ANY WARRANTY; without even the implied warranty of
23+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24+# GNU General Public License for more details.
25
26 initd="/etc/init.d"
27 etcd="/etc/rc"
diff --git a/meta/packages/update-rc.d/update-rc.d_0.6.bb b/meta/packages/update-rc.d/update-rc.d_0.6.bb
new file mode 100644
index 0000000000..ba2f551371
--- /dev/null
+++ b/meta/packages/update-rc.d/update-rc.d_0.6.bb
@@ -0,0 +1,22 @@
1SECTION = "base"
2PRIORITY = "standard"
3DESCRIPTION = "Manage symlinks in /etc/rcN.d"
4MAINTAINER = "Phil Blundell <pb@handhelds.org>"
5LICENSE = "GPL"
6S = "${WORKDIR}/update-rc.d"
7PR = "r1"
8
9SRC_URI = "${HANDHELDS_CVS};module=apps/update-rc.d;tag=r0_6 \
10 file://copyright.patch;patch=1"
11
12do_compile() {
13}
14
15do_stage() {
16 install -m 0755 ${S}/update-rc.d ${STAGING_BINDIR}/
17}
18
19do_install() {
20 install -d ${D}${sbindir}
21 install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
22}
diff --git a/meta/packages/update-rc.d/update-rc.d_0.7.bb b/meta/packages/update-rc.d/update-rc.d_0.7.bb
new file mode 100644
index 0000000000..ae1cfe83fe
--- /dev/null
+++ b/meta/packages/update-rc.d/update-rc.d_0.7.bb
@@ -0,0 +1,21 @@
1SECTION = "base"
2PRIORITY = "standard"
3DESCRIPTION = "Manage symlinks in /etc/rcN.d"
4MAINTAINER = "Phil Blundell <pb@handhelds.org>"
5LICENSE = "GPL"
6S = "${WORKDIR}/update-rc.d"
7PR = "r0"
8
9SRC_URI = "${HANDHELDS_CVS};module=apps/update-rc.d;tag=r0_7"
10
11do_compile() {
12}
13
14do_stage() {
15 install -m 0755 ${S}/update-rc.d ${STAGING_BINDIR}/
16}
17
18do_install() {
19 install -d ${D}${sbindir}
20 install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
21}