diff options
Diffstat (limited to 'meta/packages/update-alternatives')
6 files changed, 74 insertions, 0 deletions
diff --git a/meta/packages/update-alternatives/update-alternatives-cworth-native_0.99.154.bb b/meta/packages/update-alternatives/update-alternatives-cworth-native_0.99.154.bb new file mode 100644 index 0000000000..99f8c07244 --- /dev/null +++ b/meta/packages/update-alternatives/update-alternatives-cworth-native_0.99.154.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require update-alternatives-cworth.inc | ||
2 | inherit native | ||
3 | |||
4 | PROVIDES += "virtual/update-alternatives" | ||
5 | |||
6 | do_stage () { | ||
7 | install -d ${sbindir} \ | ||
8 | ${libdir}/ipkg/alternatives | ||
9 | |||
10 | install -m 0755 update-alternatives ${sbindir}/update-alternatives | ||
11 | } | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-cworth.inc b/meta/packages/update-alternatives/update-alternatives-cworth.inc new file mode 100644 index 0000000000..e5bf1c8e27 --- /dev/null +++ b/meta/packages/update-alternatives/update-alternatives-cworth.inc | |||
@@ -0,0 +1,6 @@ | |||
1 | LICENSE = "GPL" | ||
2 | SECTION = "base" | ||
3 | MAINTAINER = "Chris Larson <kergoth@handhelds.org>" | ||
4 | SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')}" | ||
5 | S = "${WORKDIR}/ipkg/C" | ||
6 | PACKAGE_ARCH = "all" | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-cworth_0.99.154.bb b/meta/packages/update-alternatives/update-alternatives-cworth_0.99.154.bb new file mode 100644 index 0000000000..18dab4e65f --- /dev/null +++ b/meta/packages/update-alternatives/update-alternatives-cworth_0.99.154.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require update-alternatives-cworth.inc | ||
2 | |||
3 | RPROVIDES_${PN} = "update-alternatives" | ||
4 | |||
5 | do_install () { | ||
6 | install -d ${D}${sbindir} \ | ||
7 | ${D}${sysconfdir}/alternatives \ | ||
8 | ${D}${libdir}/ipkg/alternatives | ||
9 | |||
10 | install -m 0755 update-alternatives ${D}${sbindir}/update-alternatives | ||
11 | } | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb b/meta/packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb new file mode 100644 index 0000000000..f621e6a13f --- /dev/null +++ b/meta/packages/update-alternatives/update-alternatives-dpkg-native_1.13.22.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | require update-alternatives-dpkg.inc | ||
2 | inherit native | ||
3 | |||
4 | PROVIDES += "virtual/update-alternatives" | ||
5 | DEPENDS += "perl-native dpkg-native" | ||
6 | DEFAULT_PREFERENCE = "-1" | ||
7 | |||
8 | do_stage () { | ||
9 | install -d ${sbindir} \ | ||
10 | ${localstatedir}/dpkg/alternatives \ | ||
11 | ${sysconfdir}/alternatives | ||
12 | |||
13 | install -m 0755 scripts/update-alternatives ${sbindir}/update-alternatives | ||
14 | } | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-dpkg.inc b/meta/packages/update-alternatives/update-alternatives-dpkg.inc new file mode 100644 index 0000000000..e767ed632b --- /dev/null +++ b/meta/packages/update-alternatives/update-alternatives-dpkg.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | LICENSE = "GPL" | ||
2 | SECTION = "base" | ||
3 | MAINTAINER = "Chris Larson <kergoth@handhelds.org>" | ||
4 | SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz" | ||
5 | S = "${WORKDIR}/dpkg-${PV}" | ||
6 | PACKAGE_ARCH = "all" | ||
7 | |||
8 | do_patch () { | ||
9 | cat ${S}/scripts/update-alternatives.pl | \ | ||
10 | sed -n -e ' | ||
11 | /^\$admindir=.*staging/{ | ||
12 | x | ||
13 | s/^.*$/$D=$ENV{"D"} || ""\;/; | ||
14 | p; | ||
15 | x; | ||
16 | s,^\$admindir=.*staging.*$,$admindir="$D${localstatedir}/dpkg"\;,; | ||
17 | }; | ||
18 | s,^\$altdir=.*$,$altdir="$D${sysconfdir}/alternatives"\;,; | ||
19 | p;' > ${S}/scripts/update-alternatives | ||
20 | } | ||
diff --git a/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb b/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb new file mode 100644 index 0000000000..a07d5e36d4 --- /dev/null +++ b/meta/packages/update-alternatives/update-alternatives-dpkg_1.13.22.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require update-alternatives-dpkg.inc | ||
2 | |||
3 | RPROVIDES_${PN} = "update-alternatives" | ||
4 | RDEPENDS_${PN} = "perl dpkg" | ||
5 | |||
6 | do_install () { | ||
7 | install -d ${D}${sbindir} \ | ||
8 | ${D}${localstatedir}/dpkg/alternatives \ | ||
9 | ${D}${sysconfdir}/alternatives | ||
10 | |||
11 | install -m 0755 scripts/update-alternatives ${D}${sbindir}/update-alternatives | ||
12 | } | ||