summaryrefslogtreecommitdiffstats
path: root/meta/packages/udev/udev-084/flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/udev/udev-084/flags.patch')
-rw-r--r--meta/packages/udev/udev-084/flags.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/packages/udev/udev-084/flags.patch b/meta/packages/udev/udev-084/flags.patch
new file mode 100644
index 0000000000..f144a5f622
--- /dev/null
+++ b/meta/packages/udev/udev-084/flags.patch
@@ -0,0 +1,52 @@
1--- udev-081/Makefile.orig 2006-01-29 12:36:33.000000000 +0100
2+++ udev-081/Makefile 2006-01-29 12:36:58.000000000 +0100
3@@ -123,29 +123,29 @@
4 STRIP = $(CROSS)strip
5 STRIPCMD = $(STRIP) -s
6
7-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
8+override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
9 WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
10 -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
11 -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
12-CFLAGS += $(WARNINGS)
13+override CFLAGS += $(WARNINGS)
14
15 LDFLAGS = -Wl,-warn-common
16
17 OPTFLAGS = -Os
18-CFLAGS += $(OPTFLAGS)
19+override CFLAGS += $(OPTFLAGS)
20
21 ifeq ($(strip $(USE_LOG)),true)
22- CFLAGS += -DUSE_LOG
23+ override CFLAGS += -DUSE_LOG
24 endif
25
26 # if DEBUG is enabled, then we do not strip
27 ifeq ($(strip $(DEBUG)),true)
28- CFLAGS += -DDEBUG
29+ override CFLAGS += -DDEBUG
30 STRIPCMD =
31 endif
32
33 ifeq ($(strip $(USE_GCOV)),true)
34- CFLAGS += -fprofile-arcs -ftest-coverage
35+ override CFLAGS += -fprofile-arcs -ftest-coverage
36 LDFLAGS += -fprofile-arcs
37 endif
38
39@@ -160,11 +160,11 @@
40 ifeq ($(strip $(USE_SELINUX)),true)
41 UDEV_OBJS += udev_selinux.o
42 LIB_OBJS += -lselinux -lsepol
43- CFLAGS += -DUSE_SELINUX
44+ override CFLAGS += -DUSE_SELINUX
45 endif
46
47 ifeq ($(strip $(USE_STATIC)),true)
48- CFLAGS += -DUSE_STATIC
49+ override CFLAGS += -DUSE_STATIC
50 LDFLAGS += -static
51 endif
52