diff options
Diffstat (limited to 'meta/packages/uclibc/uclibc_0.9.30.1.bb')
-rw-r--r-- | meta/packages/uclibc/uclibc_0.9.30.1.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/uclibc/uclibc_0.9.30.1.bb b/meta/packages/uclibc/uclibc_0.9.30.1.bb new file mode 100644 index 0000000000..14b59b74e3 --- /dev/null +++ b/meta/packages/uclibc/uclibc_0.9.30.1.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | # UCLIBC_BASE should be the latest released revision of uclibc (that way | ||
2 | # the config files will typically be correct!) uclibc-cvs takes precedence | ||
3 | # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date | ||
4 | # try removing it | ||
5 | # | ||
6 | # UCLIBC_BASE can be set in a distro file, but whether this works depends | ||
7 | # on whether the base patches apply to the selected (SRCDATE) svn release. | ||
8 | # | ||
9 | UCLIBC_BASE ?= "0.9.30.1" | ||
10 | |||
11 | require uclibc.inc | ||
12 | PR = "r0" | ||
13 | |||
14 | PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc" | ||
15 | |||
16 | SRC_URI += "file://uClibc.machine file://uClibc.distro \ | ||
17 | file://arm-linuxthreads.patch;patch=1 \ | ||
18 | file://linuxthreads-changes.patch;patch=1 \ | ||
19 | file://pthread_atfork.patch;patch=1 \ | ||
20 | file://uclibc_ldso_use_O0.patch;patch=1 \ | ||
21 | file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;patch=1 \ | ||
22 | file://gcc-4.4-fixlet.patch;patch=1 \ | ||
23 | file://uclibc-c99-ldbl-math.patch;patch=1 \ | ||
24 | file://Use-__always_inline-instead-of-__inline__.patch;patch=1 \ | ||
25 | " | ||
26 | #recent versions uclibc require real kernel headers | ||
27 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
28 | |||
29 | #as stated above, uclibc needs real kernel-headers | ||
30 | #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking .... | ||
31 | KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}" | ||
32 | |||
33 | S = "${WORKDIR}/uClibc-${UCLIBC_BASE}" | ||