summaryrefslogtreecommitdiffstats
path: root/meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb b/meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb
new file mode 100644
index 0000000000..d0d47d84d8
--- /dev/null
+++ b/meta/packages/uboot/u-boot-mkimage-openmoko-native_oe.bb
@@ -0,0 +1,83 @@
1require uboot-openmoko_svn.bb
2
3PV = "1.2.0+git9912121f7ed804ea58fd62f3f230b5dcfc357d88svn2238"
4
5SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git;tag=9912121f7ed804ea58fd62f3f230b5dcfc357d88 \
6file://uboot-machtypes.patch;patch=1 \
7file://ext2load_hex.patch;patch=1 \
8file://uboot-s3c2410-warnings-fix.patch;patch=1 \
9file://uboot-strtoul.patch;patch=1 \
10file://uboot-cramfs_but_no_jffs2.patch;patch=1 \
11file://nand-read_write_oob.patch;patch=1 \
12file://uboot-arm920t-gd_in_irq.patch;patch=1 \
13file://uboot-arm920_s3c2410_irq_demux.patch;patch=1 \
14file://uboot-s3c2410-nand.patch;patch=1 \
15file://uboot-cmd_s3c2410.patch;patch=1 \
16file://uboot-s3c2410-mmc.patch;patch=1 \
17file://env_nand_oob.patch;patch=1 \
18file://dynenv-harden.patch;patch=1 \
19file://uboot-s3c2410_fb.patch;patch=1 \
20file://uboot-20061030-qt2410.patch;patch=1 \
21file://uboot-20061030-neo1973.patch;patch=1 \
22file://uboot-s3c2410-misccr-definitions.patch;patch=1 \
23file://boot-from-ram-reloc.patch;patch=1 \
24file://boot-from-ram-and-nand.patch;patch=1 \
25file://wakeup-reason-nand-only.patch;patch=1 \
26file://uboot-neo1973-resume.patch;patch=1 \
27file://nand-dynamic_partitions.patch;patch=1 \
28file://uboot-s3c2410-norelocate_irqvec_cpy.patch;patch=1 \
29file://uboot-usbtty-acm.patch;patch=1 \
30file://uboot-s3c2410_udc.patch;patch=1 \
31file://bbt-create-optional.patch;patch=1 \
32file://nand-createbbt.patch;patch=1 \
33file://dontask.patch;patch=1 \
34file://nand-badisbad.patch;patch=1 \
35file://uboot-bbt-quiet.patch;patch=1 \
36file://raise-limits.patch;patch=1 \
37file://splashimage-command.patch;patch=1 \
38file://cmd-unzip.patch;patch=1 \
39file://enable-splash-bmp.patch;patch=1 \
40file://preboot-override.patch;patch=1 \
41file://lowlevel_foo.patch;patch=1 \
42file://default-env.patch;patch=1 \
43file://console-ansi.patch;patch=1 \
44file://boot-menu.patch;patch=1 \
45file://uboot-dfu.patch;patch=1 \
46file://uboot-neo1973-defaultenv.patch;patch=1 \
47file://uboot-nand-markbad-reallybad.patch;patch=1 \
48file://usbdcore-multiple_configs.patch;patch=1 \
49file://neo1973-chargefast.patch;patch=1 \
50file://uboot-s3c2440.patch;patch=1 \
51file://uboot-smdk2440.patch;patch=1 \
52file://uboot-hxd8.patch;patch=1 \
53file://uboot-license.patch;patch=1 \
54file://uboot-gta02.patch;patch=1 \
55file://uboot-s3c2443.patch;patch=1 \
56file://uboot-smdk2443.patch;patch=1 \
57file://unbusy-i2c.patch;patch=1 \
58file://makefile-no-dirafter.patch;patch=1 \
59"
60
61PROVIDES = ""
62TARGET_LDFLAGS = ""
63
64do_quilt() {
65:
66}
67
68do_compile () {
69 chmod +x board/neo1973/gta01/split_by_variant.sh
70 oe_runmake gta01bv3_config
71 oe_runmake clean
72 oe_runmake tools
73}
74
75do_deploy () {
76 install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
77 ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
78}
79
80do_deploy[dirs] = "${S}"
81addtask deploy before do_package after do_install
82
83