summaryrefslogtreecommitdiffstats
path: root/meta/packages/uboot/u-boot-mkimage-openmoko-native/makefile-no-dirafter.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/uboot/u-boot-mkimage-openmoko-native/makefile-no-dirafter.patch')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-openmoko-native/makefile-no-dirafter.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-openmoko-native/makefile-no-dirafter.patch b/meta/packages/uboot/u-boot-mkimage-openmoko-native/makefile-no-dirafter.patch
new file mode 100644
index 0000000000..2ed26c3127
--- /dev/null
+++ b/meta/packages/uboot/u-boot-mkimage-openmoko-native/makefile-no-dirafter.patch
@@ -0,0 +1,17 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile 2007-10-03 16:51:38.000000000 +0100
4+++ git/tools/Makefile 2007-10-03 16:52:03.000000000 +0100
5@@ -114,9 +114,9 @@
6 #
7 # Use native tools and options
8 #
9-CPPFLAGS = -idirafter $(SRCTREE)/include \
10- -idirafter $(OBJTREE)/include2 \
11- -idirafter $(OBJTREE)/include \
12+CPPFLAGS = -I$(SRCTREE)/include \
13+ -I$(OBJTREE)/include2 \
14+ -I$(OBJTREE)/include \
15 -DTEXT_BASE=$(TEXT_BASE) -DUSE_HOSTCC
16 CFLAGS = $(HOST_CFLAGS) $(CPPFLAGS) -O
17 AFLAGS = -D__ASSEMBLY__ $(CPPFLAGS)