summaryrefslogtreecommitdiffstats
path: root/meta/packages/tslib/tslib_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/tslib/tslib_cvs.bb')
-rw-r--r--meta/packages/tslib/tslib_cvs.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/meta/packages/tslib/tslib_cvs.bb b/meta/packages/tslib/tslib_cvs.bb
new file mode 100644
index 0000000000..3fd8813537
--- /dev/null
+++ b/meta/packages/tslib/tslib_cvs.bb
@@ -0,0 +1,81 @@
1SECTION = "base"
2DESCRIPTION = "tslib is a touchscreen access library."
3PV = "0.0+cvs${SRCDATE}"
4PR = "r35"
5
6SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
7PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}"
8PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
9
10SRC_URI = "cvs://cvs:@pubcvs.arm.linux.org.uk/mnt/src/cvsroot;module=tslib \
11 file://usec_fix.patch;patch=1 \
12 file://ts.conf file://ts-2.6.conf \
13 file://ts.conf-h3600-2.4 file://ts.conf-simpad-2.4 \
14 file://ts.conf-corgi-2.4 file://ts.conf-collie-2.4 \
15 file://tslib.sh"
16SRC_URI_append_mnci += " file://devfs.patch;patch=1"
17SRC_URI_append_mnci += " file://event1.patch;patch=1"
18S = "${WORKDIR}/tslib"
19LICENSE = "LGPL"
20CONFFILES_${PN} = "${sysconfdir}/ts.conf"
21
22inherit autotools pkgconfig
23
24PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate"
25EXTRA_OECONF = "--enable-shared"
26EXTRA_OECONF_mnci = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
27EXTRA_OECONF_beagle = "--enable-shared --enable-h3600 --disable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
28
29do_stage () {
30autotools_stage_all
31}
32
33do_install_prepend () {
34 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
35}
36
37do_install_append() {
38 install -d ${D}${sysconfdir}/profile.d/
39 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
40 case ${MACHINE} in
41 h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel)
42 install -d ${D}${datadir}/tslib
43 for f in ts-2.6.conf ts.conf-h3600-2.4; do
44 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
45 done
46 rm -f ${D}${sysconfdir}/ts.conf
47 ;;
48 c7x0 | spitz | akita | tosa )
49 install -d ${D}${datadir}/tslib
50 for f in ts-2.6.conf ts.conf-corgi-2.4; do
51 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
52 done
53 rm -f ${D}${sysconfdir}/ts.conf
54 ;;
55 collie | poodle )
56 install -d ${D}${datadir}/tslib
57 for f in ts-2.6.conf ts.conf-collie-2.4; do
58 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
59 done
60 rm -f ${D}${sysconfdir}/ts.conf
61 ;;
62
63 simpad )
64 install -d ${D}${datadir}/tslib
65 for f in ts-2.6.conf ts.conf-simpad-2.4; do
66 install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
67 done
68 rm -f ${D}${sysconfdir}/ts.conf
69 ;;
70 *)
71 ;;
72 esac
73}
74
75RDEPENDS_libts = "tslib-conf"
76
77FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
78FILES_libts = "${libdir}/*.so.* ${libdir}/ts/*.so*"
79FILES_libts-dev = "${FILES_tslib-dev}"
80FILES_tslib-calibrate += "${bindir}/ts_calibrate"
81FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"