summaryrefslogtreecommitdiffstats
path: root/meta/packages/telepathy/empathy-0.5
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/telepathy/empathy-0.5')
-rw-r--r--meta/packages/telepathy/empathy-0.5/no-gnome.diff133
1 files changed, 133 insertions, 0 deletions
diff --git a/meta/packages/telepathy/empathy-0.5/no-gnome.diff b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
new file mode 100644
index 0000000000..3246c8789d
--- /dev/null
+++ b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
@@ -0,0 +1,133 @@
1Index: libempathy-gtk/gossip-ui-utils.c
2===================================================================
3--- libempathy-gtk/gossip-ui-utils.c (revision 99)
4+++ libempathy-gtk/gossip-ui-utils.c (working copy)
5@@ -33,7 +33,6 @@
6 #include <glib/gi18n.h>
7 #include <gtk/gtk.h>
8 #include <glade/glade.h>
9-#include <libgnome/libgnome.h>
10
11 #include <libmissioncontrol/mc-profile.h>
12
13@@ -1283,7 +1282,7 @@
14 GError *error = NULL;
15
16 real_url = fixup_url (url);
17- gnome_url_show (real_url, &error);
18+ g_warning ("TODO: gnome_url_show (real_url, &error);");
19 if (error) {
20 g_warning ("Couldn't show URL:'%s'", real_url);
21 g_error_free (error);
22Index: src/empathy-chat-main.c
23===================================================================
24--- src/empathy-chat-main.c (revision 99)
25+++ src/empathy-chat-main.c (working copy)
26@@ -28,9 +28,6 @@
27 #include <glib/gi18n.h>
28 #include <gtk/gtk.h>
29
30-#include <libgnome/gnome-program.h>
31-#include <libgnomeui/gnome-ui-init.h>
32-
33 #include <libtelepathy/tp-conn.h>
34 #include <libtelepathy/tp-chan.h>
35 #include <libmissioncontrol/mc-account.h>
36@@ -162,7 +159,6 @@
37 main (int argc, char *argv[])
38 {
39 EmpathyChandler *chandler;
40- GnomeProgram *program;
41 gchar *localedir;
42
43 localedir = gossip_paths_get_locale_path ();
44@@ -171,14 +167,8 @@
45 textdomain (GETTEXT_PACKAGE);
46 g_free (localedir);
47
48- program = gnome_program_init ("empathy-chat",
49- PACKAGE_VERSION,
50- LIBGNOMEUI_MODULE,
51- argc, argv,
52- GNOME_PROGRAM_STANDARD_PROPERTIES,
53- GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
54- NULL);
55-
56+ gtk_init (&argc, &argv);
57+
58 gtk_window_set_default_icon_name ("empathy");
59
60 if (g_getenv ("EMPATHY_DEBUG")) {
61@@ -194,7 +184,6 @@
62
63 gtk_main ();
64
65- g_object_unref (program);
66 g_object_unref (chandler);
67
68 return EXIT_SUCCESS;
69Index: src/empathy-main.c
70===================================================================
71--- src/empathy-main.c (revision 99)
72+++ src/empathy-main.c (working copy)
73@@ -28,9 +28,6 @@
74 #include <glib/gi18n.h>
75 #include <gtk/gtk.h>
76
77-#include <libgnome/gnome-program.h>
78-#include <libgnomeui/gnome-ui-init.h>
79-
80 #include <libmissioncontrol/mc-account.h>
81 #include <libmissioncontrol/mc-account-monitor.h>
82 #include <libmissioncontrol/mission-control.h>
83@@ -136,7 +133,6 @@
84 McAccountMonitor *monitor;
85 EmpathyFilter *filter;
86 gchar *localedir;
87- GnomeProgram *program;
88 gboolean no_connect = FALSE;
89 GOptionContext *context;
90 GOptionEntry options[] = {
91@@ -157,14 +153,8 @@
92
93 g_set_application_name (PACKAGE_NAME);
94
95- program = gnome_program_init ("empathy",
96- PACKAGE_VERSION,
97- LIBGNOMEUI_MODULE,
98- argc, argv,
99- GNOME_PROGRAM_STANDARD_PROPERTIES,
100- "goption-context", context,
101- GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
102- NULL);
103+ gtk_init (&argc, &argv);
104+ /* TODO: option parsing */
105
106 gtk_window_set_default_icon_name ("empathy");
107
108@@ -204,7 +194,6 @@
109 g_object_unref (monitor);
110 g_object_unref (mc);
111 g_object_unref (icon);
112- g_object_unref (program);
113
114 return EXIT_SUCCESS;
115 }
116Index: configure.ac
117===================================================================
118--- configure.ac (revision 99)
119+++ configure.ac (working copy)
120@@ -62,12 +62,12 @@
121
122 PKG_CHECK_MODULES(EMPATHY,
123 [
124+ libxml-2.0
125 glib-2.0 >= $GLIB_REQUIRED
126 gobject-2.0
127 gtk+-2.0 >= $GTK_REQUIRED
128 gconf-2.0 >= $GCONF_REQUIRED
129 libglade-2.0 >= $LIBGLADE_REQUIRED
130- libgnomeui-2.0
131 libtelepathy >= $TELEPATHY_REQUIRED
132 libmissioncontrol >= $MISSION_CONTROL_REQUIRED
133 ])