summaryrefslogtreecommitdiffstats
path: root/meta/packages/sudo/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/sudo/files')
-rw-r--r--meta/packages/sudo/files/autofoo.patch131
-rw-r--r--meta/packages/sudo/files/autofoo1.patch222
-rw-r--r--meta/packages/sudo/files/noexec-link.patch4
-rw-r--r--meta/packages/sudo/files/nonrootinstall.patch56
-rw-r--r--meta/packages/sudo/files/nostrip.patch5
5 files changed, 34 insertions, 384 deletions
diff --git a/meta/packages/sudo/files/autofoo.patch b/meta/packages/sudo/files/autofoo.patch
index 995f026a83..4f24737610 100644
--- a/meta/packages/sudo/files/autofoo.patch
+++ b/meta/packages/sudo/files/autofoo.patch
@@ -1,51 +1,11 @@
1Index: sudo-1.6.8p12/configure.in 1# fix underquotes, rebased to 1.7.2p7
2#
3# by Kevin Tian <kevin.tian@intel.com>, 06/23/2010
4Index: sudo-1.7.2p7/aclocal.m4
2=================================================================== 5===================================================================
3--- sudo-1.6.8p12.orig/configure.in 2004-11-26 04:31:20.000000000 +1100 6--- sudo-1.7.2p7.orig/aclocal.m4 2010-06-23 13:33:57.000000000 +0800
4+++ sudo-1.6.8p12/configure.in 2007-05-16 16:45:20.000000000 +1000 7+++ sudo-1.7.2p7/aclocal.m4 2010-06-23 13:36:41.000000000 +0800
5@@ -1609,7 +1609,7 @@ 8@@ -10,7 +10,7 @@
6 AC_CHECK_FUNCS(getspnam, [CHECKSHADOW="false"], [AC_CHECK_LIB(gen, getspnam, AC_DEFINE(HAVE_GETSPNAM) [SUDO_LIBS="${SUDO_LIBS} -lgen"; LIBS="${LIBS} -lgen"])])
7 fi
8 if test "$CHECKSHADOW" = "true"; then
9- AC_CHECK_FUNC(getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1], AC_CHECK_LIB(sec, getprpwnam, AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsec"; LIBS="${LIBS} -lsec"], AC_CHECK_LIB(security, getprpwnam, AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsecurity"; LIBS="${LIBS} -lsecurity"], AC_CHECK_LIB(prot, getprpwnam, AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lprot"; LIBS="${LIBS} -lprot"])))])
10+ AC_CHECK_FUNC(getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1], [AC_CHECK_LIB(sec, getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsec"; LIBS="${LIBS} -lsec"], [AC_CHECK_LIB(security, getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsecurity"; LIBS="${LIBS} -lsecurity"], [AC_CHECK_LIB(prot, getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lprot"; LIBS="${LIBS} -lprot"])])])])
11 fi
12
13 dnl
14@@ -1670,7 +1670,7 @@
15 SUDO_TYPE_INO_T
16 SUDO_FULL_VOID
17 SUDO_UID_T_LEN
18-SUDO_LONG_LONG
19+SUDO_TYPE_LONG_LONG
20 SUDO_SOCK_SA_LEN
21 dnl
22 dnl only set RETSIGTYPE if it is not set already
23@@ -1700,12 +1700,14 @@
24 if test -z "$BROKEN_GETCWD"; then
25 AC_REPLACE_FUNCS(getcwd)
26 fi
27-AC_CHECK_FUNCS(lockf flock, [break])
28-AC_CHECK_FUNCS(waitpid wait3, [break])
29-AC_CHECK_FUNCS(innetgr _innetgr, [AC_CHECK_FUNCS(getdomainname) [break]])
30-AC_CHECK_FUNCS(lsearch, , [AC_CHECK_LIB(compat, lsearch, AC_CHECK_HEADER(search.h, AC_DEFINE(HAVE_LSEARCH) [LIBS="${LIBS} -lcompat"], AC_LIBOBJ(lsearch), -), AC_LIBOBJ(lsearch))])
31-AC_CHECK_FUNCS(utimes, [AC_CHECK_FUNCS(futimes futimesat, [break])], [AC_CHECK_FUNCS(futime) AC_LIBOBJ(utimes)])
32-SUDO_FUNC_FNMATCH(AC_DEFINE(HAVE_FNMATCH), AC_LIBOBJ(fnmatch))
33+AC_CHECK_FUNCS(lockf flock)
34+AC_CHECK_FUNCS(waitpid wait3)
35+AC_CHECK_FUNCS(innetgr _innetgr, [AC_CHECK_FUNCS(getdomainname)])
36+
37+AC_CHECK_FUNCS(lsearch, , [AC_CHECK_LIB(compat, lsearch, [AC_CHECK_HEADER(search.h, [AC_DEFINE(HAVE_LSEARCH) LIBS="$LIBS -lcompat"], [AC_LIBOBJ([lsearch])])], [AC_LIBOBJ([lsearch])])])
38+
39+AC_CHECK_FUNCS(utimes)
40+SUDO_FUNC_FNMATCH([AC_DEFINE([HAVE_FNMATCH], [1], [Define if you have the 'fnmatch' function.])], [AC_LIBOBJ([fnmatch])])
41 SUDO_FUNC_ISBLANK
42 AC_REPLACE_FUNCS(strerror strcasecmp sigaction strlcpy strlcat closefrom)
43 AC_CHECK_FUNCS(snprintf vsnprintf asprintf vasprintf, , [NEED_SNPRINTF=1])
44Index: sudo-1.6.8p12/aclocal.m4
45===================================================================
46--- sudo-1.6.8p12.orig/aclocal.m4 2004-09-08 03:14:51.000000000 +1000
47+++ sudo-1.6.8p12/aclocal.m4 2007-05-16 16:45:08.000000000 +1000
48@@ -9,7 +9,7 @@
49 dnl 9 dnl
50 dnl check for sendmail 10 dnl check for sendmail
51 dnl 11 dnl
@@ -54,7 +14,7 @@ Index: sudo-1.6.8p12/aclocal.m4
54 if test -f "/usr/sbin/sendmail"; then 14 if test -f "/usr/sbin/sendmail"; then
55 AC_MSG_RESULT(/usr/sbin/sendmail) 15 AC_MSG_RESULT(/usr/sbin/sendmail)
56 SUDO_DEFINE(_PATH_SUDO_SENDMAIL, "/usr/sbin/sendmail") 16 SUDO_DEFINE(_PATH_SUDO_SENDMAIL, "/usr/sbin/sendmail")
57@@ -36,7 +36,7 @@ 17@@ -37,7 +37,7 @@
58 dnl 18 dnl
59 dnl check for vi 19 dnl check for vi
60 dnl 20 dnl
@@ -63,7 +23,7 @@ Index: sudo-1.6.8p12/aclocal.m4
63 if test -f "/usr/bin/vi"; then 23 if test -f "/usr/bin/vi"; then
64 AC_MSG_RESULT(/usr/bin/vi) 24 AC_MSG_RESULT(/usr/bin/vi)
65 SUDO_DEFINE(_PATH_VI, "/usr/bin/vi") 25 SUDO_DEFINE(_PATH_VI, "/usr/bin/vi")
66@@ -60,7 +60,7 @@ 26@@ -61,7 +61,7 @@
67 dnl 27 dnl
68 dnl check for mv 28 dnl check for mv
69 dnl 29 dnl
@@ -72,7 +32,7 @@ Index: sudo-1.6.8p12/aclocal.m4
72 if test -f "/usr/bin/mv"; then 32 if test -f "/usr/bin/mv"; then
73 AC_MSG_RESULT(/usr/bin/mv) 33 AC_MSG_RESULT(/usr/bin/mv)
74 SUDO_DEFINE(_PATH_MV, "/usr/bin/mv") 34 SUDO_DEFINE(_PATH_MV, "/usr/bin/mv")
75@@ -81,7 +81,7 @@ 35@@ -82,7 +82,7 @@
76 dnl 36 dnl
77 dnl check for bourne shell 37 dnl check for bourne shell
78 dnl 38 dnl
@@ -81,7 +41,7 @@ Index: sudo-1.6.8p12/aclocal.m4
81 if test -f "/bin/sh"; then 41 if test -f "/bin/sh"; then
82 AC_MSG_RESULT(/bin/sh) 42 AC_MSG_RESULT(/bin/sh)
83 SUDO_DEFINE(_PATH_BSHELL, "/bin/sh") 43 SUDO_DEFINE(_PATH_BSHELL, "/bin/sh")
84@@ -114,7 +114,7 @@ 44@@ -115,7 +115,7 @@
85 dnl 45 dnl
86 dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm 46 dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm
87 dnl 47 dnl
@@ -90,7 +50,7 @@ Index: sudo-1.6.8p12/aclocal.m4
90 if test -n "$with_logpath"; then 50 if test -n "$with_logpath"; then
91 AC_MSG_RESULT($with_logpath) 51 AC_MSG_RESULT($with_logpath)
92 SUDO_DEFINE_UNQUOTED(_PATH_SUDO_LOGFILE, "$with_logpath") 52 SUDO_DEFINE_UNQUOTED(_PATH_SUDO_LOGFILE, "$with_logpath")
93@@ -135,7 +135,7 @@ 53@@ -136,7 +136,7 @@
94 dnl 54 dnl
95 dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm 55 dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm
96 dnl 56 dnl
@@ -99,16 +59,7 @@ Index: sudo-1.6.8p12/aclocal.m4
99 if test -n "$with_timedir"; then 59 if test -n "$with_timedir"; then
100 AC_MSG_RESULT($with_timedir) 60 AC_MSG_RESULT($with_timedir)
101 SUDO_DEFINE_UNQUOTED(_PATH_SUDO_TIMEDIR, "$with_timedir") 61 SUDO_DEFINE_UNQUOTED(_PATH_SUDO_TIMEDIR, "$with_timedir")
102@@ -158,7 +158,7 @@ 62@@ -160,7 +160,7 @@
103 dnl
104 dnl check for fullly working void
105 dnl
106-AC_DEFUN(SUDO_FULL_VOID, [AC_MSG_CHECKING(for full void implementation)
107+AC_DEFUN([SUDO_FULL_VOID], [AC_MSG_CHECKING(for full void implementation)
108 AC_TRY_COMPILE(, [void *foo;
109 foo = (void *)0; (void *)"test";], AC_DEFINE(VOID, void, [Define to "void" if your compiler supports void pointers, else use "char"].)
110 AC_MSG_RESULT(yes), AC_DEFINE(VOID, char)
111@@ -168,7 +168,7 @@
112 dnl SUDO_CHECK_TYPE(TYPE, DEFAULT) 63 dnl SUDO_CHECK_TYPE(TYPE, DEFAULT)
113 dnl XXX - should require the check for unistd.h... 64 dnl XXX - should require the check for unistd.h...
114 dnl 65 dnl
@@ -117,7 +68,7 @@ Index: sudo-1.6.8p12/aclocal.m4
117 [AC_REQUIRE([AC_HEADER_STDC])dnl 68 [AC_REQUIRE([AC_HEADER_STDC])dnl
118 AC_MSG_CHECKING(for $1) 69 AC_MSG_CHECKING(for $1)
119 AC_CACHE_VAL(sudo_cv_type_$1, 70 AC_CACHE_VAL(sudo_cv_type_$1,
120@@ -189,31 +189,31 @@ 71@@ -181,31 +181,31 @@
121 dnl 72 dnl
122 dnl Check for size_t declation 73 dnl Check for size_t declation
123 dnl 74 dnl
@@ -151,22 +102,10 @@ Index: sudo-1.6.8p12/aclocal.m4
151 dnl 102 dnl
152-AC_DEFUN(SUDO_FUNC_FNMATCH, 103-AC_DEFUN(SUDO_FUNC_FNMATCH,
153+AC_DEFUN([SUDO_FUNC_FNMATCH], 104+AC_DEFUN([SUDO_FUNC_FNMATCH],
154 [AC_MSG_CHECKING(for working fnmatch with FNM_CASEFOLD) 105 [AC_MSG_CHECKING([for working fnmatch with FNM_CASEFOLD])
155 AC_CACHE_VAL(sudo_cv_func_fnmatch, 106 AC_CACHE_VAL(sudo_cv_func_fnmatch,
156 [rm -f conftestdata; > conftestdata 107 [rm -f conftestdata; > conftestdata
157@@ -224,9 +224,9 @@ 108@@ -271,7 +271,7 @@
158 rm -f core core.* *.core])dnl
159 AC_MSG_RESULT($sudo_cv_func_fnmatch)
160 if test $sudo_cv_func_fnmatch = yes; then
161- [$1]
162+ $1
163 else
164- [$2]
165+ $2
166 fi
167 ])
168
169@@ -246,7 +246,7 @@
170 dnl 109 dnl
171 dnl check for sa_len field in struct sockaddr 110 dnl check for sa_len field in struct sockaddr
172 dnl 111 dnl
@@ -175,7 +114,7 @@ Index: sudo-1.6.8p12/aclocal.m4
175 [AC_MSG_CHECKING(for sa_len field in struct sockaddr) 114 [AC_MSG_CHECKING(for sa_len field in struct sockaddr)
176 AC_CACHE_VAL(sudo_cv_sock_sa_len, 115 AC_CACHE_VAL(sudo_cv_sock_sa_len,
177 [AC_TRY_RUN([#include <sys/types.h> 116 [AC_TRY_RUN([#include <sys/types.h>
178@@ -269,7 +269,7 @@ 117@@ -294,7 +294,7 @@
179 dnl we can't really trust UID_MAX or MAXUID since they may exist 118 dnl we can't really trust UID_MAX or MAXUID since they may exist
180 dnl only for backwards compatibility. 119 dnl only for backwards compatibility.
181 dnl 120 dnl
@@ -184,39 +123,21 @@ Index: sudo-1.6.8p12/aclocal.m4
184 [AC_REQUIRE([AC_TYPE_UID_T]) 123 [AC_REQUIRE([AC_TYPE_UID_T])
185 AC_MSG_CHECKING(max length of uid_t) 124 AC_MSG_CHECKING(max length of uid_t)
186 AC_CACHE_VAL(sudo_cv_uid_t_len, 125 AC_CACHE_VAL(sudo_cv_uid_t_len,
187@@ -301,17 +301,29 @@ 126@@ -327,7 +327,7 @@
188
189 dnl 127 dnl
190 dnl check for "long long" 128 dnl Check for presence of long long and for sizeof(long long) == sizeof(long)
191-dnl XXX hard to cache since it includes 2 tests
192 dnl 129 dnl
193-AC_DEFUN(SUDO_LONG_LONG, [AC_MSG_CHECKING(for long long support) 130-AC_DEFUN(SUDO_TYPE_LONG_LONG,
194-AC_TRY_LINK(, [long long foo = 1000; foo /= 10;], AC_DEFINE(HAVE_LONG_LONG, 1, [Define if your compiler supports the "long long" type.])
195-[AC_TRY_RUN([main() {if (sizeof(long long) == sizeof(long)) exit(0); else exit(1);}], AC_DEFINE(LONG_IS_QUAD, 1, [Define if sizeof(long) == sizeof(long long).]))]
196-AC_MSG_RESULT(yes), AC_MSG_RESULT(no))])
197+AC_DEFUN([SUDO_TYPE_LONG_LONG], 131+AC_DEFUN([SUDO_TYPE_LONG_LONG],
198+[AC_CHECK_TYPES(long long, [AC_DEFINE(HAVE_LONG_LONG, 1, [Define if your 132 [AC_CHECK_TYPES(long long, [AC_DEFINE(HAVE_LONG_LONG, 1, [Define if your compiler supports the "long long" type.])]
199+compiler supports the "long long" type.])] 133 [AC_MSG_CHECKING(for long and long long equivalence)
200+[AC_MSG_CHECKING(for long and long long equivalence) 134 AC_CACHE_VAL(sudo_cv_type_long_is_quad,
201+AC_CACHE_VAL(sudo_cv_type_long_is_quad, 135@@ -347,7 +347,7 @@
202+[AC_TRY_RUN([
203+main() {
204+if (sizeof(long long) == sizeof(long)) exit(0);
205+else exit(1);
206+}], [sudo_cv_type_long_is_quad=yes],
207+[sudo_cv_type_long_is_quad=no], [sudo_cv_type_long_is_quad=no])
208+rm -f core core.* *.core])dnl
209+AC_MSG_RESULT($sudo_cv_type_long_is_quad)
210+if test $sudo_cv_type_long_is_quad = yes; then
211+ AC_DEFINE(LONG_IS_QUAD, 1, [Define if sizeof(long) == sizeof(long long).])
212+fi
213+])])
214
215 dnl 136 dnl
216 dnl append a libpath to an LDFLAGS style variable 137 dnl append a libpath to an LDFLAGS style variable
217 dnl 138 dnl
218-AC_DEFUN(SUDO_APPEND_LIBPATH, [ 139-AC_DEFUN(SUDO_APPEND_LIBPATH, [
219+AC_DEFUN([SUDO_APPEND_LIBPATH], [ 140+AC_DEFUN([SUDO_APPEND_LIBPATH], [
220 if test X"$with_rpath" = X"yes"; then 141 if test X"$with_rpath" = X"yes"; then
221 $1="${$1} -L$2 -R$2" 142 case "$host" in
222 else 143 *-*-hpux*) $1="${$1} -L$2 -Wl,+b,$2"
diff --git a/meta/packages/sudo/files/autofoo1.patch b/meta/packages/sudo/files/autofoo1.patch
deleted file mode 100644
index 995f026a83..0000000000
--- a/meta/packages/sudo/files/autofoo1.patch
+++ /dev/null
@@ -1,222 +0,0 @@
1Index: sudo-1.6.8p12/configure.in
2===================================================================
3--- sudo-1.6.8p12.orig/configure.in 2004-11-26 04:31:20.000000000 +1100
4+++ sudo-1.6.8p12/configure.in 2007-05-16 16:45:20.000000000 +1000
5@@ -1609,7 +1609,7 @@
6 AC_CHECK_FUNCS(getspnam, [CHECKSHADOW="false"], [AC_CHECK_LIB(gen, getspnam, AC_DEFINE(HAVE_GETSPNAM) [SUDO_LIBS="${SUDO_LIBS} -lgen"; LIBS="${LIBS} -lgen"])])
7 fi
8 if test "$CHECKSHADOW" = "true"; then
9- AC_CHECK_FUNC(getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1], AC_CHECK_LIB(sec, getprpwnam, AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsec"; LIBS="${LIBS} -lsec"], AC_CHECK_LIB(security, getprpwnam, AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsecurity"; LIBS="${LIBS} -lsecurity"], AC_CHECK_LIB(prot, getprpwnam, AC_DEFINE(HAVE_GETPRPWNAM) [CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lprot"; LIBS="${LIBS} -lprot"])))])
10+ AC_CHECK_FUNC(getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1], [AC_CHECK_LIB(sec, getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsec"; LIBS="${LIBS} -lsec"], [AC_CHECK_LIB(security, getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lsecurity"; LIBS="${LIBS} -lsecurity"], [AC_CHECK_LIB(prot, getprpwnam, [AC_DEFINE(HAVE_GETPRPWNAM) CHECKSHADOW="false"; SECUREWARE=1; SUDO_LIBS="${SUDO_LIBS} -lprot"; LIBS="${LIBS} -lprot"])])])])
11 fi
12
13 dnl
14@@ -1670,7 +1670,7 @@
15 SUDO_TYPE_INO_T
16 SUDO_FULL_VOID
17 SUDO_UID_T_LEN
18-SUDO_LONG_LONG
19+SUDO_TYPE_LONG_LONG
20 SUDO_SOCK_SA_LEN
21 dnl
22 dnl only set RETSIGTYPE if it is not set already
23@@ -1700,12 +1700,14 @@
24 if test -z "$BROKEN_GETCWD"; then
25 AC_REPLACE_FUNCS(getcwd)
26 fi
27-AC_CHECK_FUNCS(lockf flock, [break])
28-AC_CHECK_FUNCS(waitpid wait3, [break])
29-AC_CHECK_FUNCS(innetgr _innetgr, [AC_CHECK_FUNCS(getdomainname) [break]])
30-AC_CHECK_FUNCS(lsearch, , [AC_CHECK_LIB(compat, lsearch, AC_CHECK_HEADER(search.h, AC_DEFINE(HAVE_LSEARCH) [LIBS="${LIBS} -lcompat"], AC_LIBOBJ(lsearch), -), AC_LIBOBJ(lsearch))])
31-AC_CHECK_FUNCS(utimes, [AC_CHECK_FUNCS(futimes futimesat, [break])], [AC_CHECK_FUNCS(futime) AC_LIBOBJ(utimes)])
32-SUDO_FUNC_FNMATCH(AC_DEFINE(HAVE_FNMATCH), AC_LIBOBJ(fnmatch))
33+AC_CHECK_FUNCS(lockf flock)
34+AC_CHECK_FUNCS(waitpid wait3)
35+AC_CHECK_FUNCS(innetgr _innetgr, [AC_CHECK_FUNCS(getdomainname)])
36+
37+AC_CHECK_FUNCS(lsearch, , [AC_CHECK_LIB(compat, lsearch, [AC_CHECK_HEADER(search.h, [AC_DEFINE(HAVE_LSEARCH) LIBS="$LIBS -lcompat"], [AC_LIBOBJ([lsearch])])], [AC_LIBOBJ([lsearch])])])
38+
39+AC_CHECK_FUNCS(utimes)
40+SUDO_FUNC_FNMATCH([AC_DEFINE([HAVE_FNMATCH], [1], [Define if you have the 'fnmatch' function.])], [AC_LIBOBJ([fnmatch])])
41 SUDO_FUNC_ISBLANK
42 AC_REPLACE_FUNCS(strerror strcasecmp sigaction strlcpy strlcat closefrom)
43 AC_CHECK_FUNCS(snprintf vsnprintf asprintf vasprintf, , [NEED_SNPRINTF=1])
44Index: sudo-1.6.8p12/aclocal.m4
45===================================================================
46--- sudo-1.6.8p12.orig/aclocal.m4 2004-09-08 03:14:51.000000000 +1000
47+++ sudo-1.6.8p12/aclocal.m4 2007-05-16 16:45:08.000000000 +1000
48@@ -9,7 +9,7 @@
49 dnl
50 dnl check for sendmail
51 dnl
52-AC_DEFUN(SUDO_PROG_SENDMAIL, [AC_MSG_CHECKING(for sendmail)
53+AC_DEFUN([SUDO_PROG_SENDMAIL], [AC_MSG_CHECKING(for sendmail)
54 if test -f "/usr/sbin/sendmail"; then
55 AC_MSG_RESULT(/usr/sbin/sendmail)
56 SUDO_DEFINE(_PATH_SUDO_SENDMAIL, "/usr/sbin/sendmail")
57@@ -36,7 +36,7 @@
58 dnl
59 dnl check for vi
60 dnl
61-AC_DEFUN(SUDO_PROG_VI, [AC_MSG_CHECKING(for vi)
62+AC_DEFUN([SUDO_PROG_VI], [AC_MSG_CHECKING(for vi)
63 if test -f "/usr/bin/vi"; then
64 AC_MSG_RESULT(/usr/bin/vi)
65 SUDO_DEFINE(_PATH_VI, "/usr/bin/vi")
66@@ -60,7 +60,7 @@
67 dnl
68 dnl check for mv
69 dnl
70-AC_DEFUN(SUDO_PROG_MV, [AC_MSG_CHECKING(for mv)
71+AC_DEFUN([SUDO_PROG_MV], [AC_MSG_CHECKING(for mv)
72 if test -f "/usr/bin/mv"; then
73 AC_MSG_RESULT(/usr/bin/mv)
74 SUDO_DEFINE(_PATH_MV, "/usr/bin/mv")
75@@ -81,7 +81,7 @@
76 dnl
77 dnl check for bourne shell
78 dnl
79-AC_DEFUN(SUDO_PROG_BSHELL, [AC_MSG_CHECKING(for bourne shell)
80+AC_DEFUN([SUDO_PROG_BSHELL], [AC_MSG_CHECKING(for bourne shell)
81 if test -f "/bin/sh"; then
82 AC_MSG_RESULT(/bin/sh)
83 SUDO_DEFINE(_PATH_BSHELL, "/bin/sh")
84@@ -114,7 +114,7 @@
85 dnl
86 dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm
87 dnl
88-AC_DEFUN(SUDO_LOGFILE, [AC_MSG_CHECKING(for log file location)
89+AC_DEFUN([SUDO_LOGFILE], [AC_MSG_CHECKING(for log file location)
90 if test -n "$with_logpath"; then
91 AC_MSG_RESULT($with_logpath)
92 SUDO_DEFINE_UNQUOTED(_PATH_SUDO_LOGFILE, "$with_logpath")
93@@ -135,7 +135,7 @@
94 dnl
95 dnl Where the log file goes, use /var/log if it exists, else /{var,usr}/adm
96 dnl
97-AC_DEFUN(SUDO_TIMEDIR, [AC_MSG_CHECKING(for timestamp file location)
98+AC_DEFUN([SUDO_TIMEDIR], [AC_MSG_CHECKING(for timestamp file location)
99 if test -n "$with_timedir"; then
100 AC_MSG_RESULT($with_timedir)
101 SUDO_DEFINE_UNQUOTED(_PATH_SUDO_TIMEDIR, "$with_timedir")
102@@ -158,7 +158,7 @@
103 dnl
104 dnl check for fullly working void
105 dnl
106-AC_DEFUN(SUDO_FULL_VOID, [AC_MSG_CHECKING(for full void implementation)
107+AC_DEFUN([SUDO_FULL_VOID], [AC_MSG_CHECKING(for full void implementation)
108 AC_TRY_COMPILE(, [void *foo;
109 foo = (void *)0; (void *)"test";], AC_DEFINE(VOID, void, [Define to "void" if your compiler supports void pointers, else use "char"].)
110 AC_MSG_RESULT(yes), AC_DEFINE(VOID, char)
111@@ -168,7 +168,7 @@
112 dnl SUDO_CHECK_TYPE(TYPE, DEFAULT)
113 dnl XXX - should require the check for unistd.h...
114 dnl
115-AC_DEFUN(SUDO_CHECK_TYPE,
116+AC_DEFUN([SUDO_CHECK_TYPE],
117 [AC_REQUIRE([AC_HEADER_STDC])dnl
118 AC_MSG_CHECKING(for $1)
119 AC_CACHE_VAL(sudo_cv_type_$1,
120@@ -189,31 +189,31 @@
121 dnl
122 dnl Check for size_t declation
123 dnl
124-AC_DEFUN(SUDO_TYPE_SIZE_T,
125+AC_DEFUN([SUDO_TYPE_SIZE_T],
126 [SUDO_CHECK_TYPE(size_t, int)])
127
128 dnl
129 dnl Check for ssize_t declation
130 dnl
131-AC_DEFUN(SUDO_TYPE_SSIZE_T,
132+AC_DEFUN([SUDO_TYPE_SSIZE_T],
133 [SUDO_CHECK_TYPE(ssize_t, int)])
134
135 dnl
136 dnl Check for dev_t declation
137 dnl
138-AC_DEFUN(SUDO_TYPE_DEV_T,
139+AC_DEFUN([SUDO_TYPE_DEV_T],
140 [SUDO_CHECK_TYPE(dev_t, int)])
141
142 dnl
143 dnl Check for ino_t declation
144 dnl
145-AC_DEFUN(SUDO_TYPE_INO_T,
146+AC_DEFUN([SUDO_TYPE_INO_T],
147 [SUDO_CHECK_TYPE(ino_t, unsigned int)])
148
149 dnl
150 dnl check for working fnmatch(3)
151 dnl
152-AC_DEFUN(SUDO_FUNC_FNMATCH,
153+AC_DEFUN([SUDO_FUNC_FNMATCH],
154 [AC_MSG_CHECKING(for working fnmatch with FNM_CASEFOLD)
155 AC_CACHE_VAL(sudo_cv_func_fnmatch,
156 [rm -f conftestdata; > conftestdata
157@@ -224,9 +224,9 @@
158 rm -f core core.* *.core])dnl
159 AC_MSG_RESULT($sudo_cv_func_fnmatch)
160 if test $sudo_cv_func_fnmatch = yes; then
161- [$1]
162+ $1
163 else
164- [$2]
165+ $2
166 fi
167 ])
168
169@@ -246,7 +246,7 @@
170 dnl
171 dnl check for sa_len field in struct sockaddr
172 dnl
173-AC_DEFUN(SUDO_SOCK_SA_LEN,
174+AC_DEFUN([SUDO_SOCK_SA_LEN],
175 [AC_MSG_CHECKING(for sa_len field in struct sockaddr)
176 AC_CACHE_VAL(sudo_cv_sock_sa_len,
177 [AC_TRY_RUN([#include <sys/types.h>
178@@ -269,7 +269,7 @@
179 dnl we can't really trust UID_MAX or MAXUID since they may exist
180 dnl only for backwards compatibility.
181 dnl
182-AC_DEFUN(SUDO_UID_T_LEN,
183+AC_DEFUN([SUDO_UID_T_LEN],
184 [AC_REQUIRE([AC_TYPE_UID_T])
185 AC_MSG_CHECKING(max length of uid_t)
186 AC_CACHE_VAL(sudo_cv_uid_t_len,
187@@ -301,17 +301,29 @@
188
189 dnl
190 dnl check for "long long"
191-dnl XXX hard to cache since it includes 2 tests
192 dnl
193-AC_DEFUN(SUDO_LONG_LONG, [AC_MSG_CHECKING(for long long support)
194-AC_TRY_LINK(, [long long foo = 1000; foo /= 10;], AC_DEFINE(HAVE_LONG_LONG, 1, [Define if your compiler supports the "long long" type.])
195-[AC_TRY_RUN([main() {if (sizeof(long long) == sizeof(long)) exit(0); else exit(1);}], AC_DEFINE(LONG_IS_QUAD, 1, [Define if sizeof(long) == sizeof(long long).]))]
196-AC_MSG_RESULT(yes), AC_MSG_RESULT(no))])
197+AC_DEFUN([SUDO_TYPE_LONG_LONG],
198+[AC_CHECK_TYPES(long long, [AC_DEFINE(HAVE_LONG_LONG, 1, [Define if your
199+compiler supports the "long long" type.])]
200+[AC_MSG_CHECKING(for long and long long equivalence)
201+AC_CACHE_VAL(sudo_cv_type_long_is_quad,
202+[AC_TRY_RUN([
203+main() {
204+if (sizeof(long long) == sizeof(long)) exit(0);
205+else exit(1);
206+}], [sudo_cv_type_long_is_quad=yes],
207+[sudo_cv_type_long_is_quad=no], [sudo_cv_type_long_is_quad=no])
208+rm -f core core.* *.core])dnl
209+AC_MSG_RESULT($sudo_cv_type_long_is_quad)
210+if test $sudo_cv_type_long_is_quad = yes; then
211+ AC_DEFINE(LONG_IS_QUAD, 1, [Define if sizeof(long) == sizeof(long long).])
212+fi
213+])])
214
215 dnl
216 dnl append a libpath to an LDFLAGS style variable
217 dnl
218-AC_DEFUN(SUDO_APPEND_LIBPATH, [
219+AC_DEFUN([SUDO_APPEND_LIBPATH], [
220 if test X"$with_rpath" = X"yes"; then
221 $1="${$1} -L$2 -R$2"
222 else
diff --git a/meta/packages/sudo/files/noexec-link.patch b/meta/packages/sudo/files/noexec-link.patch
index 98b35c657b..e0d35d0e25 100644
--- a/meta/packages/sudo/files/noexec-link.patch
+++ b/meta/packages/sudo/files/noexec-link.patch
@@ -1,3 +1,7 @@
1# libtool requires library's name to start with 'lib', or else error is reported. with "-module" option
2# that check is skipped
3#
4# comments added by Kevin Tian <kevin.tian@intel.com>, 06/23/2010
1Index: sudo-1.6.8p6/Makefile.in 5Index: sudo-1.6.8p6/Makefile.in
2=================================================================== 6===================================================================
3--- sudo-1.6.8p6.orig/Makefile.in 2005-01-21 19:09:26.963276656 -0500 7--- sudo-1.6.8p6.orig/Makefile.in 2005-01-21 19:09:26.963276656 -0500
diff --git a/meta/packages/sudo/files/nonrootinstall.patch b/meta/packages/sudo/files/nonrootinstall.patch
deleted file mode 100644
index db174b373f..0000000000
--- a/meta/packages/sudo/files/nonrootinstall.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6Index: sudo-1.6.8p5/Makefile.in
7===================================================================
8--- sudo-1.6.8p5.orig/Makefile.in 2004-11-25 12:27:00.000000000 -0500
9+++ sudo-1.6.8p5/Makefile.in 2005-01-21 18:02:00.447440568 -0500
10@@ -81,10 +81,16 @@
11 mandirform = $(mandir)/$(mantype)$(mansectform)
12
13 # User and group ids the installed files should be "owned" by
14+ifeq ($(DESTDIR),)
15+install_owncmd = -o $(install_uid) -g $(install_gid)
16+endif
17 install_uid = 0
18 install_gid = 0
19
20 # User, group, and mode the sudoers file should be "owned" by (configure)
21+ifeq ($(DESTDIR),)
22+sudoers_owncmd = -o $(sudoers_uid) -g $(sudoers_gid)
23+endif
24 sudoers_uid = @SUDOERS_UID@
25 sudoers_gid = @SUDOERS_GID@
26 sudoers_mode = @SUDOERS_MODE@
27@@ -301,12 +307,11 @@
28 $(DESTDIR)$(noexecdir)
29
30 install-binaries: $(PROGS)
31- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
32+ $(INSTALL) $(install_owncmd) -m 4555 -s sudo $(DESTDIR)$(sudodir)/sudo
33+ $(INSTALL) $(install_owncmd) -m 0555 -s visudo $(DESTDIR)$(visudodir)/visudo
34 rm -f $(DESTDIR)$(sudodir)/sudoedit
35 ln $(DESTDIR)$(sudodir)/sudo $(DESTDIR)$(sudodir)/sudoedit
36
37- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
38-
39 install-noexec: sudo_noexec.la
40 $(LIBTOOL) --mode=install $(INSTALL) sudo_noexec.la $(DESTDIR)$(noexecdir)
41
42@@ -319,11 +324,11 @@
43 $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
44
45 install-man:
46- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
47+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
48 @rm -f $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
49 ln $(DESTDIR)$(mandirsu)/sudo.$(mansectsu) $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
50- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
51- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
52+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
53+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
54 @MAN_POSTINSTALL@
55
56 check:
diff --git a/meta/packages/sudo/files/nostrip.patch b/meta/packages/sudo/files/nostrip.patch
index 287d43a8e7..3c71b4fd86 100644
--- a/meta/packages/sudo/files/nostrip.patch
+++ b/meta/packages/sudo/files/nostrip.patch
@@ -1,4 +1,7 @@
1 1# this could be pushed upstream to allowing conditional strip. Now it's not applied.
2# we use sed in recipe for same purpose. Keep here as reminder for upstream
3#
4# comment added by Kevin Tian <kevin.tian@intel.com>, 07/01/2010
2# 5#
3# Patch managed by http://www.holgerschurig.de/patcher.html 6# Patch managed by http://www.holgerschurig.de/patcher.html
4# 7#