summaryrefslogtreecommitdiffstats
path: root/meta/packages/sudo/files/nonrootinstall.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/sudo/files/nonrootinstall.patch')
-rw-r--r--meta/packages/sudo/files/nonrootinstall.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/packages/sudo/files/nonrootinstall.patch b/meta/packages/sudo/files/nonrootinstall.patch
deleted file mode 100644
index db174b373f..0000000000
--- a/meta/packages/sudo/files/nonrootinstall.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6Index: sudo-1.6.8p5/Makefile.in
7===================================================================
8--- sudo-1.6.8p5.orig/Makefile.in 2004-11-25 12:27:00.000000000 -0500
9+++ sudo-1.6.8p5/Makefile.in 2005-01-21 18:02:00.447440568 -0500
10@@ -81,10 +81,16 @@
11 mandirform = $(mandir)/$(mantype)$(mansectform)
12
13 # User and group ids the installed files should be "owned" by
14+ifeq ($(DESTDIR),)
15+install_owncmd = -o $(install_uid) -g $(install_gid)
16+endif
17 install_uid = 0
18 install_gid = 0
19
20 # User, group, and mode the sudoers file should be "owned" by (configure)
21+ifeq ($(DESTDIR),)
22+sudoers_owncmd = -o $(sudoers_uid) -g $(sudoers_gid)
23+endif
24 sudoers_uid = @SUDOERS_UID@
25 sudoers_gid = @SUDOERS_GID@
26 sudoers_mode = @SUDOERS_MODE@
27@@ -301,12 +307,11 @@
28 $(DESTDIR)$(noexecdir)
29
30 install-binaries: $(PROGS)
31- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
32+ $(INSTALL) $(install_owncmd) -m 4555 -s sudo $(DESTDIR)$(sudodir)/sudo
33+ $(INSTALL) $(install_owncmd) -m 0555 -s visudo $(DESTDIR)$(visudodir)/visudo
34 rm -f $(DESTDIR)$(sudodir)/sudoedit
35 ln $(DESTDIR)$(sudodir)/sudo $(DESTDIR)$(sudodir)/sudoedit
36
37- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
38-
39 install-noexec: sudo_noexec.la
40 $(LIBTOOL) --mode=install $(INSTALL) sudo_noexec.la $(DESTDIR)$(noexecdir)
41
42@@ -319,11 +324,11 @@
43 $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
44
45 install-man:
46- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
47+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
48 @rm -f $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
49 ln $(DESTDIR)$(mandirsu)/sudo.$(mansectsu) $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
50- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
51- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
52+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
53+ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
54 @MAN_POSTINSTALL@
55
56 check: