diff options
Diffstat (limited to 'meta/packages/speex')
-rw-r--r-- | meta/packages/speex/speex_1.1.12+1.2beta2.bb | 24 | ||||
-rw-r--r-- | meta/packages/speex/speex_1.1.7.bb | 31 |
2 files changed, 24 insertions, 31 deletions
diff --git a/meta/packages/speex/speex_1.1.12+1.2beta2.bb b/meta/packages/speex/speex_1.1.12+1.2beta2.bb new file mode 100644 index 0000000000..f60408d50a --- /dev/null +++ b/meta/packages/speex/speex_1.1.12+1.2beta2.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Speex is an Open Source/Free Software patent-free audio compression format designed for speech." | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "BSD" | ||
4 | HOMEPAGE = "http://www.speex.org" | ||
5 | DEPENDS = "libogg" | ||
6 | |||
7 | SRC_URI = "http://downloads.us.xiph.org/releases/speex/speex-1.2beta2.tar.gz" | ||
8 | S = "${WORKDIR}/${PN}-1.2beta2" | ||
9 | |||
10 | PARALLEL_MAKE = "" | ||
11 | |||
12 | inherit autotools pkgconfig | ||
13 | |||
14 | EXTRA_OECONF = " --enable-fixed-point --with-ogg-libraries=${STAGING_LIBDIR} \ | ||
15 | --with-ogg-includes=${STAGING_INCDIR} --disable-oggtest" | ||
16 | |||
17 | do_stage() { | ||
18 | autotools_stage_all | ||
19 | } | ||
20 | |||
21 | PACKAGES += "${PN}-bin" | ||
22 | FILES_${PN} = "${libdir}/libspeex.so.*" | ||
23 | FILES_${PN}-dev += "${libdir}/libspeex.so.*" | ||
24 | FILES_${PN}-bin = "${bindir}" | ||
diff --git a/meta/packages/speex/speex_1.1.7.bb b/meta/packages/speex/speex_1.1.7.bb deleted file mode 100644 index 624f76287c..0000000000 --- a/meta/packages/speex/speex_1.1.7.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | DESCRIPTION = "Speex is an Open Source/Free Software patent-free audio compression format designed for speech." | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "BSD" | ||
4 | HOMEPAGE = "http://www.speex.org" | ||
5 | DEPENDS = "libogg" | ||
6 | PR = "r1" | ||
7 | |||
8 | SRC_URI = "http://downloads.us.xiph.org/releases/speex/${PN}-${PV}.tar.gz" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | # Some interesting options are: | ||
13 | # | ||
14 | # --enable-arm4-asm | ||
15 | # --enable-arm5e-asm | ||
16 | # --enable-fixed-point | ||
17 | # | ||
18 | # NB: the arm assembly is currently broken :( | ||
19 | # | ||
20 | |||
21 | EXTRA_OECONF = " --enable-fixed-point --with-ogg-libraries=${STAGING_LIBDIR} --with-ogg-includes=${STAGING_INCDIR}" | ||
22 | |||
23 | do_stage() { | ||
24 | oe_libinstall -C libspeex/.libs -so libspeex ${STAGING_LIBDIR} | ||
25 | install -d ${STAGING_INCDIR}/speex | ||
26 | install -m 0644 include/speex/speex.h ${STAGING_INCDIR}/speex | ||
27 | install -m 0644 include/speex/speex_bits.h ${STAGING_INCDIR}/speex | ||
28 | install -m 0644 include/speex/speex_callbacks.h ${STAGING_INCDIR}/speex | ||
29 | install -m 0644 include/speex/speex_header.h ${STAGING_INCDIR}/speex | ||
30 | install -m 0644 include/speex/speex_stereo.h ${STAGING_INCDIR}/speex | ||
31 | } | ||