summaryrefslogtreecommitdiffstats
path: root/meta/packages/rxvt-unicode/rxvt-unicode_5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/rxvt-unicode/rxvt-unicode_5.6.bb')
-rw-r--r--meta/packages/rxvt-unicode/rxvt-unicode_5.6.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/rxvt-unicode/rxvt-unicode_5.6.bb b/meta/packages/rxvt-unicode/rxvt-unicode_5.6.bb
new file mode 100644
index 0000000000..b224bb0c9d
--- /dev/null
+++ b/meta/packages/rxvt-unicode/rxvt-unicode_5.6.bb
@@ -0,0 +1,68 @@
1SECTION = "x11/utils"
2DEPENDS = "libx11 libxt libxft"
3DESCRIPTION = "rxvt-unicode is a clone of the well known \
4terminal emulator rxvt, modified to store text in Unicode \
5(either UCS-2 or UCS-4) and to use locale-correct input and \
6output. It also supports mixing multiple fonts at the \
7same time, including Xft fonts."
8LICENSE = "GPL"
9SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
10 file://xwc.patch;patch=1 \
11 file://signedchar.patch;patch=1 \
12 file://rxvt.desktop \
13 file://rxvt.png"
14PR = "r3"
15
16inherit autotools update-alternatives
17
18PROVIDES = "virtual/x-terminal-emulator"
19ALTERNATIVE_NAME = "x-terminal-emulator"
20ALTERNATIVE_PATH = "${bindir}/rxvt"
21
22CFLAGS_append = " -fpermissive"
23
24EXTRA_OECONF = "--enable-menubar --enable-xim \
25 --enable-utmp --enable-wtmp --enable-lastlog \
26 --disable-strings --with-term=rxvt --enable-keepscrolling \
27 --enable-xft --with-name=rxvt --enable-frills \
28 --enable-swapscreen --enable-transparency \
29 --with-codesets=eu \
30 --enable-cursor-blink --enable-pointer-blank \
31 --enable-text-blink --enable-rxvt-scroll \
32 --enable-combining --enable-shared \
33 --enable-xgetdefault \
34 --with-x=${STAGING_LIBDIR}/.."
35EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
36 'XLIB=-L${STAGING_LIBDIR} -lX11'"
37
38do_configure () {
39 mv autoconf/configure.in . || true
40 rm autoconf/libtool.m4
41 libtoolize --force
42 autotools_do_configure
43 echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
44 echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
45 echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
46 echo '#define HAVE_XLOCALE 1' >> config.h
47}
48
49do_compile () {
50 if test -e ${S}/${HOST_SYS}-libtool; then
51 LIBTOOL=${S}/${HOST_SYS}-libtool
52 else
53 LIBTOOL=${S}/libtool
54 fi
55 # docs need "yodl" and I have no idea what that is
56 oe_runmake -C src "LIBTOOL=$LIBTOOL"
57}
58
59do_install_append () {
60 install -d ${D}/${datadir}
61 install -d ${D}/${datadir}/applications
62 install -d ${D}/${datadir}/pixmaps/
63
64 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
65 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
66}
67
68FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"