summaryrefslogtreecommitdiffstats
path: root/meta/packages/rsync
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/rsync')
-rw-r--r--meta/packages/rsync/files/rsyncd.conf15
-rw-r--r--meta/packages/rsync/rsync_2.6.9.bb17
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/rsync/files/rsyncd.conf b/meta/packages/rsync/files/rsyncd.conf
new file mode 100644
index 0000000000..845f5b33f5
--- /dev/null
+++ b/meta/packages/rsync/files/rsyncd.conf
@@ -0,0 +1,15 @@
1# /etc/rsyncd.conf
2
3# Minimal configuration file for rsync daemon
4# See rsync(1) and rsyncd.conf(5) man pages for help
5
6# This file is required by rsync --daemon
7pid file = /var/run/rsyncd.pid
8use chroot = yes
9read only = yes
10
11# Simple example for enabling your own local rsync server
12#[everything]
13# path = /
14# comment = Everything except /etc exposed
15# exclude = /etc
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb
new file mode 100644
index 0000000000..ab7ae43428
--- /dev/null
+++ b/meta/packages/rsync/rsync_2.6.9.bb
@@ -0,0 +1,17 @@
1LICENSE = "GPL"
2DESCRIPTION = "A file-synchronization tool"
3SECTION = "console/network"
4PRIORITY = "optional"
5PR = "r0"
6
7SRC_URI = "http://rsync.samba.org/ftp/rsync/rsync-${PV}.tar.gz \
8 file://rsyncd.conf"
9
10inherit autotools
11
12do_install_append() {
13 install -d ${D}/etc
14 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
15}
16
17EXTRA_OEMAKE='STRIP=""'