summaryrefslogtreecommitdiffstats
path: root/meta/packages/rpm/rpm_4.4.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/rpm/rpm_4.4.2.3.bb')
-rw-r--r--meta/packages/rpm/rpm_4.4.2.3.bb117
1 files changed, 0 insertions, 117 deletions
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb
deleted file mode 100644
index 6605650023..0000000000
--- a/meta/packages/rpm/rpm_4.4.2.3.bb
+++ /dev/null
@@ -1,117 +0,0 @@
1DESCRIPTION = "The RPM Package Manager."
2HOMEPAGE = "http://rpm.org/"
3BUGTRACKER = "http://rpm.org/report"
4
5# library is covered under dual license of GPL | LGPL
6LICENSE = "(LGPLv2+ | GPLv2+) & GPLv2+"
7
8DEPENDS = "zlib beecrypt file popt python"
9PR = "r16"
10
11SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
12 file://external-tools.patch;patch=1 \
13 file://cross_libpaths.patch;patch=1 \
14 file://weakdeps.patch;patch=1;pnum=0 \
15 file://tagsbackport.patch;patch=1;pnum=0 \
16 file://missingok.patch;patch=1;pnum=0 \
17 file://extcond.patch;patch=1;pnum=0 \
18 file://disabledwarf.patch;patch=1"
19
20S = "${WORKDIR}/rpm-${PV}"
21
22inherit autotools gettext
23
24acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
25
26EXTRA_OECONF = "--with-python=$PYTHONVER \
27 --with-python-incdir=${STAGING_INCDIR}/python$PYTHONVER \
28 --with-python-libdir=${libdir}/python$PYTHONVER \
29 --without-apidocs \
30 --without-selinux \
31 --without-lua \
32 --without-dmalloc \
33 --without-efence"
34
35PACKAGES += "python-rpm"
36FILES_python-rpm = "${libdir}/python*/site-packages/rpm/_*"
37
38# Handle the db MUTEX settings here, the POSIX library is
39# the default - "POSIX/pthreads/library".
40# Don't ignore the nice SWP instruction on the ARM:
41# These enable the ARM assembler mutex code, this won't
42# work with thumb compilation...
43ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
44MUTEX = ""
45MUTEX_arm = "${ARM_MUTEX}"
46MUTEX_armeb = "${ARM_MUTEX}"
47EXTRA_OECONF += "${MUTEX}"
48
49export varprefix = "${localstatedir}"
50
51do_configure () {
52 rm ${S}/popt/ -Rf
53 rm ${S}/db/dist/configure.in -f
54 cd ${S}/db/dist/aclocal
55 rm libtool* -f
56 for i in `ls *.ac`; do
57 j=`echo $i | sed 's/.ac/.m4/g'`
58 mv $i $j
59 done
60 cd ${S}/db/dist/aclocal_java
61 for i in `ls *.ac`; do
62 j=`echo $i | sed 's/.ac/.m4/g'`
63 mv $i $j
64 done
65 cd ${S}
66 autotools_do_configure
67 cd ${S}/db/dist
68 . ./RELEASE
69 # Edit version information we couldn't pre-compute.
70 (echo "1,\$s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" &&
71 echo "1,\$s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" &&
72 echo "1,\$s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" &&
73 echo "1,\$s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" &&
74 echo "1,\$s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" &&
75 echo "1,\$s/__EDIT_DB_VERSION__/$DB_VERSION/g" &&
76 echo "w" &&
77 echo "q") | ed configure
78 cd ${S}/db3
79 ${S}/db3/configure \
80 --build=${BUILD_SYS} \
81 --host=${HOST_SYS} \
82 --target=${TARGET_SYS} \
83 --prefix=${prefix} \
84 --exec_prefix=${exec_prefix} \
85 --bindir=${bindir} \
86 --sbindir=${sbindir} \
87 --libexecdir=${libexecdir} \
88 --datadir=${datadir} \
89 --sysconfdir=${sysconfdir} \
90 --sharedstatedir=${sharedstatedir} \
91 --localstatedir=${localstatedir} \
92 --libdir=${libdir} \
93 --includedir=${includedir} \
94 --oldincludedir=${oldincludedir} \
95 --infodir=${infodir} \
96 --mandir=${mandir} \
97 ${EXTRA_OECONF} \
98 --with-pic
99
100}
101
102do_install_append () {
103 rmdir ${D}${localstatedir}/tmp || true
104}
105
106def rpm_python_version(d):
107 import os, bb
108 staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
109 if os.path.exists( "%s/python2.6" % staging_incdir ): return "2.6"
110 if os.path.exists( "%s/python2.5" % staging_incdir ): return "2.5"
111 if os.path.exists( "%s/python2.4" % staging_incdir ): return "2.4"
112 if os.path.exists( "%s/python2.3" % staging_incdir ): return "2.3"
113 raise "No Python in STAGING_INCDIR. Forgot to build python/python-native?"
114
115# Use a shell variable here since otherwise gettext trys to expand this at
116# parse time when it manipulates EXTRA_OECONF which fails
117export PYTHONVER = "${@rpm_python_version(d)}"