summaryrefslogtreecommitdiffstats
path: root/meta/packages/rpm/files/external-tools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/rpm/files/external-tools.patch')
-rw-r--r--meta/packages/rpm/files/external-tools.patch108
1 files changed, 0 insertions, 108 deletions
diff --git a/meta/packages/rpm/files/external-tools.patch b/meta/packages/rpm/files/external-tools.patch
deleted file mode 100644
index 2b2ff701ad..0000000000
--- a/meta/packages/rpm/files/external-tools.patch
+++ /dev/null
@@ -1,108 +0,0 @@
1Index: rpm-4.4.2.3/configure.ac
2===================================================================
3--- rpm-4.4.2.3.orig/configure.ac 2008-04-01 08:30:14.000000000 +0100
4+++ rpm-4.4.2.3/configure.ac 2008-08-17 10:57:30.000000000 +0100
5@@ -529,7 +529,7 @@
6 WITH_MAGIC_INCLUDE=
7 WITH_MAGIC_LIB=
8
9-if test -d file ; then
10+if test -d file ; then
11 WITH_RPMFILE=rpmfile
12 WITH_MAGIC_SUBDIR=file
13 WITH_MAGIC_INCLUDE="-I\${top_srcdir}/${WITH_MAGIC_SUBDIR}/src"
14@@ -1307,7 +1307,7 @@
15 dnl # XXX Propagate -lucb to popt ...
16 dnl export LIBS INCPATH CONFIG_SITE
17
18-AC_CONFIG_SUBDIRS(popt file db3)
19+AC_CONFIG_SUBDIRS(db/dist file)
20
21 AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt
22 rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
23Index: rpm-4.4.2.3/db/dist/configure.ac
24===================================================================
25--- rpm-4.4.2.3.orig/db/dist/configure.ac 2008-04-01 08:28:21.000000000 +0100
26+++ rpm-4.4.2.3/db/dist/configure.ac 2008-08-17 09:54:37.000000000 +0100
27@@ -11,14 +11,6 @@
28 AC_CANONICAL_HOST()
29 AC_ARG_PROGRAM()
30
31-# Don't build in the top-level or dist directories.
32-AC_MSG_CHECKING(if building in the top-level or dist directories)
33-if [ test -d db_archive -o -f configure.ac ] ; then
34- AC_MSG_RESULT(yes)
35- AC_MSG_ERROR(
36- [Berkeley DB should not be built in the top-level or dist directories.])
37-fi
38-AC_MSG_RESULT(no)
39
40 # Substitution variables.
41 AC_SUBST(ADDITIONAL_INCS)
42@@ -281,7 +273,7 @@
43 AC_PROG_LIBTOOL
44
45 SOFLAGS="-rpath \$(libdir)"
46-LIBTOOL_PROG="${SHELL} ./libtool"
47+LIBTOOL_PROG="${SHELL} ./$host_alias-libtool"
48
49 # Set SOSUFFIX and friends
50 SOSUFFIX_CONFIG
51@@ -297,7 +289,7 @@
52 MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -avoid-version"
53 MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK}"
54
55-LIBTOOL="\$(SHELL) ./libtool"
56+LIBTOOL="\$(SHELL) ./$host_alias-libtool"
57
58 case "$host_os" in
59 cygwin* | mingw*)
60Index: rpm-4.4.2.3/db/dist/aclocal/options.ac
61===================================================================
62--- rpm-4.4.2.3.orig/db/dist/aclocal/options.ac 2008-08-17 09:57:49.000000000 +0100
63+++ rpm-4.4.2.3/db/dist/aclocal/options.ac 2008-08-17 09:57:59.000000000 +0100
64@@ -277,10 +277,6 @@
65
66 # Uniquename excludes C++, Java, RPC.
67 if test "$db_cv_uniquename" = "yes"; then
68- if test "$db_cv_rpc" = "yes"; then
69- AC_MSG_ERROR(
70- [--with-uniquename is not compatible with --enable-rpc])
71- fi
72 if test "$db_cv_cxx" = "yes"; then
73 AC_MSG_ERROR(
74 [--with-uniquename is not compatible with --enable-cxx])
75Index: rpm-4.4.2.3/db/dist/aclocal/rpc.ac
76===================================================================
77--- rpm-4.4.2.3.orig/db/dist/aclocal/rpc.ac 2008-08-17 10:46:26.000000000 +0100
78+++ rpm-4.4.2.3/db/dist/aclocal/rpc.ac 2008-08-17 10:46:47.000000000 +0100
79@@ -60,6 +60,7 @@
80 -e 's/^}/__dbsrv_timeout(0);}/' \
81 -e '}' \
82 -e '1,/^#include/s/^#include/#include "db_config.h"\
83+#include "db_int_def.h"\
84 &/' > db_server_svc.c
85
86 $RPCGEN -c $XDR_FILE |
87Index: rpm-4.4.2.3/tools/rpmfile.c
88===================================================================
89--- rpm-4.4.2.3.orig/tools/rpmfile.c 2008-08-17 11:01:51.000000000 +0100
90+++ rpm-4.4.2.3/tools/rpmfile.c 2008-08-17 11:03:07.000000000 +0100
91@@ -29,7 +29,7 @@
92 * file - find type of a file or files - main program.
93 */
94
95-#include "file.h"
96+#include "../file/src/file.h"
97 #include "magic.h"
98
99 #include <stdio.h>
100@@ -69,7 +69,7 @@
101
102 #include <netinet/in.h> /* for byte swapping */
103
104-#include "patchlevel.h"
105+#include "../file/src/patchlevel.h"
106
107 #ifndef lint
108 FILE_RCSID("@(#)$Id: file.c,v 1.96 2005/03/06 05:58:22 christos Exp $")