summaryrefslogtreecommitdiffstats
path: root/meta/packages/rpm/files/cross_libpaths.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/rpm/files/cross_libpaths.patch')
-rw-r--r--meta/packages/rpm/files/cross_libpaths.patch253
1 files changed, 0 insertions, 253 deletions
diff --git a/meta/packages/rpm/files/cross_libpaths.patch b/meta/packages/rpm/files/cross_libpaths.patch
deleted file mode 100644
index 9e8f7dca82..0000000000
--- a/meta/packages/rpm/files/cross_libpaths.patch
+++ /dev/null
@@ -1,253 +0,0 @@
1Index: rpm-4.4.2.3/configure.ac
2===================================================================
3--- rpm-4.4.2.3.orig/configure.ac 2008-08-23 16:03:51.000000000 +0100
4+++ rpm-4.4.2.3/configure.ac 2008-08-25 16:26:11.000000000 +0100
5@@ -326,10 +326,8 @@
6
7 localdone=
8
9-dirs=$prefix
10 if test "$cross_compiling" != "yes"; then
11- dirs="$dirs /usr/local"
12-fi
13+dirs="$prefix /usr/local"
14 for dir in $dirs
15 do
16 case $dir in
17@@ -371,6 +369,7 @@
18 else
19 AC_MSG_RESULT(no)
20 fi
21+fi
22
23 dnl
24 dnl Check for features
25@@ -473,7 +472,7 @@
26 AC_CHECK_HEADER([beecrypt/api.h], [
27 AC_DEFINE(HAVE_BEECRYPT_API_H, 1, [Define to 1 if you have the <beecrypt/api.h> header file.])
28 ])
29- WITH_BEECRYPT_INCLUDE="-I${includedir}/beecrypt"
30+ WITH_BEECRYPT_INCLUDE=""
31 WITH_BEECRYPT_LIB="-lbeecrypt"
32 ])
33 ],[
34@@ -506,7 +505,7 @@
35 AC_CHECK_LIB(neon, ne_send_request_chunk, [
36 AC_DEFINE(HAVE_NEON_NE_SEND_REQUEST_CHUNK, 1, [Define to 1 if you have ne_send_request_chunk() in libneon.])
37 ])
38- WITH_NEON_INCLUDE="-I${includedir}/neon"
39+ WITH_NEON_INCLUDE=""
40 WITH_NEON_LIB="-lneon"
41 ])
42 ],[
43@@ -857,6 +856,12 @@
44 dnl
45 dnl Auto-detect which python bindings should be built.
46 dnl
47+
48+AC_ARG_WITH(python-incdir, [ --with-python-incdir python include directory ])
49+PYTHON_INCDIR=$withval
50+AC_ARG_WITH(python-libdir, [ --with-python-libdir python library directory ])
51+PYTHON_LIBDIR=$withval
52+
53 withval=auto
54 AC_ARG_WITH(python, [ --with-python build rpm python bindings ])
55
56@@ -934,6 +939,8 @@
57 AC_SUBST(WITH_PYTHON_SUBDIR)
58 AC_SUBST(WITH_PYTHON_SUBPACKAGE)
59 AC_SUBST(WITH_PYTHON_VERSION)
60+AC_SUBST(PYTHON_LIBDIR)
61+AC_SUBST(PYTHON_INCDIR)
62
63 AC_PATH_PROG(__DOXYGEN, doxygen, no, $PATH)
64 dnl
65Index: rpm-4.4.2.3/rpmio/Makefile.am
66===================================================================
67--- rpm-4.4.2.3.orig/rpmio/Makefile.am 2008-04-01 08:28:22.000000000 +0100
68+++ rpm-4.4.2.3/rpmio/Makefile.am 2008-08-23 12:14:12.000000000 +0100
69@@ -26,9 +26,7 @@
70
71 BEECRYPTLOBJS = $(shell test X"@WITH_BEECRYPT_SUBDIR@" != X && cat $(top_builddir)/@WITH_BEECTYPT_SUBDIR@/listobjs)
72
73-LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
74-
75-usrlibdir = $(libdir)@MARK64@
76+usrlibdir = $(libdir)
77 usrlib_LTLIBRARIES = librpmio.la
78 librpmio_la_SOURCES = \
79 argv.c digest.c fts.c macro.c rpmdav.c \
80Index: rpm-4.4.2.3/rpmio/rpmio_internal.h
81===================================================================
82--- rpm-4.4.2.3.orig/rpmio/rpmio_internal.h 2008-04-01 08:28:22.000000000 +0100
83+++ rpm-4.4.2.3/rpmio/rpmio_internal.h 2008-08-23 12:07:29.000000000 +0100
84@@ -12,22 +12,22 @@
85 #if HAVE_BEECRYPT_API_H
86 #include <api.h>
87 #else
88-#include <beecrypt.api.h>
89+#include <beecrypt/beecrypt.api.h>
90 #endif
91
92 #include <rpmpgp.h>
93 #include <rpmsw.h>
94
95 /* Drag in the beecrypt includes. */
96-#include <beecrypt.h>
97-#include <base64.h>
98-#include <dsa.h>
99-#include <endianness.h>
100-#include <md5.h>
101-#include <mp.h>
102-#include <rsa.h>
103-#include <rsapk.h>
104-#include <sha1.h>
105+#include <beecrypt/beecrypt.h>
106+#include <beecrypt/base64.h>
107+#include <beecrypt/dsa.h>
108+#include <beecrypt/endianness.h>
109+#include <beecrypt/md5.h>
110+#include <beecrypt/mp.h>
111+#include <beecrypt/rsa.h>
112+#include <beecrypt/rsapk.h>
113+#include <beecrypt/sha1.h>
114 #if HAVE_BEECRYPT_API_H
115 #include <sha256.h>
116 #include <sha384.h>
117Index: rpm-4.4.2.3/Makefile.am
118===================================================================
119--- rpm-4.4.2.3.orig/Makefile.am 2008-04-01 08:28:21.000000000 +0100
120+++ rpm-4.4.2.3/Makefile.am 2008-08-25 23:09:40.000000000 +0100
121@@ -10,7 +10,7 @@
122 po/*.in po/*.po po/rpm.pot \
123 rpm.magic rpmpopt-$(VERSION) rpmqv.c
124
125-SUBDIRS = po misc @WITH_ZLIB_SUBDIR@ @WITH_ELFUTILS_SUBDIR@ @WITH_MAGIC_SUBDIR@ @WITH_DB_SUBDIR@ @WITH_SQLITE3_SUBDIR@ @WITH_POPT_SUBDIR@ @WITH_BEECRYPT_SUBDIR@ @WITH_NEON_SUBDIR@ lua rpmio rpmdb lib build @WITH_PYTHON_SUBDIR@ tools scripts doc .
126+SUBDIRS = po misc @WITH_ZLIB_SUBDIR@ @WITH_ELFUTILS_SUBDIR@ @WITH_MAGIC_SUBDIR@ @WITH_DB_SUBDIR@ @WITH_SQLITE3_SUBDIR@ @WITH_POPT_SUBDIR@ @WITH_BEECRYPT_SUBDIR@ @WITH_NEON_SUBDIR@ rpmio rpmdb lib build @WITH_PYTHON_SUBDIR@ tools scripts doc .
127
128 INCLUDES = \
129 -I$(top_srcdir)/build \
130@@ -93,7 +93,7 @@
131 rpm2cpio_LDFLAGS = $(myLDFLAGS)
132 rpm2cpio_LDADD = $(myLDADD) @LIBMISC@
133
134-$(PROGRAMS): $(myLDADD) @WITH_APIDOCS_TARGET@
135+$(PROGRAMS): @WITH_APIDOCS_TARGET@
136
137 .PHONY: splint
138 splint:
139Index: rpm-4.4.2.3/rpmdb/Makefile.am
140===================================================================
141--- rpm-4.4.2.3.orig/rpmdb/Makefile.am 2008-04-01 08:28:22.000000000 +0100
142+++ rpm-4.4.2.3/rpmdb/Makefile.am 2008-08-23 12:13:18.000000000 +0100
143@@ -41,10 +41,7 @@
144 # XXX watchout, ../db3/libdb.la created by this Makefile may surprise
145 libdb_la = $(top_builddir)/$(WITH_DB_SUBDIR)/libdb.la
146
147-# XXX grrr, RPM_BUILD_ROOT prevents build pollution if/when -lrpm different
148-LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
149-
150-usrlibdir = $(libdir)@MARK64@
151+usrlibdir = $(libdir)
152 usrlib_LTLIBRARIES = librpmdb.la
153 librpmdb_la_SOURCES = \
154 dbconfig.c fprint.c \
155Index: rpm-4.4.2.3/lib/Makefile.am
156===================================================================
157--- rpm-4.4.2.3.orig/lib/Makefile.am 2008-04-01 08:28:22.000000000 +0100
158+++ rpm-4.4.2.3/lib/Makefile.am 2008-08-23 16:03:51.000000000 +0100
159@@ -29,9 +29,7 @@
160 mylibs = librpm.la
161 LIBS =
162
163-LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
164-
165-usrlibdir = $(libdir)@MARK64@
166+usrlibdir = $(libdir)
167 usrlib_LTLIBRARIES = librpm.la
168 librpm_la_SOURCES = \
169 cpio.c depends.c formats.c fs.c fsm.c getdate.c \
170Index: rpm-4.4.2.3/build/Makefile.am
171===================================================================
172--- rpm-4.4.2.3.orig/build/Makefile.am 2008-04-01 08:28:21.000000000 +0100
173+++ rpm-4.4.2.3/build/Makefile.am 2008-08-23 16:03:51.000000000 +0100
174@@ -22,9 +22,7 @@
175 pkginc_HEADERS = rpmbuild.h rpmfc.h rpmfile.h rpmspec.h
176 noinst_HEADERS = buildio.h
177
178-LDFLAGS = -L$(RPM_BUILD_ROOT)$(usrlibdir) -L$(DESTDIR)$(usrlibdir)
179-
180-usrlibdir = $(libdir)@MARK64@
181+usrlibdir = $(libdir)
182 usrlib_LTLIBRARIES = librpmbuild.la
183 librpmbuild_la_SOURCES = \
184 build.c expression.c files.c misc.c names.c pack.c \
185Index: rpm-4.4.2.3/python/Makefile.am
186===================================================================
187--- rpm-4.4.2.3.orig/python/Makefile.am 2008-04-01 08:28:22.000000000 +0100
188+++ rpm-4.4.2.3/python/Makefile.am 2008-08-25 16:26:56.000000000 +0100
189@@ -4,8 +4,8 @@
190
191 LINT = splint
192
193-pylibdir = ${prefix}/lib@MARK64@/python@WITH_PYTHON_VERSION@
194-pyincdir = $(prefix)/include/python@WITH_PYTHON_VERSION@
195+pylibdir = @PYTHON_LIBDIR@
196+pyincdir = @PYTHON_INCDIR@
197
198 SUBDIRS = rpm
199
200Index: rpm-4.4.2.3/python/rpm/Makefile.am
201===================================================================
202--- rpm-4.4.2.3.orig/python/rpm/Makefile.am 2008-04-01 08:28:22.000000000 +0100
203+++ rpm-4.4.2.3/python/rpm/Makefile.am 2008-08-25 16:27:29.000000000 +0100
204@@ -4,8 +4,8 @@
205
206 PYVER = @WITH_PYTHON_VERSION@
207
208-pylibdir = ${prefix}/lib@MARK64@/python@WITH_PYTHON_VERSION@
209-pyincdir = $(prefix)/include/python@WITH_PYTHON_VERSION@
210+pylibdir = @PYTHON_LIBDIR@
211+pyincdir = @PYTHON_INCDIR@
212
213 EXTRA_DIST = \
214 __init__.py
215Index: rpm-4.4.2.3/file/src/Makefile.am
216===================================================================
217--- rpm-4.4.2.3.orig/file/src/Makefile.am 2008-08-23 16:06:25.000000000 +0100
218+++ rpm-4.4.2.3/file/src/Makefile.am 2008-08-23 16:06:39.000000000 +0100
219@@ -4,7 +4,7 @@
220 EXTRA_DIST = test.c
221
222 # XXX Make sure compress.c links internal zlib
223-INCLUDES = -I. -I ../../zlib
224+INCLUDES = -I.
225
226 pkglibdir = @prefix@/lib/rpm
227 MAGIC = $(pkglibdir)/magic
228@@ -26,7 +26,7 @@
229
230 noinst_PROGRAMS = file
231 file_SOURCES = file.c
232-file_LDFLAGS = -L../../zlib # -all-static
233+#file_LDFLAGS = -L../../zlib # -all-static
234 file_LDADD = libmagic.la
235
236 listobjs:
237Index: rpm-4.4.2.3/file/magic/Makefile.am
238===================================================================
239--- rpm-4.4.2.3.orig/file/magic/Makefile.am 2008-08-25 16:14:47.000000000 +0100
240+++ rpm-4.4.2.3/file/magic/Makefile.am 2008-08-25 16:15:02.000000000 +0100
241@@ -18,10 +18,10 @@
242 done >> $@
243
244 magic.mgc: magic
245- $(top_builddir)/src/file -C -m magic
246+ file -C -m magic
247
248 magic.mime.mgc: magic.mime
249- $(top_builddir)/src/file -C -m $(srcdir)/magic.mime
250+ file -C -m $(srcdir)/magic.mime
251
252 magic_FRAGMENTS = \
253 Magdir/acorn \