diff options
Diffstat (limited to 'meta/packages/readline')
-rw-r--r-- | meta/packages/readline/files/acinclude.m4 (renamed from meta/packages/readline/readline-5.2/acinclude.m4) | 0 | ||||
-rw-r--r-- | meta/packages/readline/files/configure-fix.patch (renamed from meta/packages/readline/readline-5.2/configure_fix.patch) | 0 | ||||
-rw-r--r-- | meta/packages/readline/readline.inc | 35 | ||||
-rw-r--r-- | meta/packages/readline/readline_5.2.bb | 36 | ||||
-rw-r--r-- | meta/packages/readline/readline_6.1.bb | 3 |
5 files changed, 42 insertions, 32 deletions
diff --git a/meta/packages/readline/readline-5.2/acinclude.m4 b/meta/packages/readline/files/acinclude.m4 index 8a45f99084..8a45f99084 100644 --- a/meta/packages/readline/readline-5.2/acinclude.m4 +++ b/meta/packages/readline/files/acinclude.m4 | |||
diff --git a/meta/packages/readline/readline-5.2/configure_fix.patch b/meta/packages/readline/files/configure-fix.patch index 4100fe42a7..4100fe42a7 100644 --- a/meta/packages/readline/readline-5.2/configure_fix.patch +++ b/meta/packages/readline/files/configure-fix.patch | |||
diff --git a/meta/packages/readline/readline.inc b/meta/packages/readline/readline.inc new file mode 100644 index 0000000000..f8bb45abea --- /dev/null +++ b/meta/packages/readline/readline.inc | |||
@@ -0,0 +1,35 @@ | |||
1 | DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \ | ||
2 | command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \ | ||
3 | additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \ | ||
4 | lines, and perform csh-like history expansion on previous commands." | ||
5 | SECTION = "libs" | ||
6 | PRIORITY = "optional" | ||
7 | |||
8 | # GPLv2+ (< 6.0), GPLv3+ (>= 6.0) | ||
9 | LICENSE = "GPLv3+" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
11 | |||
12 | DEPENDS += "ncurses" | ||
13 | RPROVIDES_${PN} += "readline" | ||
14 | |||
15 | SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz \ | ||
16 | file://configure-fix.patch \ | ||
17 | file://acinclude.m4" | ||
18 | |||
19 | S = "${WORKDIR}/${BPN}-${PV}" | ||
20 | |||
21 | inherit autotools | ||
22 | |||
23 | LEAD_SONAME = "libreadline.so" | ||
24 | |||
25 | do_configure_prepend () { | ||
26 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | ||
27 | } | ||
28 | |||
29 | do_install_append () { | ||
30 | # Make install doesn't properly install these | ||
31 | oe_libinstall -so -C shlib libhistory ${D}${libdir} | ||
32 | oe_libinstall -so -C shlib libreadline ${D}${libdir} | ||
33 | } | ||
34 | |||
35 | BBCLASSEXTEND = "native" | ||
diff --git a/meta/packages/readline/readline_5.2.bb b/meta/packages/readline/readline_5.2.bb index 10ce18fe9a..10f88ce196 100644 --- a/meta/packages/readline/readline_5.2.bb +++ b/meta/packages/readline/readline_5.2.bb | |||
@@ -1,33 +1,5 @@ | |||
1 | DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \ | 1 | require readline.inc |
2 | command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \ | ||
3 | additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \ | ||
4 | lines, and perform csh-like history expansion on previous commands." | ||
5 | SECTION = "libs" | ||
6 | PRIORITY = "optional" | ||
7 | LICENSE = "GPLv2" | ||
8 | DEPENDS += "ncurses" | ||
9 | RPROVIDES_${PN} += "readline" | ||
10 | LEAD_SONAME = "libreadline.so" | ||
11 | PR = "r4" | ||
12 | 2 | ||
13 | SRC_URI = "ftp://ftp.gnu.org/gnu/readline/readline-${PV}.tar.gz \ | 3 | LICENSE = "GPLv2+" |
14 | file://configure_fix.patch;patch=1 \ | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f" |
15 | file://acinclude.m4" | 5 | PR = "r5" |
16 | |||
17 | S = "${WORKDIR}/readline-${PV}" | ||
18 | |||
19 | inherit autotools | ||
20 | |||
21 | do_configure () { | ||
22 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | ||
23 | autotools_do_configure | ||
24 | } | ||
25 | |||
26 | do_install () { | ||
27 | autotools_do_install | ||
28 | # Make install doesn't properly install these | ||
29 | oe_libinstall -so -C shlib libhistory ${D}${libdir} | ||
30 | oe_libinstall -so -C shlib libreadline ${D}${libdir} | ||
31 | } | ||
32 | |||
33 | BBCLASSEXTEND = "native" | ||
diff --git a/meta/packages/readline/readline_6.1.bb b/meta/packages/readline/readline_6.1.bb new file mode 100644 index 0000000000..c32755669c --- /dev/null +++ b/meta/packages/readline/readline_6.1.bb | |||
@@ -0,0 +1,3 @@ | |||
1 | require readline.inc | ||
2 | |||
3 | PR = "r0" | ||