summaryrefslogtreecommitdiffstats
path: root/meta/packages/readline/readline_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/readline/readline_5.2.bb')
-rw-r--r--meta/packages/readline/readline_5.2.bb36
1 files changed, 4 insertions, 32 deletions
diff --git a/meta/packages/readline/readline_5.2.bb b/meta/packages/readline/readline_5.2.bb
index 10ce18fe9a..10f88ce196 100644
--- a/meta/packages/readline/readline_5.2.bb
+++ b/meta/packages/readline/readline_5.2.bb
@@ -1,33 +1,5 @@
1DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \ 1require readline.inc
2command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4lines, and perform csh-like history expansion on previous commands."
5SECTION = "libs"
6PRIORITY = "optional"
7LICENSE = "GPLv2"
8DEPENDS += "ncurses"
9RPROVIDES_${PN} += "readline"
10LEAD_SONAME = "libreadline.so"
11PR = "r4"
12 2
13SRC_URI = "ftp://ftp.gnu.org/gnu/readline/readline-${PV}.tar.gz \ 3LICENSE = "GPLv2+"
14 file://configure_fix.patch;patch=1 \ 4LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f"
15 file://acinclude.m4" 5PR = "r5"
16
17S = "${WORKDIR}/readline-${PV}"
18
19inherit autotools
20
21do_configure () {
22 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
23 autotools_do_configure
24}
25
26do_install () {
27 autotools_do_install
28 # Make install doesn't properly install these
29 oe_libinstall -so -C shlib libhistory ${D}${libdir}
30 oe_libinstall -so -C shlib libreadline ${D}${libdir}
31}
32
33BBCLASSEXTEND = "native"