summaryrefslogtreecommitdiffstats
path: root/meta/packages/readline/readline_4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/readline/readline_4.3.bb')
-rw-r--r--meta/packages/readline/readline_4.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/packages/readline/readline_4.3.bb b/meta/packages/readline/readline_4.3.bb
new file mode 100644
index 0000000000..d0ff2a8d7c
--- /dev/null
+++ b/meta/packages/readline/readline_4.3.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4lines, and perform csh-like history expansion on previous commands."
5SECTION = "libs"
6PRIORITY = "optional"
7LICENSE = "GPLv2"
8DEPENDS += "ncurses"
9RPROVIDES_${PN} += "readline"
10LEAD_SONAME = "libreadline.so"
11PR = "r3"
12
13SRC_URI = "ftp://ftp.cwru.edu/pub/bash/readline-${PV}.tar.gz \
14 file://shlink-termcap.patch;patch=1 \
15 file://acinclude.m4"
16S = "${WORKDIR}/readline-${PV}"
17
18inherit autotools
19
20do_configure () {
21 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
22 autotools_do_configure
23}
24
25do_stage() {
26 autotools_stage_all
27}
28
29do_install () {
30 autotools_do_install
31 # Make install doesn't properly install these
32 oe_libinstall -so -C shlib libhistory ${D}${libdir}
33 oe_libinstall -so -C shlib libreadline ${D}${libdir}
34}