summaryrefslogtreecommitdiffstats
path: root/meta/packages/quilt
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/quilt')
-rw-r--r--meta/packages/quilt/files/install.patch19
-rw-r--r--meta/packages/quilt/files/non-gnu.patch13
-rw-r--r--meta/packages/quilt/files/nostrip.patch16
-rw-r--r--meta/packages/quilt/quilt-native_0.42.bb14
-rw-r--r--meta/packages/quilt/quilt-package.inc10
-rw-r--r--meta/packages/quilt/quilt.inc13
-rw-r--r--meta/packages/quilt/quilt_0.42.bb7
7 files changed, 92 insertions, 0 deletions
diff --git a/meta/packages/quilt/files/install.patch b/meta/packages/quilt/files/install.patch
new file mode 100644
index 0000000000..4122370d6a
--- /dev/null
+++ b/meta/packages/quilt/files/install.patch
@@ -0,0 +1,19 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- quilt-0.32/Makefile.in~install
7+++ quilt-0.32/Makefile.in
8@@ -9,9 +9,9 @@
9 libdir := @libdir@
10 datadir := @datadir@
11 docdir := @docdir@
12-mandir := $(datadir)/man
13+mandir := @mandir@
14 localedir := $(datadir)/locale
15-etcdir := $(subst /usr/etc,/etc,$(prefix)/etc)
16+etcdir := @sysconfdir@
17
18 QUILT_DIR = $(datadir)/$(PACKAGE)
19 SCRIPTS_DIR = $(QUILT_DIR)/scripts
diff --git a/meta/packages/quilt/files/non-gnu.patch b/meta/packages/quilt/files/non-gnu.patch
new file mode 100644
index 0000000000..8b07bc2923
--- /dev/null
+++ b/meta/packages/quilt/files/non-gnu.patch
@@ -0,0 +1,13 @@
1Index: quilt/Makefile.in
2===================================================================
3--- quilt.orig/Makefile.in
4+++ quilt/Makefile.in
5@@ -216,7 +216,7 @@
6 -e 's:@LOCALEDIR''@:$(localedir):g' \
7 -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE)-$(VERSION):g' \
8 $< > $@
9- @chmod --reference=$< $@
10+ @chmod `stat -f "%p" $<` $@
11
12 Makefile : Makefile.in
13 @echo "Please run ./configure by hand"
diff --git a/meta/packages/quilt/files/nostrip.patch b/meta/packages/quilt/files/nostrip.patch
new file mode 100644
index 0000000000..4dedad96d4
--- /dev/null
+++ b/meta/packages/quilt/files/nostrip.patch
@@ -0,0 +1,16 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- quilt-0.32/Makefile.in~nostrip
7+++ quilt-0.32/Makefile.in
8@@ -240,7 +240,7 @@
9 @INSTALL@ -m 644 scripts/patchfns $(BUILD_ROOT)$(SCRIPTS_DIR)
10
11 @INSTALL@ -d $(BUILD_ROOT)$(LIB_DIR)
12- @INSTALL@ -m 755 -s $(LIB:%=lib/%) $(BUILD_ROOT)$(LIB_DIR)/
13+ @INSTALL@ -m 755 $(LIB:%=lib/%) $(BUILD_ROOT)$(LIB_DIR)/
14
15 @INSTALL@ -d $(BUILD_ROOT)$(docdir)/$(PACKAGE)-$(VERSION)/
16 @INSTALL@ -m 644 doc/README \
diff --git a/meta/packages/quilt/quilt-native_0.42.bb b/meta/packages/quilt/quilt-native_0.42.bb
new file mode 100644
index 0000000000..d9bdc0e00c
--- /dev/null
+++ b/meta/packages/quilt/quilt-native_0.42.bb
@@ -0,0 +1,14 @@
1include quilt.inc
2RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native"
3
4INHIBIT_AUTOTOOLS_DEPS = "1"
5
6inherit autotools native
7
8PATCHCLEANCMD = ""
9PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
10EXTRA_OECONF = "--disable-nls"
11
12do_configure () {
13 oe_runconf
14}
diff --git a/meta/packages/quilt/quilt-package.inc b/meta/packages/quilt/quilt-package.inc
new file mode 100644
index 0000000000..bcdbcf026a
--- /dev/null
+++ b/meta/packages/quilt/quilt-package.inc
@@ -0,0 +1,10 @@
1PACKAGES += "guards guards-doc"
2FILES_${PN} = "${sysconfdir} ${datadir}/quilt \
3 ${bindir}/quilt ${libdir}/quilt"
4FILES_guards = "${bindir}/guards"
5FILES_${PN}-doc = "${mandir}/man1/quilt.1 ${docdir}/${P}"
6FILES_guards-doc = "${mandir}/man1/guards.1"
7
8do_install () {
9 oe_runmake 'BUILD_ROOT=${D}' install
10}
diff --git a/meta/packages/quilt/quilt.inc b/meta/packages/quilt/quilt.inc
new file mode 100644
index 0000000000..cd5e85c3d8
--- /dev/null
+++ b/meta/packages/quilt/quilt.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "Tool to work with series of patches."
2HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
3SECTION = "devel"
4MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
5LICENSE = "GPL"
6
7SRC_URI = "http://download.savannah.gnu.org/releases/quilt/quilt-${PV}.tar.gz \
8 file://install.patch;patch=1 \
9 file://nostrip.patch;patch=1"
10
11SRC_URI_append_build-darwin = " file://non-gnu.patch;patch=1 "
12
13S = "${WORKDIR}/quilt-${PV}"
diff --git a/meta/packages/quilt/quilt_0.42.bb b/meta/packages/quilt/quilt_0.42.bb
new file mode 100644
index 0000000000..51bfa7a469
--- /dev/null
+++ b/meta/packages/quilt/quilt_0.42.bb
@@ -0,0 +1,7 @@
1RDEPENDS_${PN} += "patch diffstat bzip2"
2
3include quilt.inc
4
5inherit autotools gettext
6
7include quilt-package.inc