diff options
Diffstat (limited to 'meta/packages/qmake/qmake2-cross_2.10a.bb')
-rw-r--r-- | meta/packages/qmake/qmake2-cross_2.10a.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/packages/qmake/qmake2-cross_2.10a.bb b/meta/packages/qmake/qmake2-cross_2.10a.bb new file mode 100644 index 0000000000..99fe90722a --- /dev/null +++ b/meta/packages/qmake/qmake2-cross_2.10a.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | DESCRIPTION = "TrollTech Makefile Generator" | ||
2 | PRIORITY = "optional" | ||
3 | HOMEPAGE = "http://www.trolltech.com" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPL" | ||
6 | PR = "r1" | ||
7 | |||
8 | QTVER = "qtopia-core-opensource-src-4.3.2" | ||
9 | |||
10 | SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \ | ||
11 | file://0001-fix-mkspecs.patch;patch=1 \ | ||
12 | file://use-lflags-last.patch;patch=1 \ | ||
13 | file://linux-oe-qmake.conf" | ||
14 | S = "${WORKDIR}/${QTVER}" | ||
15 | |||
16 | # we need the real target system here | ||
17 | CROSS_SYS := "${TARGET_SYS}" | ||
18 | inherit autotools cross | ||
19 | |||
20 | export QTDIR = "${S}" | ||
21 | EXTRA_OEMAKE = "-e" | ||
22 | |||
23 | do_configure() { | ||
24 | # Install the OE build templates | ||
25 | for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ | ||
26 | do | ||
27 | install -d ${S}/mkspecs/$template | ||
28 | install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf | ||
29 | ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h | ||
30 | done | ||
31 | |||
32 | QMAKESPEC= | ||
33 | PLATFORM=${HOST_OS}-oe-g++ | ||
34 | export PLATFORM | ||
35 | # yes, TARGET_SYS is correct, because this is a 'cross'-qmake-native :) :M: | ||
36 | export OE_QMAKE_CC="${CC}" | ||
37 | export OE_QMAKE_CFLAGS="${CFLAGS}" | ||
38 | export OE_QMAKE_CXX="${CXX}" | ||
39 | export OE_QMAKE_CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}" | ||
40 | export OE_QMAKE_LDFLAGS="${LDFLAGS}" | ||
41 | export OE_QMAKE_LINK="${CCLD}" | ||
42 | export OE_QMAKE_AR="${AR}" | ||
43 | export OE_QMAKE_STRIP="${STRIP}" | ||
44 | export OE_QMAKE_UIC="${STAGING_BINDIR_NATIVE}/uic" | ||
45 | export OE_QMAKE_MOC="${STAGING_BINDIR_NATIVE}/moc" | ||
46 | export OE_QMAKE_RCC="non-existant" | ||
47 | export OE_QMAKE_QMAKE="${STAGING_BINDIR_NATIVE}/qmake" | ||
48 | export OE_QMAKE_RPATH="-Wl,-rpath-link," | ||
49 | echo yes | ./configure -prefix ${STAGING_DIR}/${CROSS_SYS}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed" | ||
50 | } | ||
51 | |||
52 | do_compile() { | ||
53 | : | ||
54 | } | ||
55 | |||
56 | do_stage() { | ||
57 | install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake2 | ||
58 | install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake-qt4 | ||
59 | install -d ${STAGING_DIR}/${CROSS_SYS}/qt4/ | ||
60 | cp -PfR mkspecs ${STAGING_DIR}/${CROSS_SYS}/qt4/ | ||
61 | install -d ${STAGING_DIR}/${HOST_SYS}/qt4/ | ||
62 | cp -PfR mkspecs ${STAGING_DIR}/${HOST_SYS}/qt4/ | ||
63 | } | ||
64 | |||
65 | do_install() { | ||
66 | : | ||
67 | } | ||