summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/qemu/qemu_cvs.bb')
-rw-r--r--meta/packages/qemu/qemu_cvs.bb25
1 files changed, 8 insertions, 17 deletions
diff --git a/meta/packages/qemu/qemu_cvs.bb b/meta/packages/qemu/qemu_cvs.bb
index 137262ca2d..4af21f4a89 100644
--- a/meta/packages/qemu/qemu_cvs.bb
+++ b/meta/packages/qemu/qemu_cvs.bb
@@ -1,7 +1,7 @@
1LICENSE = "GPL" 1LICENSE = "GPL"
2DEPENDS = "zlib" 2DEPENDS = "zlib"
3PV = "0.9.0+cvs${SRCDATE}" 3PV = "0.9.1+cvs${SRCDATE}"
4PR = "r4" 4PR = "r1"
5 5
6DEFAULT_PREFERENCE = "-1" 6DEFAULT_PREFERENCE = "-1"
7FILESDIR = "${WORKDIR}" 7FILESDIR = "${WORKDIR}"
@@ -9,13 +9,10 @@ FILESDIR = "${WORKDIR}"
9SRC_URI = "\ 9SRC_URI = "\
10 cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \ 10 cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
11 file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \ 11 file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
12 file://03_machines_list_no_error.patch;patch=1;pnum=0 \
13 file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
14 file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \ 12 file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
15 file://06_exit_segfault.patch;patch=1;pnum=0 \ 13 file://06_exit_segfault.patch;patch=1;pnum=0 \
16 file://10_signal_jobs.patch;patch=1;pnum=0 \ 14 file://10_signal_jobs.patch;patch=1;pnum=0 \
17 file://11_signal_sigaction.patch;patch=1;pnum=0 \ 15 file://11_signal_sigaction.patch;patch=1;pnum=0 \
18 file://12_signal_powerpc_support.patch;patch=1;pnum=1 \
19 file://22_net_tuntap_stall.patch;patch=1;pnum=0 \ 16 file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
20 file://31_syscalls.patch;patch=1;pnum=0 \ 17 file://31_syscalls.patch;patch=1;pnum=0 \
21 file://32_syscall_sysctl.patch;patch=1;pnum=0 \ 18 file://32_syscall_sysctl.patch;patch=1;pnum=0 \
@@ -29,27 +26,21 @@ SRC_URI = "\
29 file://65_kfreebsd.patch;patch=1;pnum=0 \ 26 file://65_kfreebsd.patch;patch=1;pnum=0 \
30 file://66_tls_ld.patch;patch=1;pnum=0 \ 27 file://66_tls_ld.patch;patch=1;pnum=0 \
31 file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \ 28 file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
32 file://93-oh-pl110-rgb.patch;patch=1;pnum=0 \
33 file://qemu-0.9.0-nptl.patch;patch=1 \ 29 file://qemu-0.9.0-nptl.patch;patch=1 \
34 file://qemu-0.9.0-nptl-update.patch;patch=1 \ 30 file://qemu-0.9.0-nptl-update.patch;patch=1 \
35 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \ 31 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
36 file://workaround_bad_futex_headers.patch;patch=1 \ 32 file://workaround_bad_futex_headers.patch;patch=1 \
37 file://fix_segfault.patch;patch=1" 33 file://fix_segfault.patch;patch=1 \
38 34 file://no-strip.patch;patch=1"
39# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
40# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
41# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
42# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
43# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
44# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
45# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
46# file://debian/patches/96-x.patch;patch=1"
47 35
48S = "${WORKDIR}/qemu" 36S = "${WORKDIR}/qemu"
49 37
50#EXTRA_OECONF += "--disable-sdl" 38#EXTRA_OECONF += "--disable-sdl"
51#EXTRA_OECONF += "--target-list=arm-linux-user" 39#EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu"
52EXTRA_OECONF += "--disable-gfx-check" 40EXTRA_OECONF += "--disable-gfx-check"
53 41
54inherit autotools 42inherit autotools
55 43
44do_configure() {
45 ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
46}