summaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu_20071121.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/qemu/qemu_20071121.bb')
-rw-r--r--meta/packages/qemu/qemu_20071121.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu_20071121.bb b/meta/packages/qemu/qemu_20071121.bb
new file mode 100644
index 0000000000..63100806b0
--- /dev/null
+++ b/meta/packages/qemu/qemu_20071121.bb
@@ -0,0 +1,58 @@
1LICENSE = "GPL"
2DEPENDS = "zlib"
3SRCDATE = "20071121"
4PV = "0.9.0+cvs${SRCDATE}"
5
6DEFAULT_PREFERENCE = "-1"
7
8FILESPATH = "${FILE_DIRNAME}/qemu-${PV}:${FILE_DIRNAME}/files"
9FILESDIR = "${WORKDIR}"
10
11SRC_URI = "\
12 cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
13 file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
14 file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
15 file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
16 file://06_exit_segfault.patch;patch=1;pnum=0 \
17 file://10_signal_jobs.patch;patch=1;pnum=0 \
18 file://11_signal_sigaction.patch;patch=1;pnum=0 \
19 file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
20 file://31_syscalls.patch;patch=1;pnum=0 \
21 file://32_syscall_sysctl.patch;patch=1;pnum=0 \
22 file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
23 file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
24 file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
25 file://52_ne2000_return.patch;patch=1;pnum=1 \
26 file://61_safe_64bit_int.patch;patch=1;pnum=0 \
27 file://63_sparc_build.patch;patch=1;pnum=0 \
28 file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
29 file://65_kfreebsd.patch;patch=1;pnum=0 \
30 file://66_tls_ld.patch;patch=1;pnum=0 \
31 file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
32 file://qemu-0.9.0-nptl.patch;patch=1 \
33 file://qemu-0.9.0-nptl-update.patch;patch=1 \
34 file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
35 file://workaround_bad_futex_headers.patch;patch=1 \
36 file://fix_segfault.patch;patch=1 \
37 file://disable-error-in-configure.patch;patch=1"
38
39# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
40# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
41# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
42# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
43# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
44# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
45# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
46# file://debian/patches/96-x.patch;patch=1"
47
48S = "${WORKDIR}/qemu"
49
50#EXTRA_OECONF += "--disable-sdl"
51#EXTRA_OECONF += "--target-list=arm-linux-user"
52EXTRA_OECONF += "--disable-gfx-check"
53
54inherit autotools
55
56do_configure() {
57 oe_runconf
58}