diff options
Diffstat (limited to 'meta/packages/qemu/qemu-git/fix-nogl.patch')
-rw-r--r-- | meta/packages/qemu/qemu-git/fix-nogl.patch | 31 |
1 files changed, 16 insertions, 15 deletions
diff --git a/meta/packages/qemu/qemu-git/fix-nogl.patch b/meta/packages/qemu/qemu-git/fix-nogl.patch index 6cb812f00c..68efab3a1f 100644 --- a/meta/packages/qemu/qemu-git/fix-nogl.patch +++ b/meta/packages/qemu/qemu-git/fix-nogl.patch | |||
@@ -1,20 +1,21 @@ | |||
1 | Index: git/Makefile.target | 1 | Index: qemu/Makefile.target |
2 | =================================================================== | 2 | =================================================================== |
3 | --- git.orig/Makefile.target 2009-06-09 22:05:27.000000000 +0100 | 3 | --- qemu.orig/Makefile.target 2010-05-11 16:53:34.545811866 -0400 |
4 | +++ git/Makefile.target 2009-06-09 22:05:28.000000000 +0100 | 4 | +++ qemu/Makefile.target 2010-05-11 16:53:37.743809704 -0400 |
5 | @@ -155,6 +155,8 @@ | 5 | @@ -47,6 +47,9 @@ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/soft |
6 | libobj-y += op_helper.o helper.o | ||
7 | libobj-$(CONFIG_NEED_MMU) += mmu.o | ||
8 | libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o | ||
9 | +libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o | ||
10 | +libobj-$(TARGET_ARM) += dummygl.o | ||
11 | +libobj-$(TARGET_MIPS) += dummygl.o | ||
12 | libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o | ||
13 | libobj-$(TARGET_ALPHA) += alpha_palcode.o | ||
6 | 14 | ||
7 | ifeq ($(TARGET_BASE_ARCH), i386) | 15 | Index: qemu/target-arm/dummygl.c |
8 | LIBOBJS+=helper_opengl.o opengl_exec.o | ||
9 | +else | ||
10 | +LIBOBJS+=dummygl.o | ||
11 | endif | ||
12 | |||
13 | ifeq ($(TARGET_BASE_ARCH), arm) | ||
14 | Index: git/target-arm/dummygl.c | ||
15 | =================================================================== | 16 | =================================================================== |
16 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 17 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 |
17 | +++ git/target-arm/dummygl.c 2009-06-09 22:15:55.000000000 +0100 | 18 | +++ qemu/target-arm/dummygl.c 2010-05-11 16:53:37.743809704 -0400 |
18 | @@ -0,0 +1,22 @@ | 19 | @@ -0,0 +1,22 @@ |
19 | +#include <string.h> | 20 | +#include <string.h> |
20 | +#include <stdlib.h> | 21 | +#include <stdlib.h> |
@@ -38,10 +39,10 @@ Index: git/target-arm/dummygl.c | |||
38 | +{ | 39 | +{ |
39 | + | 40 | + |
40 | +} | 41 | +} |
41 | Index: git/target-mips/dummygl.c | 42 | Index: qemu/target-mips/dummygl.c |
42 | =================================================================== | 43 | =================================================================== |
43 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 44 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 |
44 | +++ git/target-mips/dummygl.c 2009-06-09 22:15:55.000000000 +0100 | 45 | +++ qemu/target-mips/dummygl.c 2010-05-11 16:53:37.744811919 -0400 |
45 | @@ -0,0 +1,22 @@ | 46 | @@ -0,0 +1,22 @@ |
46 | +#include <string.h> | 47 | +#include <string.h> |
47 | +#include <stdlib.h> | 48 | +#include <stdlib.h> |