diff options
Diffstat (limited to 'meta/packages/qemu/qemu-0.12.4/fix-nogl.patch')
-rw-r--r-- | meta/packages/qemu/qemu-0.12.4/fix-nogl.patch | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch b/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch new file mode 100644 index 0000000000..68efab3a1f --- /dev/null +++ b/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch | |||
@@ -0,0 +1,68 @@ | |||
1 | Index: qemu/Makefile.target | ||
2 | =================================================================== | ||
3 | --- qemu.orig/Makefile.target 2010-05-11 16:53:34.545811866 -0400 | ||
4 | +++ qemu/Makefile.target 2010-05-11 16:53:37.743809704 -0400 | ||
5 | @@ -47,6 +47,9 @@ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/soft | ||
6 | libobj-y += op_helper.o helper.o | ||
7 | libobj-$(CONFIG_NEED_MMU) += mmu.o | ||
8 | libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o | ||
9 | +libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o | ||
10 | +libobj-$(TARGET_ARM) += dummygl.o | ||
11 | +libobj-$(TARGET_MIPS) += dummygl.o | ||
12 | libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o | ||
13 | libobj-$(TARGET_ALPHA) += alpha_palcode.o | ||
14 | |||
15 | Index: qemu/target-arm/dummygl.c | ||
16 | =================================================================== | ||
17 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
18 | +++ qemu/target-arm/dummygl.c 2010-05-11 16:53:37.743809704 -0400 | ||
19 | @@ -0,0 +1,22 @@ | ||
20 | +#include <string.h> | ||
21 | +#include <stdlib.h> | ||
22 | +#include <assert.h> | ||
23 | +#include <stdint.h> | ||
24 | +#include <X11/Xlib.h> | ||
25 | +#include <X11/Xutil.h> | ||
26 | + | ||
27 | +void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window) | ||
28 | +{ | ||
29 | + | ||
30 | +} | ||
31 | + | ||
32 | +void opengl_process_enable(void) | ||
33 | +{ | ||
34 | + | ||
35 | +} | ||
36 | + | ||
37 | + | ||
38 | +void mem_opengl(uint64_t ptr) | ||
39 | +{ | ||
40 | + | ||
41 | +} | ||
42 | Index: qemu/target-mips/dummygl.c | ||
43 | =================================================================== | ||
44 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
45 | +++ qemu/target-mips/dummygl.c 2010-05-11 16:53:37.744811919 -0400 | ||
46 | @@ -0,0 +1,22 @@ | ||
47 | +#include <string.h> | ||
48 | +#include <stdlib.h> | ||
49 | +#include <assert.h> | ||
50 | +#include <stdint.h> | ||
51 | +#include <X11/Xlib.h> | ||
52 | +#include <X11/Xutil.h> | ||
53 | + | ||
54 | +void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window) | ||
55 | +{ | ||
56 | + | ||
57 | +} | ||
58 | + | ||
59 | +void opengl_process_enable(void) | ||
60 | +{ | ||
61 | + | ||
62 | +} | ||
63 | + | ||
64 | + | ||
65 | +void mem_opengl(uint64_t ptr) | ||
66 | +{ | ||
67 | + | ||
68 | +} | ||