diff options
Diffstat (limited to 'meta/packages/python')
-rw-r--r-- | meta/packages/python/files/pyrex-fix-optimized-mode.patch | 13 | ||||
-rw-r--r-- | meta/packages/python/python-dbus_0.83.0.bb | 25 | ||||
-rw-r--r-- | meta/packages/python/python-pyrex-native_0.9.8.5.bb | 10 | ||||
-rw-r--r-- | meta/packages/python/python-pyrex_0.9.8.5.bb | 16 |
4 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/python/files/pyrex-fix-optimized-mode.patch b/meta/packages/python/files/pyrex-fix-optimized-mode.patch new file mode 100644 index 0000000000..a1f5bb29ba --- /dev/null +++ b/meta/packages/python/files/pyrex-fix-optimized-mode.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: Pyrex-0.9.8.4/Pyrex/Distutils/extension.py | ||
2 | =================================================================== | ||
3 | --- Pyrex-0.9.8.4.orig/Pyrex/Distutils/extension.py | ||
4 | +++ Pyrex-0.9.8.4/Pyrex/Distutils/extension.py | ||
5 | @@ -15,7 +15,7 @@ except ImportError: | ||
6 | warnings = None | ||
7 | |||
8 | class Extension(_Extension.Extension): | ||
9 | - _Extension.Extension.__doc__ + \ | ||
10 | + _Extension.Extension.__doc__ or "" + \ | ||
11 | """pyrex_include_dirs : [string] | ||
12 | list of directories to search for Pyrex header files (.pxd) (in | ||
13 | Unix form for portability) | ||
diff --git a/meta/packages/python/python-dbus_0.83.0.bb b/meta/packages/python/python-dbus_0.83.0.bb new file mode 100644 index 0000000000..275e60e329 --- /dev/null +++ b/meta/packages/python/python-dbus_0.83.0.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication" | ||
2 | SECTION = "devel/python" | ||
3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | ||
4 | LICENSE = "MIT" | ||
5 | DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native" | ||
6 | PR = "ml1" | ||
7 | |||
8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz" | ||
9 | S = "${WORKDIR}/dbus-python-${PV}" | ||
10 | |||
11 | inherit distutils-base autotools pkgconfig | ||
12 | |||
13 | export BUILD_SYS | ||
14 | export HOST_SYS | ||
15 | |||
16 | export STAGING_LIBDIR | ||
17 | export STAGING_INCDIR | ||
18 | |||
19 | do_stage() { | ||
20 | autotools_stage_all | ||
21 | } | ||
22 | |||
23 | RDEPENDS = "python-io python-logging python-stringold python-threading python-xml" | ||
24 | |||
25 | FILES_${PN}-dev += "${libdir}/pkgconfig | ||
diff --git a/meta/packages/python/python-pyrex-native_0.9.8.5.bb b/meta/packages/python/python-pyrex-native_0.9.8.5.bb new file mode 100644 index 0000000000..4405212040 --- /dev/null +++ b/meta/packages/python/python-pyrex-native_0.9.8.5.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | require python-pyrex_${PV}.bb | ||
2 | inherit native | ||
3 | DEPENDS = "python-native" | ||
4 | RDEPENDS = "" | ||
5 | |||
6 | do_stage() { | ||
7 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
8 | STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ | ||
9 | ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR} | ||
10 | } | ||
diff --git a/meta/packages/python/python-pyrex_0.9.8.5.bb b/meta/packages/python/python-pyrex_0.9.8.5.bb new file mode 100644 index 0000000000..03468a0522 --- /dev/null +++ b/meta/packages/python/python-pyrex_0.9.8.5.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Pyrex is a language specially designed for writing Python extension modules. \ | ||
2 | It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \ | ||
3 | and the messy, low-level world of C." | ||
4 | SECTION = "devel/python" | ||
5 | PRIORITY = "optional" | ||
6 | LICENSE = "GPL" | ||
7 | SRCNAME = "Pyrex" | ||
8 | PR = "ml1" | ||
9 | |||
10 | SRC_URI = "\ | ||
11 | http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ | ||
12 | file://pyrex-fix-optimized-mode.patch;patch=1 \ | ||
13 | " | ||
14 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
15 | |||
16 | inherit distutils | ||