summaryrefslogtreecommitdiffstats
path: root/meta/packages/python/python-native_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/python/python-native_2.6.1.bb')
-rw-r--r--meta/packages/python/python-native_2.6.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/python/python-native_2.6.1.bb b/meta/packages/python/python-native_2.6.1.bb
new file mode 100644
index 0000000000..3acd1babe9
--- /dev/null
+++ b/meta/packages/python/python-native_2.6.1.bb
@@ -0,0 +1,33 @@
1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
3PR = "${INC_PR}.2"
4
5SRC_URI = "\
6 http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
7 file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
8 file://04-default-is-optimized.patch;patch=1 \
9 file://05-enable-ctypes-cross-build.patch;patch=1 \
10 file://10-distutils-fix-swig-parameter.patch;patch=1 \
11 file://11-distutils-never-modify-shebang-line.patch;patch=1 \
12 file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
13 file://debug.patch;patch=1 \
14 file://nohostlibs.patch;patch=1 \
15"
16S = "${WORKDIR}/Python-${PV}"
17
18inherit native
19
20EXTRA_OEMAKE = '\
21 BUILD_SYS="" \
22 HOST_SYS="" \
23 LIBC="" \
24 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
25 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
26'
27
28NATIVE_INSTALL_WORKS = "1"
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31 install -d ${D}${bindir}/
32 install -m 0755 Parser/pgen ${D}${bindir}/
33}