summaryrefslogtreecommitdiffstats
path: root/meta/packages/python/python-native_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/python/python-native_2.5.1.bb')
-rw-r--r--meta/packages/python/python-native_2.5.1.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/packages/python/python-native_2.5.1.bb b/meta/packages/python/python-native_2.5.1.bb
deleted file mode 100644
index 421bcaf1bd..0000000000
--- a/meta/packages/python/python-native_2.5.1.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1DESCRIPTION = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSF"
4DEPENDS = "openssl-native bzip2-full-native sqlite3-native"
5SECTION = "devel/python"
6PRIORITY = "optional"
7PR = "ml6"
8
9EXCLUDE_FROM_WORLD = "1"
10
11SRC_URI = "\
12 http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
13 file://bindir-libdir.patch;patch=1 \
14 file://cross-distutils.patch;patch=1 \
15 file://dont-modify-shebang-line.patch;patch=1 \
16 file://default-is-optimized.patch;patch=1 \
17 file://catchup-with-swig.patch;patch=1 \
18 file://fix-staging.patch;patch=1 \
19 file://enable-ctypes-module.patch;patch=1 \
20"
21S = "${WORKDIR}/Python-${PV}"
22
23inherit autotools native
24
25EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \
26 --without-cxx --with-signal-module --with-wctype-functions"
27EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS="" STAGING_LIBDIR=${STAGING_LIBDIR} \
28 STAGING_INCDIR=${STAGING_INCDIR}'
29
30do_install() {
31 oe_runmake 'DESTDIR=${D}' install
32 install -d ${D}${bindir}/
33 install -m 0755 Parser/pgen ${D}${bindir}/
34}