diff options
Diffstat (limited to 'meta/packages/python/python-imaging_1.1.6.bb')
-rw-r--r-- | meta/packages/python/python-imaging_1.1.6.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/python/python-imaging_1.1.6.bb b/meta/packages/python/python-imaging_1.1.6.bb new file mode 100644 index 0000000000..9f3b6323dd --- /dev/null +++ b/meta/packages/python/python-imaging_1.1.6.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "Python Imaging Library" | ||
2 | SECTION = "devel/python" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "GPL" | ||
5 | DEPENDS = "freetype jpeg tiff" | ||
6 | RDEPENDS = "python-lang python-stringold" | ||
7 | SRCNAME = "Imaging" | ||
8 | PR = "ml0" | ||
9 | |||
10 | SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \ | ||
11 | file://path.patch;patch=1" | ||
12 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
13 | |||
14 | inherit distutils | ||
15 | |||
16 | do_compile() { | ||
17 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
18 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
19 | distutils_do_compile | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
24 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
25 | distutils_do_install | ||
26 | install -d ${D}${datadir}/doc/${PN}/html/ | ||
27 | install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/ | ||
28 | install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/ | ||
29 | |||
30 | } | ||