diff options
Diffstat (limited to 'meta/packages/python/python-2.6.1/02-remove-test-for-cross.patch')
-rw-r--r-- | meta/packages/python/python-2.6.1/02-remove-test-for-cross.patch | 94 |
1 files changed, 0 insertions, 94 deletions
diff --git a/meta/packages/python/python-2.6.1/02-remove-test-for-cross.patch b/meta/packages/python/python-2.6.1/02-remove-test-for-cross.patch deleted file mode 100644 index 48386ea462..0000000000 --- a/meta/packages/python/python-2.6.1/02-remove-test-for-cross.patch +++ /dev/null | |||
@@ -1,94 +0,0 @@ | |||
1 | # OpenEmbedded prepopulates the autotools site cache, so if this | ||
2 | # would be using AC_TRY_CACHE, we could patch it in a more sane way | ||
3 | # Alas, I don't have enough autotalent to do that. | ||
4 | # | ||
5 | # Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de> | ||
6 | Index: Python-2.6.1/configure.in | ||
7 | =================================================================== | ||
8 | --- Python-2.6.1.orig/configure.in | ||
9 | +++ Python-2.6.1/configure.in | ||
10 | @@ -2556,38 +2556,6 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_ | ||
11 | AC_CHECK_LIB(resolv, inet_aton) | ||
12 | ) | ||
13 | |||
14 | -# On Tru64, chflags seems to be present, but calling it will | ||
15 | -# exit Python | ||
16 | -AC_MSG_CHECKING(for chflags) | ||
17 | -AC_TRY_RUN([ | ||
18 | -#include <sys/stat.h> | ||
19 | -#include <unistd.h> | ||
20 | -int main(int argc, char*argv[]) | ||
21 | -{ | ||
22 | - if(chflags(argv[0], 0) != 0) | ||
23 | - return 1; | ||
24 | - return 0; | ||
25 | -} | ||
26 | -],AC_DEFINE(HAVE_CHFLAGS, 1, Define to 1 if you have the `chflags' function.) | ||
27 | - AC_MSG_RESULT(yes), | ||
28 | - AC_MSG_RESULT(no) | ||
29 | -) | ||
30 | - | ||
31 | -AC_MSG_CHECKING(for lchflags) | ||
32 | -AC_TRY_RUN([ | ||
33 | -#include <sys/stat.h> | ||
34 | -#include <unistd.h> | ||
35 | -int main(int argc, char*argv[]) | ||
36 | -{ | ||
37 | - if(lchflags(argv[0], 0) != 0) | ||
38 | - return 1; | ||
39 | - return 0; | ||
40 | -} | ||
41 | -],AC_DEFINE(HAVE_LCHFLAGS, 1, Define to 1 if you have the `lchflags' function.) | ||
42 | - AC_MSG_RESULT(yes), | ||
43 | - AC_MSG_RESULT(no) | ||
44 | -) | ||
45 | - | ||
46 | dnl Check if system zlib has *Copy() functions | ||
47 | dnl | ||
48 | dnl On MacOSX the linker will search for dylibs on the entire linker path | ||
49 | @@ -3649,45 +3617,6 @@ else | ||
50 | AC_MSG_RESULT(no) | ||
51 | fi | ||
52 | |||
53 | -AC_MSG_CHECKING(for %zd printf() format support) | ||
54 | -AC_TRY_RUN([#include <stdio.h> | ||
55 | -#include <stddef.h> | ||
56 | -#include <string.h> | ||
57 | - | ||
58 | -#ifdef HAVE_SYS_TYPES_H | ||
59 | -#include <sys/types.h> | ||
60 | -#endif | ||
61 | - | ||
62 | -#ifdef HAVE_SSIZE_T | ||
63 | -typedef ssize_t Py_ssize_t; | ||
64 | -#elif SIZEOF_VOID_P == SIZEOF_LONG | ||
65 | -typedef long Py_ssize_t; | ||
66 | -#else | ||
67 | -typedef int Py_ssize_t; | ||
68 | -#endif | ||
69 | - | ||
70 | -int main() | ||
71 | -{ | ||
72 | - char buffer[256]; | ||
73 | - | ||
74 | - if(sprintf(buffer, "%zd", (size_t)123) < 0) | ||
75 | - return 1; | ||
76 | - | ||
77 | - if (strcmp(buffer, "123")) | ||
78 | - return 1; | ||
79 | - | ||
80 | - if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0) | ||
81 | - return 1; | ||
82 | - | ||
83 | - if (strcmp(buffer, "-123")) | ||
84 | - return 1; | ||
85 | - | ||
86 | - return 0; | ||
87 | -}], | ||
88 | -[AC_MSG_RESULT(yes) | ||
89 | - AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])], | ||
90 | - AC_MSG_RESULT(no)) | ||
91 | - | ||
92 | AC_CHECK_TYPE(socklen_t,, | ||
93 | AC_DEFINE(socklen_t,int, | ||
94 | Define to `int' if <sys/socket.h> does not define.),[ | ||