diff options
Diffstat (limited to 'meta/packages/python/python-2.5.2/autohell.patch')
-rw-r--r-- | meta/packages/python/python-2.5.2/autohell.patch | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/packages/python/python-2.5.2/autohell.patch b/meta/packages/python/python-2.5.2/autohell.patch new file mode 100644 index 0000000000..32977955d4 --- /dev/null +++ b/meta/packages/python/python-2.5.2/autohell.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | Index: Python-2.5.2/configure.in | ||
2 | =================================================================== | ||
3 | --- Python-2.5.2.orig/configure.in | ||
4 | +++ Python-2.5.2/configure.in | ||
5 | @@ -3410,45 +3410,6 @@ esac | ||
6 | |||
7 | |||
8 | |||
9 | -AC_MSG_CHECKING(for %zd printf() format support) | ||
10 | -AC_TRY_RUN([#include <stdio.h> | ||
11 | -#include <stddef.h> | ||
12 | -#include <string.h> | ||
13 | - | ||
14 | -#ifdef HAVE_SYS_TYPES_H | ||
15 | -#include <sys/types.h> | ||
16 | -#endif | ||
17 | - | ||
18 | -#ifdef HAVE_SSIZE_T | ||
19 | -typedef ssize_t Py_ssize_t; | ||
20 | -#elif SIZEOF_VOID_P == SIZEOF_LONG | ||
21 | -typedef long Py_ssize_t; | ||
22 | -#else | ||
23 | -typedef int Py_ssize_t; | ||
24 | -#endif | ||
25 | - | ||
26 | -int main() | ||
27 | -{ | ||
28 | - char buffer[256]; | ||
29 | - | ||
30 | - if(sprintf(buffer, "%zd", (size_t)123) < 0) | ||
31 | - return 1; | ||
32 | - | ||
33 | - if (strcmp(buffer, "123")) | ||
34 | - return 1; | ||
35 | - | ||
36 | - if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0) | ||
37 | - return 1; | ||
38 | - | ||
39 | - if (strcmp(buffer, "-123")) | ||
40 | - return 1; | ||
41 | - | ||
42 | - return 0; | ||
43 | -}], | ||
44 | -[AC_MSG_RESULT(yes) | ||
45 | - AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])], | ||
46 | - AC_MSG_RESULT(no)) | ||
47 | - | ||
48 | AC_CHECK_TYPE(socklen_t,, | ||
49 | AC_DEFINE(socklen_t,int, | ||
50 | Define to `int' if <sys/socket.h> does not define.),[ | ||