summaryrefslogtreecommitdiffstats
path: root/meta/packages/psplash/psplash_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/psplash/psplash_svn.bb')
-rw-r--r--meta/packages/psplash/psplash_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/psplash/psplash_svn.bb b/meta/packages/psplash/psplash_svn.bb
new file mode 100644
index 0000000000..2c21c99d7d
--- /dev/null
+++ b/meta/packages/psplash/psplash_svn.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
2SECTION = "base"
3LICENSE = "GPL"
4PV = "0.0+svn${SRCDATE}"
5
6SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
7 file://psplash-init"
8
9S = "${WORKDIR}/psplash"
10
11inherit autotools pkgconfig update-rc.d
12
13FILES_${PN} += "/mnt/.psplash"
14
15do_install_prepend() {
16 install -d ${D}/mnt/.psplash/
17 install -d ${D}${sysconfdir}/init.d/
18 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
19}
20
21INITSCRIPT_NAME = "psplash"
22INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."