summaryrefslogtreecommitdiffstats
path: root/meta/packages/powertop/powertop_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/powertop/powertop_1.9.bb')
-rw-r--r--meta/packages/powertop/powertop_1.9.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/powertop/powertop_1.9.bb b/meta/packages/powertop/powertop_1.9.bb
new file mode 100644
index 0000000000..ab84161ddc
--- /dev/null
+++ b/meta/packages/powertop/powertop_1.9.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
2HOMEPAGE = "http://www.linuxpowertop.org/"
3LICENSE = "GPLv2"
4DEPENDS = "ncurses"
5
6SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
7
8CFLAGS += "${LDFLAGS}"
9
10do_configure() {
11 # We do not build ncurses with wide char support
12 sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
13}
14
15do_install() {
16 oe_runmake install DESTDIR=${D}
17}