summaryrefslogtreecommitdiffstats
path: root/meta/packages/pkgconfig
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pkgconfig')
-rw-r--r--meta/packages/pkgconfig/pkgconfig-0.15.0/configure.patch495
-rw-r--r--meta/packages/pkgconfig/pkgconfig-0.15.0/glibconfig-sysdefs.h6
-rw-r--r--meta/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4156
-rw-r--r--meta/packages/pkgconfig/pkgconfig-native_0.15.0.bb7
-rw-r--r--meta/packages/pkgconfig/pkgconfig_0.15.0.bb26
5 files changed, 690 insertions, 0 deletions
diff --git a/meta/packages/pkgconfig/pkgconfig-0.15.0/configure.patch b/meta/packages/pkgconfig/pkgconfig-0.15.0/configure.patch
new file mode 100644
index 0000000000..4218e917d4
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig-0.15.0/configure.patch
@@ -0,0 +1,495 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- pkgconfig-0.15.0/glib-1.2.8/Makefile.am~configure.patch
7+++ pkgconfig-0.15.0/glib-1.2.8/Makefile.am
8@@ -65,7 +65,7 @@
9
10 CONFIGURE_DEPENDENCIES = acglib.m4
11
12-BUILT_SOURCES = stamp-gc-h #note: not glibconfig.h
13+BUILT_SOURCES += stamp-gc-h #note: not glibconfig.h
14 glibconfig.h: stamp-gc-h
15 @:
16 stamp-gc-h: config.status
17--- pkgconfig-0.15.0/glib-1.2.8/configure.in~configure.patch
18+++ pkgconfig-0.15.0/glib-1.2.8/configure.in
19@@ -1,10 +1,11 @@
20 dnl ***********************************
21 dnl *** include special GLib macros ***
22 dnl ***********************************
23-builtin(include, acglib.m4)dnl
24+dnl no need, just use aclocal -I . --CL
25+dnl builtin(include, acglib.m4)dnl
26
27 # require autoconf 2.13
28-AC_PREREQ(2.13)
29+AC_PREREQ(2.53)
30
31 # init autoconf (and check for presence of glist.c)
32 AC_INIT(glist.c)
33@@ -13,11 +14,48 @@
34 cflags_set=${CFLAGS+set}
35
36 # we rewrite this file
37+if test "x$cross_compiling" != "xyes"; then
38 rm -f glibconfig-sysdefs.h
39+fi
40+
41+# config defines
42+
43+AH_TEMPLATE([ENABLE_MEM_CHECK],
44+ [Define if enabling memory checking])
45+AH_TEMPLATE([ENABLE_MEM_PROFILE], [])
46+AH_TEMPLATE([GLIB_BINARY_AGE], [])
47+AH_TEMPLATE([GLIB_BYTE_CONTENTS_GMUTEX], [])
48+AH_TEMPLATE([GLIB_INTERFACE_AGE], [])
49+AH_TEMPLATE([GLIB_MAJOR_VERSION], [])
50+AH_TEMPLATE([GLIB_MINOR_VERSION], [])
51+AH_TEMPLATE([GLIB_MICRO_VERSION], [])
52+AH_TEMPLATE([GLIB_SIZEOF_GMUTEX], [])
53+AH_TEMPLATE([G_COMPILED_WITH_DEBUGGING], [])
54+AH_TEMPLATE([G_HAVE_INLINE], [])
55+AH_TEMPLATE([G_HAVE___INLINE], [])
56+AH_TEMPLATE([G_HAVE___INLINE__], [])
57+AH_TEMPLATE([G_THREAD_SOURCE], [])
58+AH_TEMPLATE([G_VA_COPY], [])
59+AH_TEMPLATE([G_VA_COPY_AS_ARRAY], [])
60+AH_TEMPLATE([HAVE_BROKEN_WCTYPE], [])
61+AH_TEMPLATE([HAVE_GETPWUID_R], [])
62+AH_TEMPLATE([HAVE_GETPWUID_R_POSIX], [])
63+AH_TEMPLATE([HAVE_PTHREAD_COND_TIMEDWAIT_POSIX], [])
64+AH_TEMPLATE([HAVE_PTHREAD_GETSPECIFIC_POSIX], [])
65+AH_TEMPLATE([HAVE_PTHREAD_MUTEX_TRYLOCK_POSIX], [])
66+AH_TEMPLATE([HAVE_WCHAR_H], [])
67+AH_TEMPLATE([HAVE_WCTYPE_H], [])
68+AH_TEMPLATE([NO_FD_SET], [])
69+AH_TEMPLATE([NO_SYS_ERRLIST], [])
70+AH_TEMPLATE([NO_SYS_SIGLIST], [])
71+AH_TEMPLATE([NO_SYS_SIGLIST_DECL], [])
72+AH_TEMPLATE([REALLOC_0_WORKS], [])
73+
74
75 dnl we need to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
76 dnl are available for $ac_help expansion (don't we all *love* autoconf?)
77-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
78+#AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)
79+#dnl
80 #
81 # The following version number definitions apply to GLib, GModule and GThread
82 # as a whole, so if changes occoured in any of them, they are all
83@@ -38,7 +76,7 @@
84 GLIB_BINARY_AGE=8
85 GLIB_VERSION=$GLIB_MAJOR_VERSION.$GLIB_MINOR_VERSION.$GLIB_MICRO_VERSION
86 dnl
87-AC_DIVERT_POP()dnl
88+#AC_DIVERT_POP()dnl
89
90 AC_SUBST(GLIB_MAJOR_VERSION)
91 AC_SUBST(GLIB_MINOR_VERSION)
92@@ -77,17 +115,15 @@
93 dnl Initialize maintainer mode
94 AM_MAINTAINER_MODE
95
96-AC_CANONICAL_HOST
97-
98 dnl figure debugging default, prior to $ac_help setup
99 dnl
100-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
101+#AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
102 if test `expr $GLIB_MINOR_VERSION \% 2` = 1 ; then
103 debug_default=yes
104 else
105 debug_default=minimum
106 fi
107-AC_DIVERT_POP()dnl
108+#AC_DIVERT_POP()dnl
109
110 dnl declare --enable-* args and collect ac_help strings
111 AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=$debug_default]],,enable_debug=$debug_default)
112@@ -173,7 +209,9 @@
113 CFLAGS=$glib_save_CFLAGS
114 AC_MSG_WARN(
115 [No ANSI prototypes found in library. (-std1 didn't work.)])
116+ , AC_MSG_WARN([Skipping test due to crosscompilation])
117 )
118+ , AC_MSG_WARN([Skipping test due to crosscompilation])
119 )
120 LIBS=$glib_save_LIBS
121
122@@ -384,11 +422,13 @@
123 return realloc (0, sizeof (int)) == 0;
124 }],
125 glib_cv_sane_realloc=yes
126- AC_DEFINE(REALLOC_0_WORKS)
127 ,
128 glib_cv_sane_realloc=no
129 ,)
130 ])
131+if test "x$glib_cv_sane_realloc" = "xyes"; then
132+ AC_DEFINE(REALLOC_0_WORKS)
133+fi
134 AC_MSG_RESULT($glib_cv_sane_realloc)
135
136
137@@ -464,7 +504,8 @@
138 ])
139 if test "x$glib_cv_va_copy" = "xyes"; then
140 AC_DEFINE(G_VA_COPY, va_copy)
141-else if test "x$glib_cv___va_copy" = "xyes"; then
142+else
143+if test "x$glib_cv___va_copy" = "xyes"; then
144 AC_DEFINE(G_VA_COPY, __va_copy)
145 fi
146 fi
147@@ -473,6 +514,7 @@
148 fi
149 AC_MSG_RESULT($glib_cv_va_val_copy)
150
151+AC_MSG_WARN([hi mom])
152
153 dnl ***********************
154 dnl *** g_module checks ***
155@@ -483,21 +525,27 @@
156 G_MODULE_NEED_USCORE=0
157 G_MODULE_HAVE_DLERROR=0
158 dnl *** dlopen() and dlsym() in system libraries
159+AC_CHECK_FUNC(dlopen,[
160+ AC_CHECK_FUNC(dlsym,[
161+ G_MODULE_IMPL=G_MODULE_IMPL_DL
162+ ],
163+ )],
164+)
165 if test -z "$G_MODULE_IMPL"; then
166- AC_CHECK_FUNC(dlopen,
167- AC_CHECK_FUNC(dlsym,
168+ AC_CHECK_FUNC(dlopen,[
169+ AC_CHECK_FUNC(dlsym,[
170 G_MODULE_IMPL=G_MODULE_IMPL_DL
171- ,)
172- ,)
173+ ])],
174+ )
175 fi
176 dnl *** dlopen() and dlsym() in libdl
177 if test -z "$G_MODULE_IMPL"; then
178- AC_CHECK_LIB(dl, dlopen,
179- AC_CHECK_LIB(dl, dlsym,
180+ AC_CHECK_LIB(dl, dlopen,[
181+ AC_CHECK_LIB(dl, dlsym,[
182 G_MODULE_LIBS=-ldl
183 G_MODULE_IMPL=G_MODULE_IMPL_DL
184- ,)
185- ,)
186+ ])]
187+ )
188 fi
189 dnl *** shl_load() in libdld (HP-UX)
190 if test -z "$G_MODULE_IMPL"; then
191@@ -576,6 +624,7 @@
192 AC_SUBST(G_MODULE_HAVE_DLERROR)
193 AC_SUBST(G_MODULE_NEED_USCORE)
194 AC_SUBST(GLIB_DEBUG_FLAGS)
195+AC_MSG_WARN([hi mom])
196
197
198 dnl ***********************
199@@ -812,38 +861,50 @@
200 fi
201 if test x"$have_threads" = xposix; then
202 LIBS="$LIBS $G_THREAD_LIBS"
203- AC_MSG_CHECKING(whether pthread_getspecific is posix like)
204 # PCThreads has pthread_getspecific(pthread_key_t, void **);
205- AC_TRY_COMPILE([#include <pthread.h>],
206- [pthread_getspecific(0,NULL);],
207- [AC_MSG_RESULT(no)],
208- [AC_MSG_RESULT(yes)
209- AC_DEFINE(HAVE_PTHREAD_GETSPECIFIC_POSIX)])
210- AC_MSG_CHECKING(whether pthread_mutex_trylock is posix like)
211+ AC_CACHE_CHECK([whether pthread_getspecific is posix like],
212+ [glib_cv_sys_pthread_getspecific_posix],
213+ AC_TRY_COMPILE([#include <pthread.h>],
214+ [pthread_getspecific(0,NULL);],
215+ [glib_cv_sys_pthread_getspecific_posix=no],
216+ [glib_cv_sys_pthread_getspecific_posix=yes])
217+ )
218+ if test x"$glib_cv_sys_pthread_getspecific_posix" = xyes; then
219+ AC_DEFINE(HAVE_PTHREAD_GETSPECIFIC_POSIX)
220+ fi
221 # DCE Threads return 1 as success, posix 0. what a mess.
222- AC_TRY_RUN([#include <pthread.h>
223- pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
224- int main () {
225- return !pthread_mutex_trylock (&mutex); }],
226- [AC_MSG_RESULT(no)],
227- [AC_MSG_RESULT(yes)
228- AC_DEFINE(HAVE_PTHREAD_MUTEX_TRYLOCK_POSIX)])
229- AC_MSG_CHECKING(whether pthread_cond_timedwait is posix like)
230+ AC_CACHE_CHECK([whether pthread_mutex_trylock is posix like],
231+ [glib_cv_sys_pthread_mutex_trylock_posix],
232+ AC_TRY_RUN([#include <pthread.h>
233+ pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
234+ int main () {
235+ return !pthread_mutex_trylock (&mutex); }],
236+ [glib_cv_sys_pthread_mutex_trylock_posix=no],
237+ [glib_cv_sys_pthread_mutex_trylock_posix=yes])
238+ )
239+ if test x"$glib_cv_sys_pthread_mutex_trylock_posix" = xyes; then
240+ AC_DEFINE(HAVE_PTHREAD_MUTEX_TRYLOCK_POSIX)
241+ fi
242 # DCE Threads return -1 as failure, posix ETIMEDOUT.
243- AC_TRY_RUN([#include <pthread.h>
244- int main () {
245- pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
246- pthread_cond_t cond = PTHREAD_COND_INITIALIZER;
247- struct timeval tval;
248- struct timespec tspec;
249- gettimeofday (&tval, NULL);
250- tspec.tv_sec = tval.tv_sec;
251- tspec.tv_nsec = 0;
252- return pthread_cond_timedwait (&cond,&mutex,&tspec)
253- != -1;}],
254- [AC_MSG_RESULT(no)],
255- [AC_MSG_RESULT(yes)
256- AC_DEFINE(HAVE_PTHREAD_COND_TIMEDWAIT_POSIX)])
257+ AC_CACHE_CHECK([whether pthread_cond_timedwait is posix like],
258+ [glib_cv_sys_pthread_cond_timedwait_posix],
259+ AC_TRY_RUN([#include <pthread.h>
260+ int main () {
261+ pthread_mutex_t mutex = PTHREAD_MUTEX_INITIALIZER;
262+ pthread_cond_t cond = PTHREAD_COND_INITIALIZER;
263+ struct timeval tval;
264+ struct timespec tspec;
265+ gettimeofday (&tval, NULL);
266+ tspec.tv_sec = tval.tv_sec;
267+ tspec.tv_nsec = 0;
268+ return pthread_cond_timedwait (&cond,&mutex,&tspec)
269+ != -1;}],
270+ [glib_cv_sys_pthread_cond_timedwait_posix=no],
271+ [glib_cv_sys_pthread_cond_timedwait_posix=yes])
272+ )
273+ if test x"$glib_cv_sys_pthread_cond_timedwait_posix" = xyes; then
274+ AC_DEFINE(HAVE_PTHREAD_COND_TIMEDWAIT_POSIX)
275+ fi
276 fi
277 LIBS="$glib_save_LIBS"
278 CFLAGS="$glib_save_CFLAGS"
279@@ -887,13 +948,14 @@
280 dnl ****************************************
281 dnl *** GLib POLL* compatibility defines ***
282 dnl ****************************************
283+if test x"$cross_compiling" != xyes; then
284 GLIB_SYSDEFS(
285 [#include <sys/types.h>
286 #include <sys/poll.h>],
287 POLLIN:1 POLLOUT:4 POLLPRI:2 POLLERR:8 POLLHUP:16 POLLNVAL:32,
288 glibconfig-sysdefs.h,
289 =)
290-
291+fi
292
293 dnl ******************************
294 dnl *** output the whole stuff ***
295@@ -950,7 +1012,7 @@
296 echo '#define GLIB_HAVE_SYS_POLL_H' >> $outfile
297 fi
298
299- cat >> $outfile <<_______EOF
300+ cat >> $outfile <<EOF
301
302 #define G_MINFLOAT $glib_mf
303 #define G_MAXFLOAT $glib_Mf
304@@ -963,60 +1025,60 @@
305 #define G_MINLONG $glib_ml
306 #define G_MAXLONG $glib_Ml
307
308-_______EOF
309+EOF
310
311
312 ### this should always be true in a modern C/C++ compiler
313- cat >>$outfile <<_______EOF
314+ cat >>$outfile <<EOF
315 typedef signed char gint8;
316 typedef unsigned char guint8;
317-_______EOF
318+EOF
319
320
321 if test -n "$gint16"; then
322- cat >>$outfile <<_______EOF
323+ cat >>$outfile <<EOF
324 typedef signed $gint16 gint16;
325 typedef unsigned $gint16 guint16;
326-_______EOF
327+EOF
328 fi
329
330
331 if test -n "$gint32"; then
332- cat >>$outfile <<_______EOF
333+ cat >>$outfile <<EOF
334 typedef signed $gint32 gint32;
335 typedef unsigned $gint32 guint32;
336-_______EOF
337+EOF
338 fi
339
340
341 if test -n "$gint64"; then
342- cat >>$outfile <<_______EOF
343+ cat >>$outfile <<EOF
344 ${glib_warning_guard}#define G_HAVE_GINT64 1
345
346 ${glib_extension}typedef signed $gint64 gint64;
347 ${glib_extension}typedef unsigned $gint64 guint64;
348
349 #define G_GINT64_CONSTANT(val) $gint64_constant
350-_______EOF
351+EOF
352 fi
353
354
355 if test -z "$glib_unknown_void_p"; then
356- cat >>$outfile <<_______EOF
357+ cat >>$outfile <<EOF
358
359 #define GPOINTER_TO_INT(p) ((gint) ${glib_gpi_cast} (p))
360 #define GPOINTER_TO_UINT(p) ((guint) ${glib_gpui_cast} (p))
361
362 #define GINT_TO_POINTER(i) ((gpointer) ${glib_gpi_cast} (i))
363 #define GUINT_TO_POINTER(u) ((gpointer) ${glib_gpui_cast} (u))
364-_______EOF
365+EOF
366 else
367 echo '#error SIZEOF_VOID_P unknown - This should never happen' >>$outfile
368 fi
369
370
371
372- cat >>$outfile <<_______EOF
373+ cat >>$outfile <<EOF
374 $glib_atexit
375 $glib_memmove
376 $glib_defines
377@@ -1028,11 +1090,11 @@
378 #else /* !__cplusplus */
379 $glib_inline
380 #endif /* !__cplusplus */
381-_______EOF
382+EOF
383
384 echo >>$outfile
385 if test x$g_mutex_has_default = xyes; then
386- cat >>$outfile <<_______EOF
387+ cat >>$outfile <<EOF
388 $g_enable_threads_def G_THREADS_ENABLED
389 #define G_THREADS_IMPL_$g_threads_impl_def
390 typedef struct _GStaticMutex GStaticMutex;
391@@ -1050,15 +1112,15 @@
392 #define g_static_mutex_get_mutex(mutex) \
393 (g_thread_use_default_impl ? ((GMutex*) &((mutex)->aligned_pad_u)) : \
394 g_static_mutex_get_mutex_impl (&((mutex)->runtime_mutex)))
395-_______EOF
396+EOF
397 else
398- cat >>$outfile <<_______EOF
399+ cat >>$outfile <<EOF
400 $g_enable_threads_def G_THREADS_ENABLED
401 #define G_THREADS_IMPL_$g_threads_impl_def
402 typedef struct _GMutex* GStaticMutex;
403 #define G_STATIC_MUTEX_INIT NULL
404 #define g_static_mutex_get_mutex(mutex) (g_static_mutex_get_mutex_impl (mutex))
405-_______EOF
406+EOF
407 fi
408
409 echo >>$outfile
410@@ -1067,15 +1129,15 @@
411 g_bit_sizes="$g_bit_sizes 64"
412 fi
413 for bits in $g_bit_sizes; do
414- cat >>$outfile <<_______EOF
415+ cat >>$outfile <<EOF
416 #define GINT${bits}_TO_${g_bs_native}(val) ((gint${bits}) (val))
417 #define GUINT${bits}_TO_${g_bs_native}(val) ((guint${bits}) (val))
418 #define GINT${bits}_TO_${g_bs_alien}(val) ((gint${bits}) GUINT${bits}_SWAP_LE_BE (val))
419 #define GUINT${bits}_TO_${g_bs_alien}(val) (GUINT${bits}_SWAP_LE_BE (val))
420-_______EOF
421+EOF
422 done
423
424- cat >>$outfile <<_______EOF
425+ cat >>$outfile <<EOF
426 #define GLONG_TO_LE(val) ((glong) GINT${glongbits}_TO_LE (val))
427 #define GULONG_TO_LE(val) ((gulong) GUINT${glongbits}_TO_LE (val))
428 #define GLONG_TO_BE(val) ((glong) GINT${glongbits}_TO_BE (val))
429@@ -1086,14 +1148,14 @@
430 #define GUINT_TO_BE(val) ((guint) GUINT${gintbits}_TO_BE (val))
431 #define G_BYTE_ORDER $g_byte_order
432
433-_______EOF
434+EOF
435
436 if test -r glibconfig-sysdefs.h; then
437 cat glibconfig-sysdefs.h >>$outfile
438 fi
439
440
441- cat >>$outfile <<_______EOF
442+ cat >>$outfile <<EOF
443
444 $glib_wc
445
446@@ -1103,7 +1165,7 @@
447 #endif /* __cplusplus */
448
449 #endif /* GLIBCONFIG_H */
450-_______EOF
451+EOF
452
453
454 if cmp -s $outfile glibconfig.h; then
455--- pkgconfig-0.15.0/glib-1.2.8/gmodule/Makefile.am~configure.patch
456+++ pkgconfig-0.15.0/glib-1.2.8/gmodule/Makefile.am
457@@ -41,7 +41,7 @@
458 libgplugin_b_la_LIBADD = @G_MODULE_LIBS@ # $(libglib)
459
460 noinst_PROGRAMS = testgmodule
461-testgmodule_LDFLAGS += @G_MODULE_LDFLAGS@
462+testgmodule_LDFLAGS = @G_MODULE_LDFLAGS@
463 testgmodule_LDADD = libgmodule.la $(libglib) @G_MODULE_LIBS@
464
465 .PHONY: files release
466--- pkgconfig-0.15.0/pkg.m4~configure.patch
467+++ pkgconfig-0.15.0/pkg.m4
468@@ -2,7 +2,7 @@
469 dnl PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4, action-if, action-not)
470 dnl defines GSTUFF_LIBS, GSTUFF_CFLAGS, see pkg-config man page
471 dnl also defines GSTUFF_PKG_ERRORS on error
472-AC_DEFUN(PKG_CHECK_MODULES, [
473+AC_DEFUN([PKG_CHECK_MODULES], [
474 succeeded=no
475
476 if test -z "$PKG_CONFIG"; then
477--- pkgconfig-0.15.0/configure.in~configure.patch
478+++ pkgconfig-0.15.0/configure.in
479@@ -1,6 +1,7 @@
480
481 AC_INIT(pkg-config.1)
482
483+AC_CONFIG_AUX_DIR(.)
484 AM_INIT_AUTOMAKE(pkgconfig, 0.15.0)
485 AM_MAINTAINER_MODE
486
487@@ -37,8 +38,6 @@
488
489 AC_SUBST(GLIB_LIBS)
490 AC_SUBST(GLIB_CFLAGS)
491-
492- AC_CONFIG_AUX_DIR(.)
493 else
494 AC_CONFIG_SUBDIRS(glib-1.2.8)
495 fi # !native_win32
diff --git a/meta/packages/pkgconfig/pkgconfig-0.15.0/glibconfig-sysdefs.h b/meta/packages/pkgconfig/pkgconfig-0.15.0/glibconfig-sysdefs.h
new file mode 100644
index 0000000000..1329e7f21c
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig-0.15.0/glibconfig-sysdefs.h
@@ -0,0 +1,6 @@
1#define GLIB_SYSDEF_POLLIN =1
2#define GLIB_SYSDEF_POLLOUT =4
3#define GLIB_SYSDEF_POLLPRI =2
4#define GLIB_SYSDEF_POLLERR =8
5#define GLIB_SYSDEF_POLLHUP =16
6#define GLIB_SYSDEF_POLLNVAL =32
diff --git a/meta/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4 b/meta/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4
new file mode 100644
index 0000000000..cbb46dbf83
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4
@@ -0,0 +1,156 @@
1# pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
2#
3# Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
4#
5# This program is free software; you can redistribute it and/or modify
6# it under the terms of the GNU General Public License as published by
7# the Free Software Foundation; either version 2 of the License, or
8# (at your option) any later version.
9#
10# This program is distributed in the hope that it will be useful, but
11# WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13# General Public License for more details.
14#
15# You should have received a copy of the GNU General Public License
16# along with this program; if not, write to the Free Software
17# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
18#
19# As a special exception to the GNU General Public License, if you
20# distribute this file as part of a program that contains a
21# configuration script generated by Autoconf, you may include it under
22# the same distribution terms that you use for the rest of that program.
23
24# PKG_PROG_PKG_CONFIG([MIN-VERSION])
25# ----------------------------------
26AC_DEFUN([PKG_PROG_PKG_CONFIG],
27[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
28m4_pattern_allow([^PKG_CONFIG(_PATH)?$])
29AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])dnl
30if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
31 AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
32fi
33if test -n "$PKG_CONFIG"; then
34 _pkg_min_version=m4_default([$1], [0.9.0])
35 AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
36 if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
37 AC_MSG_RESULT([yes])
38 else
39 AC_MSG_RESULT([no])
40 PKG_CONFIG=""
41 fi
42
43fi[]dnl
44])# PKG_PROG_PKG_CONFIG
45
46# PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
47#
48# Check to see whether a particular set of modules exists. Similar
49# to PKG_CHECK_MODULES(), but does not set variables or print errors.
50#
51#
52# Similar to PKG_CHECK_MODULES, make sure that the first instance of
53# this or PKG_CHECK_MODULES is called, or make sure to call
54# PKG_CHECK_EXISTS manually
55# --------------------------------------------------------------
56AC_DEFUN([PKG_CHECK_EXISTS],
57[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
58if test -n "$PKG_CONFIG" && \
59 AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
60 m4_ifval([$2], [$2], [:])
61m4_ifvaln([$3], [else
62 $3])dnl
63fi])
64
65
66# _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
67# ---------------------------------------------
68m4_define([_PKG_CONFIG],
69[if test -n "$PKG_CONFIG"; then
70 if test -n "$$1"; then
71 pkg_cv_[]$1="$$1"
72 else
73 PKG_CHECK_EXISTS([$3],
74 [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`],
75 [pkg_failed=yes])
76 fi
77else
78 pkg_failed=untried
79fi[]dnl
80])# _PKG_CONFIG
81
82# _PKG_SHORT_ERRORS_SUPPORTED
83# -----------------------------
84AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
85[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
86if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
87 _pkg_short_errors_supported=yes
88else
89 _pkg_short_errors_supported=no
90fi[]dnl
91])# _PKG_SHORT_ERRORS_SUPPORTED
92
93
94# PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
95# [ACTION-IF-NOT-FOUND])
96#
97#
98# Note that if there is a possibility the first call to
99# PKG_CHECK_MODULES might not happen, you should be sure to include an
100# explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
101#
102#
103# --------------------------------------------------------------
104AC_DEFUN([PKG_CHECK_MODULES],
105[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
106AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
107AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
108
109pkg_failed=no
110AC_MSG_CHECKING([for $1])
111
112_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
113_PKG_CONFIG([$1][_LIBS], [libs], [$2])
114
115m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
116and $1[]_LIBS to avoid the need to call pkg-config.
117See the pkg-config man page for more details.])
118
119if test $pkg_failed = yes; then
120 _PKG_SHORT_ERRORS_SUPPORTED
121 if test $_pkg_short_errors_supported = yes; then
122 $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$2"`
123 else
124 $1[]_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
125 fi
126 # Put the nasty error message in config.log where it belongs
127 echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
128
129 ifelse([$4], , [AC_MSG_ERROR(dnl
130[Package requirements ($2) were not met:
131
132$$1_PKG_ERRORS
133
134Consider adjusting the PKG_CONFIG_PATH environment variable if you
135installed software in a non-standard prefix.
136
137_PKG_TEXT
138])],
139 [$4])
140elif test $pkg_failed = untried; then
141 ifelse([$4], , [AC_MSG_FAILURE(dnl
142[The pkg-config script could not be found or is too old. Make sure it
143is in your PATH or set the PKG_CONFIG environment variable to the full
144path to pkg-config.
145
146_PKG_TEXT
147
148To get pkg-config, see <http://www.freedesktop.org/software/pkgconfig>.])],
149 [$4])
150else
151 $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
152 $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
153 AC_MSG_RESULT([yes])
154 ifelse([$3], , :, [$3])
155fi[]dnl
156])# PKG_CHECK_MODULES
diff --git a/meta/packages/pkgconfig/pkgconfig-native_0.15.0.bb b/meta/packages/pkgconfig/pkgconfig-native_0.15.0.bb
new file mode 100644
index 0000000000..d8e47c5d09
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig-native_0.15.0.bb
@@ -0,0 +1,7 @@
1SECTION = "console/utils"
2include pkgconfig_${PV}.bb
3FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pkgconfig-${PV}"
4
5S = "${WORKDIR}/pkgconfig-${PV}"
6inherit native
7DEPENDS = ""
diff --git a/meta/packages/pkgconfig/pkgconfig_0.15.0.bb b/meta/packages/pkgconfig/pkgconfig_0.15.0.bb
new file mode 100644
index 0000000000..31fc7820fe
--- /dev/null
+++ b/meta/packages/pkgconfig/pkgconfig_0.15.0.bb
@@ -0,0 +1,26 @@
1SECTION = "console/utils"
2DESCRIPTION = "pkg-config is a system for managing library \
3compile/link flags that works with automake and autoconf. \
4It replaces the ubiquitous *-config scripts you may have \
5seen with a single tool."
6HOMEPAGE = "http://www.freedesktop.org/software/pkgconfig/"
7LICENSE = "GPL"
8PR = "r2"
9
10SRC_URI = "http://www.freedesktop.org/software/pkgconfig/releases/pkgconfig-${PV}.tar.gz \
11 file://configure.patch;patch=1 \
12 file://pkg.m4 \
13 file://glibconfig-sysdefs.h"
14
15inherit autotools
16
17acpaths = "-I ."
18do_configure_prepend () {
19 install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
20 install -m 0644 ${WORKDIR}/pkg.m4 ${S}/
21}
22
23do_stage_append() {
24 install -d -m 0755 ${STAGING_DATADIR}/pkgconfig
25
26}