summaryrefslogtreecommitdiffstats
path: root/meta/packages/pimlico/files/tasks-owl.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pimlico/files/tasks-owl.diff')
-rw-r--r--meta/packages/pimlico/files/tasks-owl.diff74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/packages/pimlico/files/tasks-owl.diff b/meta/packages/pimlico/files/tasks-owl.diff
new file mode 100644
index 0000000000..ea867d890d
--- /dev/null
+++ b/meta/packages/pimlico/files/tasks-owl.diff
@@ -0,0 +1,74 @@
1Index: src/gtk/tasks-ui.xml
2===================================================================
3--- src/gtk/tasks-ui.xml (revision 288)
4+++ src/gtk/tasks-ui.xml (working copy)
5@@ -10,10 +10,8 @@
6 <menuitem action="DeleteTask"/>
7 <menuitem action="PurgeTasks"/>
8 <separator/>
9+ <menuitem action="About"/>
10 <menuitem action="Quit"/>
11 </menu>
12- <menu action="HelpMenu">
13- <menuitem action="About"/>
14- </menu>
15 </menubar>
16 </ui>
17Index: src/gtk/main.c
18===================================================================
19--- src/gtk/main.c (revision 288)
20+++ src/gtk/main.c (working copy)
21@@ -21,6 +21,7 @@
22 #include <libecal/e-cal.h>
23 #include <glib/gi18n.h>
24 #include <gtk/gtk.h>
25+#include <owlwindowmenu.h>
26
27 #include <libkoto/ical-util.h>
28 #include <libkoto/koto-category-group.h>
29@@ -462,17 +463,6 @@
30 NULL);
31 }
32
33-/*
34- * Callback from the UI manager with the GtkMenu widget. Pack and add this to
35- * the container.
36- */
37-static void
38-ui_add_widget (GtkUIManager *ui, GtkWidget *widget, GtkContainer *container)
39-{
40- gtk_box_pack_start (GTK_BOX (container), widget, FALSE, FALSE, 0);
41- gtk_widget_show (widget);
42-}
43-
44 /* TODO: split into global actions and actions that require a task to be selected */
45 static const GtkActionEntry actions[] =
46 {
47@@ -563,11 +553,12 @@
48 }
49 /* Bind the accelerators */
50 gtk_window_add_accel_group (GTK_WINDOW (window), gtk_ui_manager_get_accel_group (ui_manager));
51- g_signal_connect (ui_manager, "add-widget", G_CALLBACK (ui_add_widget), top_box);
52
53 /* Do this so that the menu is packed now instead of in the idle loop */
54 gtk_ui_manager_ensure_update (ui_manager);
55-
56+ owl_set_window_menu_item (GTK_WINDOW (window),
57+ GTK_MENU_ITEM (gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu")));
58+
59 box = gtk_vbox_new (FALSE, 4);
60 gtk_container_set_border_width (GTK_CONTAINER (box), 4);
61 gtk_container_add (GTK_CONTAINER (top_box), box);
62Index: src/gtk/Makefile.am
63===================================================================
64--- src/gtk/Makefile.am (revision 288)
65+++ src/gtk/Makefile.am (working copy)
66@@ -4,7 +4,7 @@
67 bin_PROGRAMS = tasks
68 tasks_CPPFLAGS = -I$(top_srcdir)/
69 tasks_CFLAGS = -Wall $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS)
70-tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS)
71+tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) -lowl
72
73 tasks_SOURCES = \
74 main.c \