diff options
Diffstat (limited to 'meta/packages/pimlico/contacts/contacts-owl-window-menu.patch')
-rw-r--r-- | meta/packages/pimlico/contacts/contacts-owl-window-menu.patch | 52 |
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/packages/pimlico/contacts/contacts-owl-window-menu.patch b/meta/packages/pimlico/contacts/contacts-owl-window-menu.patch deleted file mode 100644 index 4b9238b43a..0000000000 --- a/meta/packages/pimlico/contacts/contacts-owl-window-menu.patch +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | Index: contacts-0.9/src/contacts-gtk.c | ||
2 | =================================================================== | ||
3 | --- contacts-0.9.orig/src/contacts-gtk.c 2008-06-06 12:56:08.000000000 +0100 | ||
4 | +++ contacts-0.9/src/contacts-gtk.c 2008-06-16 08:14:28.000000000 +0100 | ||
5 | @@ -220,8 +220,8 @@ | ||
6 | vbox7 = gtk_vbox_new (FALSE, 0); | ||
7 | gtk_container_add (GTK_CONTAINER (main_window), vbox7); | ||
8 | |||
9 | - main_menubar = gtk_menu_bar_new (); | ||
10 | - gtk_box_pack_start (GTK_BOX (vbox7), main_menubar, FALSE, FALSE, 0); | ||
11 | + main_menubar = gtk_menu_new (); | ||
12 | + gtk_widget_show (main_menubar); | ||
13 | |||
14 | contacts_menu = gtk_menu_item_new_with_mnemonic (_("C_ontacts")); | ||
15 | gtk_container_add (GTK_CONTAINER (main_menubar), contacts_menu); | ||
16 | Index: contacts-0.9/src/Makefile.am | ||
17 | =================================================================== | ||
18 | --- contacts-0.9.orig/src/Makefile.am 2008-06-03 09:16:56.000000000 +0100 | ||
19 | +++ contacts-0.9/src/Makefile.am 2008-06-16 08:15:34.000000000 +0100 | ||
20 | @@ -40,7 +40,7 @@ | ||
21 | contacts-@FRONTEND@.c \ | ||
22 | contacts-@FRONTEND@.h | ||
23 | |||
24 | -contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) | ||
25 | +contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) -lowl | ||
26 | |||
27 | contacts_LDFLAGS = @CONTACTS_LIBS@ @DBUS_LIBS@ | ||
28 | |||
29 | Index: contacts-0.9/src/contacts-main.c | ||
30 | =================================================================== | ||
31 | --- contacts-0.9.orig/src/contacts-main.c 2008-06-06 10:26:52.000000000 +0100 | ||
32 | +++ contacts-0.9/src/contacts-main.c 2008-06-16 08:14:28.000000000 +0100 | ||
33 | @@ -27,6 +27,8 @@ | ||
34 | #include <libgnomevfs/gnome-vfs.h> | ||
35 | #endif | ||
36 | |||
37 | +#include <libowl/owlwindowmenu.h> | ||
38 | + | ||
39 | #include "bacon-message-connection.h" | ||
40 | #include "contacts-defs.h" | ||
41 | #include "contacts-utils.h" | ||
42 | @@ -266,6 +268,10 @@ | ||
43 | gtk_widget_show_all (widget); | ||
44 | } | ||
45 | |||
46 | + gtk_widget_show_all (data->ui->main_menubar); | ||
47 | + owl_set_window_menu (GTK_WINDOW (data->ui->main_window), | ||
48 | + GTK_MENU (data->ui->main_menubar)); | ||
49 | + | ||
50 | gtk_main (); | ||
51 | |||
52 | /* if we have modified the current contact, but not saved it, do so now */ | ||