summaryrefslogtreecommitdiffstats
path: root/meta/packages/perl/perl_5.8.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/perl/perl_5.8.7.bb')
-rw-r--r--meta/packages/perl/perl_5.8.7.bb27
1 files changed, 21 insertions, 6 deletions
diff --git a/meta/packages/perl/perl_5.8.7.bb b/meta/packages/perl/perl_5.8.7.bb
index 5e1c4660d8..a7095433a3 100644
--- a/meta/packages/perl/perl_5.8.7.bb
+++ b/meta/packages/perl/perl_5.8.7.bb
@@ -1,4 +1,7 @@
1 1
2# We need gnugrep (for -I)
3DEPENDS_append += " grep-native"
4
2require perl.inc 5require perl.inc
3 6
4SRC_URI += "file://config.sh-armeb-linux \ 7SRC_URI += "file://config.sh-armeb-linux \
@@ -6,12 +9,21 @@ SRC_URI += "file://config.sh-armeb-linux \
6 file://config.sh-i386-linux \ 9 file://config.sh-i386-linux \
7 file://config.sh-i486-linux \ 10 file://config.sh-i486-linux \
8 file://config.sh-i586-linux \ 11 file://config.sh-i586-linux \
12 file://config.sh-i686-linux \
13 file://config.sh-x86_64-linux \
9 file://config.sh-sh3-linux \ 14 file://config.sh-sh3-linux \
10 file://config.sh-sh4-linux" 15 file://config.sh-sh4-linux"
11 16
17# Patches for sh3/sh4, use gcc to link and override generaet.sh to
18# use PIC mode for compiling shared library objects.
19SRC_URI_append_sh4 += "file://override-generate-sh.patch;patch=1"
20SRC_URI_append_sh4 += "file://makefile-usegcc-to-link.patch;patch=1"
21SRC_URI_append_sh3 += "file://override-generate-sh.patch;patch=1"
22SRC_URI_append_sh3 += "file://makefile-usegcc-to-link.patch;patch=1"
23
12PARALLEL_MAKE = "" 24PARALLEL_MAKE = ""
13 25
14PR = "r17" 26PR = "r21"
15 27
16do_configure() { 28do_configure() {
17 ln -sf ${HOSTPERL} ${STAGING_BINDIR}/hostperl 29 ln -sf ${HOSTPERL} ${STAGING_BINDIR}/hostperl
@@ -24,6 +36,7 @@ do_configure() {
24 cp ${WORKDIR}/config.sh-i486-linux . 36 cp ${WORKDIR}/config.sh-i486-linux .
25 cp ${WORKDIR}/config.sh-i586-linux . 37 cp ${WORKDIR}/config.sh-i586-linux .
26 cp ${WORKDIR}/config.sh-i686-linux . 38 cp ${WORKDIR}/config.sh-i686-linux .
39 cp ${WORKDIR}/config.sh-x86_64-linux .
27 cp ${WORKDIR}/config.sh-armeb-linux . 40 cp ${WORKDIR}/config.sh-armeb-linux .
28 cp ${WORKDIR}/config.sh-sh3-linux . 41 cp ${WORKDIR}/config.sh-sh3-linux .
29 cp ${WORKDIR}/config.sh-sh4-linux . 42 cp ${WORKDIR}/config.sh-sh4-linux .
@@ -45,7 +58,7 @@ do_configure() {
45 sed -i -e "s%/usr/include/%${STAGING_INCDIR}/%g" config.sh-${TARGET_ARCH}-${TARGET_OS} 58 sed -i -e "s%/usr/include/%${STAGING_INCDIR}/%g" config.sh-${TARGET_ARCH}-${TARGET_OS}
46 59
47 #These are strewn all over the source tree 60 #These are strewn all over the source tree
48 for foo in `grep -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do 61 for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
49 echo Fixing: $foo 62 echo Fixing: $foo
50 sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo 63 sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
51 done 64 done
@@ -56,15 +69,13 @@ do_configure() {
56} 69}
57 70
58do_install_append() { 71do_install_append() {
59 # Make sure the shared library is configured before trying to symlink it 72 ln -s libperl.so.${PV} ${D}/${libdir}/libperl.so.5
60 grep -q "useshrplib='false'" ${S}/config.sh ||
61 ln -s libperl.so.${PV} ${D}/${libdir}/libperl.so.5
62 sed -i -e "s,${D},,g" ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-${TARGET_OS}/Config_heavy.pl 73 sed -i -e "s,${D},,g" ${D}/${libdir}/perl5/${PV}/${TARGET_ARCH}-${TARGET_OS}/Config_heavy.pl
63} 74}
64 75
65# Create a perl-modules package recommending all the other perl 76# Create a perl-modules package recommending all the other perl
66# packages (actually the non modules packages and not created too) 77# packages (actually the non modules packages and not created too)
67ALLOW_EMPTY_perl-modules = 1 78ALLOW_EMPTY_perl-modules = "1"
68PACKAGES_append = " perl-modules" 79PACKAGES_append = " perl-modules"
69RRECOMMENDS_perl-modules = "${PACKAGES}" 80RRECOMMENDS_perl-modules = "${PACKAGES}"
70RPROVIDES_perl-lib = "perl-lib" 81RPROVIDES_perl-lib = "perl-lib"
@@ -75,6 +86,10 @@ require perl-rdepends_${PV}.inc
75# To create/update the perl-rdepends_${PV}.inc use this piece of ugly script (modified for your arch/paths etc): 86# To create/update the perl-rdepends_${PV}.inc use this piece of ugly script (modified for your arch/paths etc):
76# daka@DaKa2:/home/slug/slugos/tmp/work/perl-5.8.7-r14/install$ egrep -r "use|require" * | grep ";$" | egrep ".pm:use |.pm:require " | grep -v v5.6.0 | grep -v 5.00 | grep -v \$module | sed -e "s, \+, ,g" | cut -f1,2 -d" " | sed -e "s,;, ,g" | sed -e "s,(), ,g" | sed -e "s,::,-,g" | sort | uniq | tr [:upper:] [:lower:] | sed -e "s,/[^ ]\+ , += \"perl-module-,g" | sed -e "s, \?$, \",g" | sed -e "s,_,-,g" | sed -e "s,^,RDEPENDS_,g" | sed -e "s,armeb-linux,\$\{TARGET_ARCH\}-\$\{TARGET_OS\},g" | egrep -v "perl-module-5|perl-module-tk|perl-module-mac-internetconfig|perl-module-ndbm-file|perl-module-html-treebuilder|perl-module-lwp-simple|perl-module-vms-filespec|perl-module-fcgi|perl-module-vms-stdio|perl-module-mac-buildtools" > /home/slug/openembedded/packages/perl/perl-rdepends_5.8.7.inc 87# daka@DaKa2:/home/slug/slugos/tmp/work/perl-5.8.7-r14/install$ egrep -r "use|require" * | grep ";$" | egrep ".pm:use |.pm:require " | grep -v v5.6.0 | grep -v 5.00 | grep -v \$module | sed -e "s, \+, ,g" | cut -f1,2 -d" " | sed -e "s,;, ,g" | sed -e "s,(), ,g" | sed -e "s,::,-,g" | sort | uniq | tr [:upper:] [:lower:] | sed -e "s,/[^ ]\+ , += \"perl-module-,g" | sed -e "s, \?$, \",g" | sed -e "s,_,-,g" | sed -e "s,^,RDEPENDS_,g" | sed -e "s,armeb-linux,\$\{TARGET_ARCH\}-\$\{TARGET_OS\},g" | egrep -v "perl-module-5|perl-module-tk|perl-module-mac-internetconfig|perl-module-ndbm-file|perl-module-html-treebuilder|perl-module-lwp-simple|perl-module-vms-filespec|perl-module-fcgi|perl-module-vms-stdio|perl-module-mac-buildtools" > /home/slug/openembedded/packages/perl/perl-rdepends_5.8.7.inc
77 88
89# Some additional dependencies that the above doesn't manage to figure out
90DEPENDS_perl-module-math-bigint += "perl-module-math-bigint-calc "
91DEPENDS_perl-module-math-bigint-calc += "perl-module-integer "
92
78# Some packages changed names in 5.8.7-r14, RPROVIDE them 93# Some packages changed names in 5.8.7-r14, RPROVIDE them
79RPROVIDES_perl-module-b-asmdata = "perl-module-${TARGET_SYS}-b-asmdata" 94RPROVIDES_perl-module-b-asmdata = "perl-module-${TARGET_SYS}-b-asmdata"
80RPROVIDES_perl-module-b-assembler = "perl-module-${TARGET_SYS}-b-assembler" 95RPROVIDES_perl-module-b-assembler = "perl-module-${TARGET_SYS}-b-assembler"