diff options
Diffstat (limited to 'meta/packages/perl/perl-5.8.8')
-rw-r--r-- | meta/packages/perl/perl-5.8.8/Makefile.SH.patch | 4 | ||||
-rw-r--r-- | meta/packages/perl/perl-5.8.8/config.sh | 87 | ||||
-rw-r--r-- | meta/packages/perl/perl-5.8.8/native-perlinc.patch | 14 | ||||
-rw-r--r-- | meta/packages/perl/perl-5.8.8/native-ssp.patch | 2 |
4 files changed, 57 insertions, 50 deletions
diff --git a/meta/packages/perl/perl-5.8.8/Makefile.SH.patch b/meta/packages/perl/perl-5.8.8/Makefile.SH.patch index a30074be2b..ab9c4b7d63 100644 --- a/meta/packages/perl/perl-5.8.8/Makefile.SH.patch +++ b/meta/packages/perl/perl-5.8.8/Makefile.SH.patch | |||
@@ -62,7 +62,7 @@ Index: perl-5.8.8/Makefile.SH | |||
62 | +# @echo " "; | 62 | +# @echo " "; |
63 | +# @echo " Everything is up to date. Type '$(MAKE) test' to run test suite." | 63 | +# @echo " Everything is up to date. Type '$(MAKE) test' to run test suite." |
64 | + | 64 | + |
65 | +all: $(FIRSTMAKEFILE) miniperl$(EXE_EXT) | 65 | +all: $(FIRSTMAKEFILE) miniperl$(EXE_EXT) $(unidatafiles) |
66 | + | 66 | + |
67 | +more: extra.pods $(private) $(public) | 67 | +more: extra.pods $(private) $(public) |
68 | + | 68 | + |
@@ -208,7 +208,7 @@ Index: perl-5.8.8/Makefile.SH | |||
208 | - | 208 | - |
209 | -install.man: all installman | 209 | -install.man: all installman |
210 | - $(LDLIBPTH) ./perl installman --destdir=$(DESTDIR) $(INSTALLFLAGS) | 210 | - $(LDLIBPTH) ./perl installman --destdir=$(DESTDIR) $(INSTALLFLAGS) |
211 | + ./hostperl -Ifake_config_library -Ilib -MConfig installperl $(INSTALLFLAGS) $(STRIPFLAGS) | 211 | + ./hostperl -Ifake_config_library -Ilib -MConfig installperl --destdir=$(DESTDIR) $(INSTALLFLAGS) $(STRIPFLAGS) |
212 | 212 | ||
213 | # XXX Experimental. Hardwired values, but useful for testing. | 213 | # XXX Experimental. Hardwired values, but useful for testing. |
214 | # Eventually Configure could ask for some of these values. | 214 | # Eventually Configure could ask for some of these values. |
diff --git a/meta/packages/perl/perl-5.8.8/config.sh b/meta/packages/perl/perl-5.8.8/config.sh index ac8d237cac..8d1f904f20 100644 --- a/meta/packages/perl/perl-5.8.8/config.sh +++ b/meta/packages/perl/perl-5.8.8/config.sh | |||
@@ -668,34 +668,34 @@ inc_version_list=' ' | |||
668 | inc_version_list_init='0' | 668 | inc_version_list_init='0' |
669 | incpath='' | 669 | incpath='' |
670 | inews='' | 670 | inews='' |
671 | installarchlib='@DESTDIR@/usr/lib/perl/5.8' | 671 | installarchlib='@LIBDIR@/perl/5.8' |
672 | installbin='@DESTDIR@/usr/bin' | 672 | installbin='@BINDIR@' |
673 | installhtml1dir='' | 673 | installhtml1dir='' |
674 | installhtml3dir='' | 674 | installhtml3dir='' |
675 | installman1dir='@DESTDIR@/usr/share/man/man1' | 675 | installman1dir='@MANDIR@/man1' |
676 | installman3dir='@DESTDIR@/usr/share/man/man3' | 676 | installman3dir='@MANDIR@/man3' |
677 | installprefix='@DESTDIR@/usr' | 677 | installprefix='@PREFIX@' |
678 | installprefixexp='@DESTDIR@/usr' | 678 | installprefixexp='@PREFIX@/usr' |
679 | installprivlib='@DESTDIR@/usr/share/perl/5.8' | 679 | installprivlib='@DATADIR@/perl/5.8' |
680 | installscript='@DESTDIR@/usr/bin' | 680 | installscript='@BINDIR@' |
681 | installsitearch='@DESTDIR@/usr/local/lib/perl/5.8.8' | 681 | installsitearch='@PREFIX@/local/lib/perl/5.8.8' |
682 | installsitebin='@DESTDIR@/usr/local/bin' | 682 | installsitebin='@PREFIX@/local/bin' |
683 | installsitehtml1dir='' | 683 | installsitehtml1dir='' |
684 | installsitehtml3dir='' | 684 | installsitehtml3dir='' |
685 | installsitelib='@DESTDIR@/usr/local/share/perl/5.8.8' | 685 | installsitelib='@PREFIX@/local/share/perl/5.8.8' |
686 | installsiteman1dir='@DESTDIR@/usr/local/man/man1' | 686 | installsiteman1dir='@PREFIX@/local/man/man1' |
687 | installsiteman3dir='@DESTDIR@/usr/local/man/man3' | 687 | installsiteman3dir='@PREFIX@/local/man/man3' |
688 | installsitescript='@DESTDIR@/usr/local/bin' | 688 | installsitescript='@PREFIX@/local/bin' |
689 | installstyle='lib/perl5' | 689 | installstyle='lib/perl5' |
690 | installusrbinperl='define' | 690 | installusrbinperl='define' |
691 | installvendorarch='@DESTDIR@/usr/lib/perl5' | 691 | installvendorarch='@LIBDIR@/perl5' |
692 | installvendorbin='@DESTDIR@/usr/bin' | 692 | installvendorbin='@BINDIR@' |
693 | installvendorhtml1dir='' | 693 | installvendorhtml1dir='' |
694 | installvendorhtml3dir='' | 694 | installvendorhtml3dir='' |
695 | installvendorlib='@DESTDIR@/usr/share/perl5' | 695 | installvendorlib='@DATADIR@/perl5' |
696 | installvendorman1dir='@DESTDIR@/usr/share/man/man1' | 696 | installvendorman1dir='@MANDIR@/man1' |
697 | installvendorman3dir='@DESTDIR@/usr/share/man/man3' | 697 | installvendorman3dir='@MANDIR@/man3' |
698 | installvendorscript='@DESTDIR@/usr/bin' | 698 | installvendorscript='@BINDIR@' |
699 | intsize='4' | 699 | intsize='4' |
700 | issymlink='test -h' | 700 | issymlink='test -h' |
701 | ivdformat='"ld"' | 701 | ivdformat='"ld"' |
@@ -981,36 +981,35 @@ zcat='' | |||
981 | zip='zip' | 981 | zip='zip' |
982 | # Configure command line arguments. | 982 | # Configure command line arguments. |
983 | config_arg0='Configure' | 983 | config_arg0='Configure' |
984 | config_args='-des -Doptimize=-O2 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Open Embedded -Dinstallprefix=@DESTDIR@ -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr -Dotherlibdirs=/usr/lib/perl5/5.8.8 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Ud_dosuid -Dd_semctl_semun -Ui_db -Ui_ndbm -Ui_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr' | 984 | config_args='-des -Doptimize=-O2 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Open Embedded -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr -Dotherlibdirs=/usr/lib/perl5/5.8.8 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Ud_dosuid -Dd_semctl_semun -Ui_db -Ui_ndbm -Ui_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr' |
985 | config_argc=28 | 985 | config_argc=27 |
986 | config_arg1='-des' | 986 | config_arg1='-des' |
987 | config_arg2='-Doptimize=-O2' | 987 | config_arg2='-Doptimize=-O2' |
988 | config_arg3='-Dmyhostname=localhost' | 988 | config_arg3='-Dmyhostname=localhost' |
989 | config_arg4='-Dperladmin=root@localhost' | 989 | config_arg4='-Dperladmin=root@localhost' |
990 | config_arg5='-Dcc=gcc' | 990 | config_arg5='-Dcc=gcc' |
991 | config_arg6='-Dcf_by=Open Embedded' | 991 | config_arg6='-Dcf_by=Open Embedded' |
992 | config_arg7='-Dinstallprefix=@DESTDIR@' | 992 | config_arg7='-Dprefix=/usr' |
993 | config_arg8='-Dprefix=/usr' | 993 | config_arg8='-Dvendorprefix=/usr' |
994 | config_arg9='-Dvendorprefix=/usr' | 994 | config_arg9='-Dsiteprefix=/usr' |
995 | config_arg10='-Dsiteprefix=/usr' | 995 | config_arg10='-Dotherlibdirs=/usr/lib/perl5/5.8.8' |
996 | config_arg11='-Dotherlibdirs=/usr/lib/perl5/5.8.8' | 996 | config_arg11='-Duseshrplib' |
997 | config_arg12='-Duseshrplib' | 997 | config_arg12='-Dusethreads' |
998 | config_arg13='-Dusethreads' | 998 | config_arg13='-Duseithreads' |
999 | config_arg14='-Duseithreads' | 999 | config_arg14='-Duselargefiles' |
1000 | config_arg15='-Duselargefiles' | 1000 | config_arg15='-Ud_dosuid' |
1001 | config_arg16='-Ud_dosuid' | 1001 | config_arg16='-Dd_semctl_semun' |
1002 | config_arg17='-Dd_semctl_semun' | 1002 | config_arg17='-Ui_db' |
1003 | config_arg18='-Ui_db' | 1003 | config_arg18='-Ui_ndbm' |
1004 | config_arg19='-Ui_ndbm' | 1004 | config_arg19='-Ui_gdbm' |
1005 | config_arg20='-Ui_gdbm' | 1005 | config_arg20='-Di_shadow' |
1006 | config_arg21='-Di_shadow' | 1006 | config_arg21='-Di_syslog' |
1007 | config_arg22='-Di_syslog' | 1007 | config_arg22='-Dman3ext=3pm' |
1008 | config_arg23='-Dman3ext=3pm' | 1008 | config_arg23='-Duseperlio' |
1009 | config_arg24='-Duseperlio' | 1009 | config_arg24='-Dinstallusrbinperl' |
1010 | config_arg25='-Dinstallusrbinperl' | 1010 | config_arg25='-Ubincompat5005' |
1011 | config_arg26='-Ubincompat5005' | 1011 | config_arg26='-Uversiononly' |
1012 | config_arg27='-Uversiononly' | 1012 | config_arg27='-Dpager=/usr/bin/less -isr' |
1013 | config_arg28='-Dpager=/usr/bin/less -isr' | ||
1014 | PERL_REVISION=5 | 1013 | PERL_REVISION=5 |
1015 | PERL_VERSION=8 | 1014 | PERL_VERSION=8 |
1016 | PERL_SUBVERSION=8 | 1015 | PERL_SUBVERSION=8 |
diff --git a/meta/packages/perl/perl-5.8.8/native-perlinc.patch b/meta/packages/perl/perl-5.8.8/native-perlinc.patch index aea38a0b56..6dc4b9538d 100644 --- a/meta/packages/perl/perl-5.8.8/native-perlinc.patch +++ b/meta/packages/perl/perl-5.8.8/native-perlinc.patch | |||
@@ -1,12 +1,20 @@ | |||
1 | Index: perl-5.8.8/lib/ExtUtils/MM_Unix.pm | 1 | Index: perl-5.8.8/lib/ExtUtils/MM_Unix.pm |
2 | =================================================================== | 2 | =================================================================== |
3 | --- perl-5.8.8.orig/lib/ExtUtils/MM_Unix.pm 2007-05-30 15:16:47.000000000 +1000 | 3 | --- perl-5.8.8.orig/lib/ExtUtils/MM_Unix.pm 2008-10-31 22:01:35.000000000 +0000 |
4 | +++ perl-5.8.8/lib/ExtUtils/MM_Unix.pm 2007-05-30 15:18:12.000000000 +1000 | 4 | +++ perl-5.8.8/lib/ExtUtils/MM_Unix.pm 2008-11-08 16:01:12.000000000 +0000 |
5 | @@ -1597,6 +1597,11 @@ | 5 | @@ -1597,6 +1597,19 @@ |
6 | $self->{PERL_LIB} ||= $Config{privlibexp}; | 6 | $self->{PERL_LIB} ||= $Config{privlibexp}; |
7 | $self->{PERL_ARCHLIB} ||= $Config{archlibexp}; | 7 | $self->{PERL_ARCHLIB} ||= $Config{archlibexp}; |
8 | $self->{PERL_INC} = $self->catdir("$self->{PERL_ARCHLIB}","CORE"); # wild guess for now | 8 | $self->{PERL_INC} = $self->catdir("$self->{PERL_ARCHLIB}","CORE"); # wild guess for now |
9 | + # Check for environment override so we'll find the headers in the correct place | 9 | + # Check for environment override so we'll find the headers in the correct place |
10 | + if (defined $ENV{PERL_LIB}) | ||
11 | + { | ||
12 | + $self->{PERL_LIB} = $ENV{PERL_LIB}; | ||
13 | + } | ||
14 | + if (defined $ENV{PERL_ARCHLIB}) | ||
15 | + { | ||
16 | + $self->{PERL_ARCHLIB} = $ENV{PERL_ARCHLIB}; | ||
17 | + } | ||
10 | + if (defined $ENV{PERL_INC}) | 18 | + if (defined $ENV{PERL_INC}) |
11 | + { | 19 | + { |
12 | + $self->{PERL_INC} = $ENV{PERL_INC}; | 20 | + $self->{PERL_INC} = $ENV{PERL_INC}; |
diff --git a/meta/packages/perl/perl-5.8.8/native-ssp.patch b/meta/packages/perl/perl-5.8.8/native-ssp.patch index f815aad452..1c825f50d0 100644 --- a/meta/packages/perl/perl-5.8.8/native-ssp.patch +++ b/meta/packages/perl/perl-5.8.8/native-ssp.patch | |||
@@ -1,5 +1,5 @@ | |||
1 | Fix for compiling with ssp enabled gcc: | 1 | Fix for compiling with ssp enabled gcc: |
2 | See http://bugs.openembedded.org/show_bug.cgi?id=1980 | 2 | See http://bugs.openembedded.net/show_bug.cgi?id=1980 |
3 | 3 | ||
4 | diff -Naur perl-5.8.7.orig/cflags.SH perl-5.8.7/cflags.SH | 4 | diff -Naur perl-5.8.7.orig/cflags.SH perl-5.8.7/cflags.SH |
5 | --- perl-5.8.7.orig/cflags.SH 2002-09-30 10:59:07.000000000 +0000 | 5 | --- perl-5.8.7.orig/cflags.SH 2002-09-30 10:59:07.000000000 +0000 |