summaryrefslogtreecommitdiffstats
path: root/meta/packages/pcmciautils/pcmciautils_013.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pcmciautils/pcmciautils_013.bb')
-rw-r--r--meta/packages/pcmciautils/pcmciautils_013.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils_013.bb b/meta/packages/pcmciautils/pcmciautils_013.bb
new file mode 100644
index 0000000000..3dde683012
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils_013.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
2DEPENDS = "sysfsutils udev module-init-tools"
3RDEPENDS = "udev module-init-tools"
4HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
5SECTION = "kernel/userland"
6PRIORITY = "optional"
7
8SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2 \
9 file://makefile_fix.patch;patch=1 \
10 file://version_workaround.patch;patch=1"
11S = "${WORKDIR}/pcmciautils-${PV}"
12
13PR = "r0"
14
15export HOSTCC = "${BUILD_CC}"
16export etcdir = "${sysconfdir}"
17export sbindir = "${base_sbindir}"
18export pcmciaconfdir = "${sysconfdir}/pcmcia"
19export udevrulesdir = "${sysconfdir}/udev/rules.d"
20export UDEV = 1
21LD = "${CC}"
22CFLAGS =+ "-I${S}/src"
23CFLAGS =+ '-DPCMCIAUTILS_VERSION=013'
24
25PARALLEL_MAKE = ""
26EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
27
28do_install () {
29 oe_runmake 'DESTDIR=${D}' install
30}
31
32CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
33RCONFLICTS_${PN} += "pcmcia-cs"