summaryrefslogtreecommitdiffstats
path: root/meta/packages/pcmciautils/pcmciautils_010.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pcmciautils/pcmciautils_010.bb')
-rw-r--r--meta/packages/pcmciautils/pcmciautils_010.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils_010.bb b/meta/packages/pcmciautils/pcmciautils_010.bb
new file mode 100644
index 0000000000..8045a0e442
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils_010.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
2DEPENDS = "sysfsutils udev module-init-tools"
3RDEPENDS = "udev module-init-tools"
4HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
5SECTION = "kernel/userland"
6PRIORITY = "optional"
7
8SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2"
9S = "${WORKDIR}/pcmciautils-${PV}"
10
11PR = "r3"
12
13export HOSTCC = "${BUILD_CC}"
14export etcdir = "${sysconfdir}"
15export sbindir = "${base_sbindir}"
16export pcmciaconfdir = "${sysconfdir}/pcmcia"
17export udevrulesdir = "${sysconfdir}/udev/rules.d"
18export UDEV = 1
19LD = "${CC}"
20CFLAGS =+ "-I${S}/src"
21CFLAGS =+ '-DPCMCIAUTILS_VERSION=010'
22
23PARALLEL_MAKE = ""
24EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
25
26do_install () {
27 oe_runmake 'DESTDIR=${D}' install
28}
29
30CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
31RCONFLICTS_${PN} += "pcmcia-cs"